rejetto forum

I got stucked ... :(

Guest · 9 · 9095

0 Members and 1 Guest are viewing this topic.


  • Guest
Hello everyone,

I use HFS from time to time for several years now and I never had a problem with it.

But things change ...

I added a file but the page to download the file, won't be accessible, no matter what I tried.
I am not behind a router, just a cable modem.
Also "Open Port Check Tool" said, that it can see me on Port 80, all green.
"Self Test" in HFS failed: Server did not answer, you might be behind a firewall, ensure nothing is blocking HFS.

OK, then I disabled windows firewall with "Windows Firewall Control - Mode: Enable all" and also disabled my antivirus completely to check again. Result: the same. My friend can't see my page too.

I tried all possible settings in HFS, nothing helped.

What the heck is going on here ?  :o

Anyone with an idea to make HFS to start working again ?


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 911
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
is HFS added to the windows firewall(your software firewall), If unsure, temp disable windows firewall and try to access the page causing trouble...

(since you made changes, i would recommended downloading a fresh copy and re-add the files) Just to make sure htere isn't a setting you changed trying to fix it that can now be a new problem...

Screen shot would be nice

Also, could easily be access to folder/file permission and or the file location -- file name...

need a bit more info to help you :(
Files I have snagged and share can be found on my google drive:

Offline LeoNeeson

  • Tireless poster
  • ****
    • Posts: 843
  • Status: On hiatus (sporadically here)
    • View Profile
Hi there,

What about using another port (instead of port 80)?
Did you try port 8080, o 8090 or any other port?...
(May be your system is already using your port 80)

HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
» Currently taking a break, until HFS v2.4 get his stable version.

Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13517
    • View Profile
does the address you are giving to your friend start with "84." ?
and, as other people said, post screenshot and try other ports.


  • Guest
Thanks everyone for your suggestions,

I answer indvidually to each of you.

You have to know, that unfortunately I just have sometimes the possibility to check HFS with a friend - generally I use the "Self Test" here, to find out, if HFS is working for me.

Also I have to say, that I use PeerBlock, but for all this tests, I disabled it too.


Yes, HFS is added to windows firewall (I set it to access enabled). I control windows firewall with WindowsFirewall Control, a tiny program, witch is just a better way to change windows firewall settings.

When I did my tests, I tried to disable firewall and antivirus completely, but nothing helped.

Also I re-added the files and the file(s) are just normal files without any special permissions and also in a free accessible location in the file-structure of windows (no folder in programs for example).


Yes, I tried with 8090 as well (I will upload screenshot too), but nothing changed. Port 80 is always open for my browser, other ports normally closed, but for testing I opened all.


The adress I gave to my fried some days ago was exactly the adress, I could see in the row on top of HFS "Open in browser:"
In the -PAST- I always gave that adress with immediately success.

I personally think, that only verifying of internal HFS Logs can maybe tell the reason, why HFS can't connect to the net.
All internet-access related programs are disabled for testings HFS without success, therefore I maybe need to deinstall them, to see, if that helps.


  • Guest
... also I have to say, that I tried all settings of HFS in menu "IP adress", nothing helped.

After I selected a file in HFS and chose Self Test, HFS will write in the log "New external address: 176.XXX.XXX.XX via"

(I x-ed out the numbers, cause I don't want to make my IP public)

Also with the same adress in the top row of HFS "Open in browser" http://176.XXX.XXX.XX:8080/Examplefile.jpg, Self Test does not work successfully.

Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13517
    • View Profile
yes, 176 is your external number, thus the correct one to give to whoever is outside of your local network (over the internet).
As an administrator of the forum i can see your IP (of when you posted), and tried to access your server but to no avail. You probably shut it down.

The self test in this case is not reliable, as it can give false negatives (never false positives anyway).

Do you confirm it works good locally, when you try to access HFS yourself?

Consider anyway that if nothing changed on your side, possibly is your internet provider who changed something. Not every ISP allow people to have servers on their connections. You should double check this for your case, by googling for the information, or trying with a different server software.


  • Guest
Hello Rejetto,

now I let HFS running all day long ... you can try to access.

Yes, I can confirm, that I am able to see my page without problems on my own PC.

I will check later today, if maybe it's the fault of my provider, I will let you

know later.

Thank you very much for the moment, I will let you know later today or tomorrow, what's the situation with my ISP. Try to see my HFS page on the net please ...


  • Guest
Resolved !

bmartino1 said it before, but I didn't got the point completely  ::)

I ran HFS from my program-folder, that was the problem. Even when I give HFS admin-rights, it can't work from within the program-folder of Windows 7 X64 to my surprise.

OK, thanks everyone for help !  :)