rejetto forum

Can't connect with telnet

Guest · 4 · 9885

0 Members and 1 Guest are viewing this topic.


  • Guest
When I connect to the server through telnet, it disconnects after the first line without reply.

For example:

telnet 80
GET / HTTP/1.1

I've tried this both locally and remotely, with OS X and XP. I can connect with any browser, and can also telnet to other web servers. I'm confused. Anyone know what may be wrong? Using build 217.

Offline Mars

  • Operator
  • Tireless poster
  • *****
    • Posts: 2059
    • View Profile
you can only connect to hfs via a http browser, not by telnet or by ftp


Offline kyle faucett

  • Occasional poster
  • *
    • Posts: 1
    • View Profile
I'm the original poster.

HTTP is just an application layer protocol, so as long as what you type follows the protocol, you can use it in telnet. For example, if you type:

telnet 80
(wait for connection)
GET / HTTP/1.1 (newline)

you should see the source code of google's home page. I think the 1.1 standard calls for a Host:... line after the GET... line, but google doesn't seem to care.

Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13510
    • View Profile
hi kyle!
this problem was introduced in the last 2-3 months, because sometimes i use telnet to test hfs.
it will be solved in next build.