rejetto forum

Max Contemp Download reached

Guest · 8 · 6276

0 Members and 1 Guest are viewing this topic.

bruce

  • Guest
When 2 people are trying to download the same file, the 2nd person would get this message...

No more downloads allowed

You have reached the limit of maximum contemporary downloads.

Is there a way to allow multiple download of the same file?

thanks.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13308
    • View Profile
by default, no limit is set.
you (or someone) accidentally set that limit.
menu -> limits -> max simultaneous downloads


bruce

  • Guest
2 people can download different files at the same time, but not the same file..

i checked the limit settings, but they are all disabled..

I am also using stunnel as well, although i turned it off and tested with just http... got the same result..


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13308
    • View Profile
try
menu -> debug -> temporarily reset options
and see if the problem persists


i just tried to download the same file from 2 different computers, and had no problem at all.


bruce

  • Guest
I dont see the debug section.. but I am using 2.2d

I also attached a picture of the limits setting.


bruce

  • Guest
Also,

I have access restricted too. However, 2 different accounts or same account downloading the same file give me the same message..


bryce

  • Guest
i think i found out why this is happening...

Since I am using the stunnel, HFS sees the connection all from same IP, which is 127.0.0.1, since it considered the download from same origin, thus only allow 1 download of the same file at the same time. Even though the connection actually originated from different IPs.

I checked this by using the using h t t p : / / hostname:8080 on different computers and download the same file, I was able to do so... however if I open the same address from the same computer using 2 browsers (IE and firefox), then i can only download 1 at a time, the other browser tells me max download reached.

I got around this by turning off "prevent leeching (download accelerator)"

Thanks for the help, this is a great software.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13308
    • View Profile
I am also using stunnel as well, although i turned it off and tested with just http... got the same result..

this sentence led me totally wrong ;)
thanks for sharing the solution anyway
all is well...