rejetto forum

Both Beta 261 and 162 will only accept 8080 as the port

Guest · 13 · 2358

0 Members and 1 Guest are viewing this topic.

Robert.H.Weinstein

  • Guest
Both Beta 261 and 162 are defaulting to port 8080

When I attempt to use port 80  a message is generated stating that HFS is already using it?

???

Worked ok with 260

see attachment


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13427
    • View Profile
welcome!
that's strange, please restart your computer.
you may have an hanged process running.
« Last Edit: July 13, 2010, 03:50:09 PM by rejetto »


Offline Mars

  • Operator
  • Tireless poster
  • *****
    • Posts: 2048
    • View Profile
how many instance of hfs are you running at the same time?

when the error appear, hit keys  CTRL-ALT-DEL and count number of hfs's proccess .


Robert.H.Weinstein

  • Guest
Unfortunately it is a no go , once instance only

I have no other service using port 80????

IT worked unitl 261 came out

attached are more photos


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13427
    • View Profile
bizarre.
could you please run #260 right now and see if the problem is still there?


Robert.H.Weinstein

  • Guest
I think I may have found out the issue, possibly

I was using all 4 gigs of memory (Phenom II X quad core)

An turned off Page files,

I just set the c drive to let the System manage page files once again and presto

I will turn off all paging and try the memory only once again to test this theory.

If the issue reooccurs then it may have something to do with the way the application is handled
when everything goes to memory without a paging file,

Why don't you try it out yourself and see if you can duplicate the 8080 issue.

IE  if you use the normal file paging then 80 is the port of choice but

If you run everything in memory then HFS somehow sees itself using port 80 and forces the
HFS to use 8080

Hmmm ???

RObert


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13427
    • View Profile
i worked for a long time without paging file, never had that problem.
i suggested you a much quicker test.


Robert.H.Weinstein

  • Guest
I tried  SAVE OPTIONS .... Clear Options and quit

That appears to have fixed it??

Can there be an OPTION that influences the port 8080 / port 80 issue?

Oh yes you have 16 more Euros.

Robert H Weinstein


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13427
    • View Profile
The port is actually an option, even if it deserves a special place in the GUI.
It's hard to say if the problem was actually caused by an option.
To be honest, i don't think so, or otherwise i would have suggested to click "temporarily reset options".
Unless the problem reappears, we may never know what the problem was.

Yes, i easily understood you was the one, since the name is the same :) thanks again


Robert.H.Weinstein

  • Guest
I do not like mysterys,

I am attempting to rule other other possibilities

I ruled out IIS (port 80) I would expect to see 8080 as the startup default. OK

I am wondering if the Memory Management of Windows 7 may be the issue?

If it (Windows 7) does not reflect the release of port 80 and HFS as the user of Port 80 then the error message
stipulating that HFS is using port 80 would actually be correct (even though the GUI is at that time reflecting 8080)

I also use Sleep mode and Hibernate more often than I used to. (Windows 7 handles the power options differently than previous versions of th OS)

I am going to test out whether one of those features is playing a role?

I will chat with my Network associate at work on this?

Let you know. When I can replicate consistantly that issue.

Robert  


Robert.H.Weinstein

  • Guest
Test using 262

In the context of the specifications below:


Goal:

   Replicate the symptom where as HFS is using port 8080
   Attempting to reset HFS port to 80, HFS reflects an error message that
             HFS is already using port 80


            For this test I added a test for SQL Server which was not installed when
            HFS first reflected the aforementioned issue

            SQL Server by default will consume port 80.

            This gives me an application that will compete with HFS for Port 80



Test 1:


   Installed SQL Server 2008 Data Center (Defaults to Port 80).

   Tested HFS an it defaulted to 8080 as expected.

   Disabled SQL Server.

   Attempted to reset the HFS port to 80.

   HFS still recognized 80 as being used by another applicaton (not itself).

            ??? Memory does not release port 80 ???

   System rebooted.

   HFS uses Port 80.



Test 2:

   SQL Server is disabled (Not active since previous boot).

   Paging set to "No Pageing File" on my Boot HD  ie drive C:

   System rebooted.

   HFS executed and uses Port 80.

   System put to sleep.

   System awakened.

   HFS still using Port 80.

   System hibernated.

   System awakened from hibernation.

   HFS still using Port 80.



Conclusion:


   Could not duplicate the issue (HFS seeing itself as already using port 80)
             I am suspect it may have something to do with Windows 7 managment of port allocation.




OS Name         Microsoft Windows 7 Ultimate

Version         6.1.7600 Build 7600

System Manufacturer   Gigabyte Technology Co., Ltd.

System Model      GA-MA785GMT-UD2H

System Type      x64-based PC

Processor      AMD Phenom(tm) II X4 965 Processor, 3400 Mhz,
                                4 Core(s), 4 Logical Processor(s)

BIOS Version/Date Award Software International, Inc. F9, 5/25/2010
SMBIOS Version   2.4

Installed Physical Memory (RAM)   4.00 GB

Total Physical Memory      3.50 GB

Available Physical Memory                2.24 GB

Total Virtual Memory      8.74 GB

Available Virtual Memory                6.63 GB


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13427
    • View Profile
i will read you asap.
in the while i want to say that i found a bug that causes to report erroneously "used by hfs.exe" while it's actually a different program.
fixed in next release #263


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13427
    • View Profile
I'll tell you more.
After the fix, HFS will not be able to tell you the name of the program using the port, because it's running with different user (it's a service, while HFS is not).
That's normal (since Vista at least), my method for reading fails in this situation.
There may be a different method (from pid to exe file) without this defect, any programmer is welcome at submitting a better function of course.

About your last message, I tried to reproduce your not-using-80-until-reboot, but with no success:
- have apache started on port 80
- start hfs, automatically listens on 8080
- i stop apache service
- click on hfs port, click OK with no number inputed (meaning autodetect)
- hfs switches to port 80


my page file is enabled, but i doubt this is affecting in any way (except performance and memory availability).