rejetto forum

Forwarded ports but still no success accessing externally

Guest · 9 · 12280

0 Members and 1 Guest are viewing this topic.


  • Guest
I'm using HFS v2.0 beta32 (did have beta27 and that had same problems)
D-link DSL-G604T router
Norton Internet Security 2005
Windows XP (Firewall disabled)
Port 8080

I can access my HFS site no problem over my LAN (via my PSP or laptop) but not over the internet.

I've forwarded port 8080 TCP and UDP in my router.
Set Norton's firewall to permit port 8080.

The HFS self test comes back successful but still every time I try to browse to my page (currently if anyone else cares to try it) it comes up with the standard 'Page cannot be displayed' stuff.

I've also tried port 81 with the same results.
When I use port 80 all I can get externally is my router's configuration page (hence the need to use a different port).

I've been playing around with this all night and I've read countless forums but nothing seems to make it work so any help would be greatly appreciated. My technical prowess is somewhat limited so simple explanations a big help.

Many thanks.

Mike Hunt

  • Guest
Quote from: "Moonfleet"
if anyone else cares to try it) it comes up with the standard 'Page cannot be displayed
Well, I can get in to your login page.  Here it is.

Doesn't work with port 8080 but does work with port 80.  You have a port configuration error somewhere.  What port are you using in HFS?


Mike Hunt

  • Guest
That might be your router login page.  Don't know for sure.  Anyway, you have a port configuration error somewhere.


Mike Hunt

  • Guest
Are you sure Norton Internet Security (your firewall) isn't blocking that traffic?

Does it work if you Turn off the firewall?

Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13516
    • View Profile
it is WORKING.
HFS replied me.
you can't browse your own server by using that address because the router only forwards external connections.
that's all.

to know when it works, use the self test
if it is not enough for you, you can use an external proxy or an anonymizer service, or ask a friend


  • Guest
Thank you Mike and Rejetto for your replies.

Mike, that is my router page. HFS is set to port 8080 and that's what I've forwarded in my router. If I completely disable Norton it still won't work.

Rejetto, so am I right in presuming that would explain why my PSP won't access it too (as it's still going through the router)... So it should work from another access point.. Fingers crossed. But why could you access my site but Mike couldn't (on port 8080)?

I've tried and typed in and it says access to port 8080 not supported. I don't know anything about external proxys or anonymizers so perhaps I'm not using it right.

It would be good to be able to test that the PSP will access HFS over the internet.

Thank you both for your help.

Offline ~GeeS~

  • Tireless poster
  • ****
    • Posts: 269
  • "The web was made for sharing..."
    • View Profile
Your site is working and protected by a password.
I had the same problem. In first instance I had a sitecom router, which allowed me to test the external adress. When I switched to a speedtouch it took me some days to find out that the speedtouch blocked the external request with its build in firewall. So some routers do some dont.
Wiyh guardster you cant surf to IP with port other than 80. So if you want to test yourself, change your server port to 80. Than guardster will work.


  • Guest
That makes it all clear now! Thank you very much. At least I know it's working.

Offline SiY11

  • Occasional poster
  • *
    • Posts: 73
    • View Profile
When I am inside my network with my PSP I use my routers assigned IP (http://HTTP:// and I can use my network. When I am over the internet I use me http://HTTP:// to connect to my server.