rejetto forum

Testing build #236

rejetto · 17 · 7616

0 Members and 1 Guest are viewing this topic.

Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13354
    • View Profile
autoupdate will work on this build tomorrow.
too much changes in this build. :)

download @ www.dovedove.it/hfs/hfs236.exe

what's new
+ address masks support form 1.2.3.4/5 http://en.wikipedia.org/wiki/CIDR#CIDR_blocks
+ Log menu -> Log what -> Deletions
+ {.delete|XXX|forced=1.}
+ {.save|XXX|var=YYY.}
+ {.section|XXX|back=YYY.}
+ {.breacrumbs|XXX|from=YYY.}
+ new template macros: cache, regexp
+ %item-type% in [file] [folder] [link]
+ breadcrumbs in search result
- sometimes a white blank icon near "open in browser"
- could not delete folders over junctions [link]
- it was not possible to empty a [section] with diff templates
- {.set table.} was not working at first time for multilines values
- {.section.} didn't work in most event scripts  
- event [start] was not working
« Last Edit: April 28, 2009, 02:02:18 AM by rejetto »


Offline maverick

  • Tireless poster
  • ****
    • Posts: 1052
  • Computer Solutions
    • View Profile
I'm having troubles with this build.  Tested with my custom template as well as the default template.  Both have same results.

The problem is with all folders/sub-folders in the vfs that have a diff template (properties -> diff template).  No output, just a white screen.
maverick


Offline SilentPliz

  • Operator
  • Tireless poster
  • *****
    • Posts: 1298
  • ....... chut ! shh!
    • View Profile
You would not have messages in the log, indicating some macros deprecated?
There are some changes had the side of macros.

My "diff tpl" are fully fonctionnals.
« Last Edit: April 28, 2009, 03:17:53 PM by SilentPliz »


Offline r][m

  • Tireless poster
  • ****
    • Posts: 347
    • View Profile
I never used the macros that were deprecated.
I agree with Maverick.
My external diff tpl aren't working correctly in 236. When you click
on the menu the browser never completely loads the page. Sometimes after
several attempts the page will appear. I'm back to 235. It works.

Edit
I may have found my diff tpl problem. Be a few hours before I'm sure.
I had added some code, and when I removed it, things are back to
normal on 236.
« Last Edit: April 29, 2009, 02:16:26 PM by r][m »


Offline maverick

  • Tireless poster
  • ****
    • Posts: 1052
  • Computer Solutions
    • View Profile
I made no changes here other than load the new build 236.  Doesn't work right with diff templates.

Went back to build 235 and everything is fine.
maverick


Offline SilentPliz

  • Operator
  • Tireless poster
  • *****
    • Posts: 1298
  • ....... chut ! shh!
    • View Profile
       
It was an idea ... That perhaps be something else.
I have had a problem with this style of syntax:

old syntax:

{.section|admin group|admins.txt.}

Solved with this syntax:

New syntax:

{.section|admin group|file=admins.txt.}
« Last Edit: April 28, 2009, 04:18:35 PM by SilentPliz »


Offline SilentPliz

  • Operator
  • Tireless poster
  • *****
    • Posts: 1298
  • ....... chut ! shh!
    • View Profile
   
Ok! I understand. I do not use the log as acute as yours ... I do not use third-party program to analyze logs. Thus, if your proposal facilitates your life ;)... I have nothing against.

   
I will learn to read long horizontal lists   :)
« Last Edit: April 28, 2009, 05:38:36 PM by SilentPliz »


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13354
    • View Profile

Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13354
    • View Profile
i cannot reproduce the diff template problem.
could you please tell me what's inside your diff templates, and if they are in files or in the folder properties ?


Offline SilentPliz

  • Operator
  • Tireless poster
  • *****
    • Posts: 1298
  • ....... chut ! shh!
    • View Profile
I never used the macros that were deprecated.
I agree with Maverick.
My external diff tpl aren't working correctly in 236. When you click
on the menu the browser never completely loads the page. Sometimes after
several attempts the page will appear. I'm back to 235. It works.

Edit
I may have found my diff tpl problem. Be a few hours before I'm sure.
I had added some code, and when I removed it, things are back to
normal on 236.


It is hoped to have good news of Maverick. ;)


i cannot reproduce the diff template problem.
could you please tell me what's inside your diff templates, and if they are in files or in the folder properties ?

I have some diff tpl of two kinds (files and folder properties) ... and I have not had the problems mentioned above.
« Last Edit: April 29, 2009, 04:07:00 PM by SilentPliz »


Offline maverick

  • Tireless poster
  • ****
    • Posts: 1052
  • Computer Solutions
    • View Profile
i cannot reproduce the diff template problem.
could you please tell me what's inside your diff templates, and if they are in files or in the folder properties ?

1. virtual & real folders
2. no macros
3. file, files, & folder sections 
4. symbols
« Last Edit: May 01, 2009, 03:34:00 AM by maverick »
maverick


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13354
    • View Profile
maverick, can you simply send me your diff template and tell me where to put it?
or you could send a VFS containing it.
it may save hours.
support@rejetto.com
« Last Edit: April 29, 2009, 10:15:54 PM by rejetto »


Offline maverick

  • Tireless poster
  • ****
    • Posts: 1052
  • Computer Solutions
    • View Profile

Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13354
    • View Profile
Ok, finally i found how to fix it.
I would rather now publish #237 as #236 would have never existed. ::)
and a big thankyou goes to you, the ones who follow the project and test, because it's an important part of it.
it would be impossible for me to reproduce every possible test case at every build.

r][m post moved to http://www.rejetto.com/forum/index.php?topic=6904.0
« Last Edit: April 30, 2009, 10:39:25 AM by rejetto »


Offline maverick

  • Tireless poster
  • ****
    • Posts: 1052
  • Computer Solutions
    • View Profile
You are very welcome rejetto.  I'm happy that I was able to help and that you were able to fix the problem.  :)

« Last Edit: April 30, 2009, 07:41:16 PM by maverick »
maverick