rejetto forum

A problem when I attemp to login.

0 Members and 1 Guest are viewing this topic.

Offline dragon_ex

  • Occasional poster
  • *
    • Posts: 58
    • View Profile
When I attemped to login with the account I had created in hfs, a issue happened just when I finished filling the blank of "User name" and the "Password" and press "OK" ,  button, as shown below.


Offline dragon_ex

  • Occasional poster
  • *
    • Posts: 58
    • View Profile
Webpage resumed after I clicked "forward" and "backward" of IE a few times with no rule.
I think there must be something wrong in the interaction between clinet IE and HFS.

« Last Edit: September 17, 2010, 06:03:35 AM by dragon_ex »


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13438
    • View Profile

Offline dragon_ex

  • Occasional poster
  • *
    • Posts: 58
    • View Profile
can you test with a different browser?
I have tested this problem under IE and Opera,and I am confirmed in the existance of the problem.
That is, when I switch into a directory named in chinese characters firstly, and then,login will be failed.

But,When I stay in the home page of hfs website or switch into a directory named in english letters or numbers firstly , then login won't be failed.
Fiddle captured codes below when I try to log in.

#2
Code: [Select]
GET http://10.0.255.5:8888/%EF%BF%BD%EF%BF%BD%EF%BF%BD%EF%BF%BD-%EF%BF%BD%EF%BF%BD%CA%B1%EF%BF%BD%EF%BF%BD%EF%BF%BD%EF%BF%BD%EF%BF%BD%C4%BC%EF%BF%BD%EF%BF%BD%EF%BF%BD/ HTTP/1.1
Accept: image/gif, image/jpeg, image/pjpeg, image/pjpeg, application/x-shockwave-flash, application/x-ms-application, application/x-ms-xbap, application/vnd.ms-xpsdocument, application/xaml+xml, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*
Referer: http://10.0.255.5:8888/%E5%85%B1%E4%BA%AB-%E4%B8%B4%E6%97%B6%E5%85%B1%E4%BA%AB%E6%96%87%E4%BB%B6%E5%A4%B9/
Accept-Language: zh-cn
User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; WOW64; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.1)
Accept-Encoding: gzip, deflate
Connection: Keep-Alive
Host: 10.0.255.5:8888


#1
Code: [Select]
GET http://10.0.255.5:8888/%E5%85%B1%E4%BA%AB-%E4%B8%B4%E6%97%B6%E5%85%B1%E4%BA%AB%E6%96%87%E4%BB%B6%E5%A4%B9/~login HTTP/1.1
Accept: image/gif, image/jpeg, image/pjpeg, image/pjpeg, application/x-shockwave-flash, application/x-ms-application, application/x-ms-xbap, application/vnd.ms-xpsdocument, application/xaml+xml, application/vnd.ms-excel, application/vnd.ms-powerpoint, application/msword, */*
Referer: http://10.0.255.5:8888/%E5%85%B1%E4%BA%AB-%E4%B8%B4%E6%97%B6%E5%85%B1%E4%BA%AB%E6%96%87%E4%BB%B6%E5%A4%B9/
Accept-Language: zh-cn
User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; WOW64; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.1)
Accept-Encoding: gzip, deflate
Authorization: Basic YWRtaW5pc3RyYXRvcjohMjM0NTZhYmM=
Connection: Keep-Alive
Host: 10.0.255.5:8888

« Last Edit: October 15, 2010, 08:10:02 AM by dragon_ex »