rejetto forum

build 165 bug report

Mars · 9 · 3362

0 Members and 1 Guest are viewing this topic.

Offline Mars

  • Operator
  • Tireless poster
  • *****
    • Posts: 2053
    • View Profile
petit bug détecté dans le default template par silentpliz et contourné comme suit:
le résultat est une mauvaise interprétation des caractères accentués en 'comment' .
remplacer :

Quote
{{if| %folder-item-comment% | <div id=foldercomment>%folder-item-comment%</div> }}

par

Quote
{{if| %folder-item-comment% | %folder-comment%  /if}}

et ajouter la section

Quote
[folder-comment]
<div id=foldercomment>%item-comment%</div>
« Last Edit: December 29, 2007, 12:55:47 AM by mars »


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13438
    • View Profile
%folder-item-comment% was introduced to allow people to not use section [folder-comment].
indeed, %folder-comment% always worked.


Offline Mars

  • Operator
  • Tireless poster
  • *****
    • Posts: 2053
    • View Profile
%folder-item-comment% n'accepte pas les caractères accentués dans les comments

Quote
comment:=foldergetDynamicComment();
addArray(result, [
  '%folder-item-comment%', optUTF8(tpl, comment)
]);
if comment > '' then comment:=xtpl(tpl['folder-comment'], [
  '%item-comment%', comment
]);

il semble que l'interprétation du code html n'est pas la même pour les deux éléments
« Last Edit: December 29, 2007, 12:47:01 AM by mars »


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13438
    • View Profile
%folder-item-comment% n'accepte pas les caractères accentués dans les comments

i made a quick test and it worked.
can you tell me report me the comment you tried?

Quote
il semble que l'interprétation du code html n'est pas la même pour les deux éléments

on the other optUTF8() is just called later, on variable comment.


Offline Mars

  • Operator
  • Tireless poster
  • *****
    • Posts: 2053
    • View Profile
hfs build 165 template par défaut

usage interne sans  modification de

<div id=body>
  {{if| %folder-item-comment% | <div id=foldercomment>%folder-item-comment% </div> }}

sous répertoire 'rejetto'
comment = il s'est arrêté de travailler, quand il a remarqué que les lettres accentuées n'étaient pas correctement affichées

l'affichage par %item-comment%   est correct [Image1.bmp]  par la section [folder]

l'affichage par %folder-item-comment% est bugué [Image2.bmp]


Offline bacter

  • Operator
  • Tireless poster
  • *****
    • Posts: 681
    • View Profile
as you use different styles to display the comment, it looks like if the charset of the typeface used in the bad print lacks of definition of the special chars. Try changing the typeface and/or view in different browser to check.
your computer has no brain - use your own !


Offline Mars

  • Operator
  • Tireless poster
  • *****
    • Posts: 2053
    • View Profile
The problem it is because the used template is the one which is integrated into HFS
It is can be due to the template, but I work only from the originals from rejetto

You can make the test yourself, I modified nothing. Most of the time it is the modified templates which are in question

Please take the template by default, and modify it by using only %folder-item-comment% to correct this bug,the one who will find by changing only the styles will have my admiration
« Last Edit: December 30, 2007, 10:44:34 PM by mars »


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13438
    • View Profile
I made a test with the default template and the comment you said.
Here it works finely.
Did i do anything wrong?


Offline Mars

  • Operator
  • Tireless poster
  • *****
    • Posts: 2053
    • View Profile
Quote
I made a test with the default template and the comment you said.
Here it works finely.
Did i do anything wrong?

 ;D ;D HI rejetto le problème existait jusqu'à la version 165, depuis la 166 celà a été corrigé dans le source LOL ;D ;D

t'as oublié de lire le titre???  build 165 bug report ;D ;D