rejetto forum

HFS is working great... but not from work

Guest · 9 · 9571

0 Members and 1 Guest are viewing this topic.

Frank F

  • Guest
Hi,

So I recently configured my home routers etc and got HFS working. It passes self test, and works if I try to access it at my friend's places etc.

However, I have been trying to use it at my place of work (meaning trying to connect to my home computer from my work computer) and I cannot access it. I have tried using both the IP address and a dyndns account I have set up on my router; both work from elsewhere but do not get through at work. The message I receive is a simple "cannot connect," it is not that the page reads as blocked.

I realize that this is very clearly not that HFS is malfunctioning, but that something is blocking me from accessing it at work. I'm just looking for a possible way around.

If it is pertinent information, I am in exactly the same situation with Windows Remote Desktop: it works from elsewhere but I cannot access it from work.

Thank you!


Offline Mars

  • Operator
  • Tireless poster
  • *****
    • Posts: 2059
    • View Profile
except if you use a external proxy to connect to your hfs with dns or external ip, it's not possible to do it.

Quote
The message I receive is a simple "cannot connect," it is not that the page reads as blocked.

except with some router, it's only possible to use 127.0.0.1 or  ip address of your network card to connect to hfs.

on the forum many posts are talking about this problem.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13516
    • View Profile
maybe you are allowed to access only a white-list of websites.
can you access any website from work?


Frank F

  • Guest
The web access from work is not white-list based, but does seem to do blocking in some other ways as well. There is content blocking using St. Bernard iPrism, which is black-list based. The effectiveness of this blocker seems heavily dependent on my browser however, 70% of its blocks don't work outside of IE.

There is some sort of other filtering/blocking going on at the router/network level as well I believe, because as I mentioned previously, I also cannot remote into my home PC using Windows Remote Desktop, and this service also works on other networks, even on this machine (my work PC is a laptop).


Offline r][m

  • Tireless poster
  • ****
    • Posts: 347
    • View Profile
Do you use an address with a :port ?
If so as an experiment try setting HFS to port 80 and forward 80 in your router to the HFS
computer's address.
Then try to access from work with YOURADDRESS.COM/ (In other words, no port)
Provided you know that your home isp doesn't block 80? You can check that with
canyouseeme.org


Frank F

  • Guest
My home ISP does block port 80, so no go on that try. I have been using it with a different port, typing it in when I try and access it. At this point I run out of enough networking knowledge to discern how my work network is "deciding" not to allow me access to my home IP address. Since its blocked on Remote Desktop too I'm really not sure how they're achieving it. Workaround ideas still welcome


Offline johnjaykay

  • Occasional poster
  • *
    • Posts: 21
    • View Profile
I don't use this way, but I read this previously, and maybe it will work. Check out this other posting....

http://www.rejetto.com/forum/index.php/topic,9388.0/topicseen.html

John


Offline bbertrand

  • Occasional poster
  • *
    • Posts: 13
    • View Profile
I know this is late.  My ISP blocked Port 80 - so no go.  But my work had proxy servers that checked protocol vs port #.  These proxies only allow protocols on "standard ports", and that is Port 80 for HTTP.

But my ISP does NOT block Port 443, the STANDARD PORT for HTTPS, so because of the ISP and Work blockages, I HAD TO USE HTTPS.  So I added STUNNEL and all is well.  STUNNEL accepts connections on HTTPS standard port 443 and sends it to HFS on any whatever port I want.


Offline Fysack

  • Tireless poster
  • ****
    • Posts: 598
  • present picture
    • View Profile
    • Admin
Use a port redirect feature listed under a modifyed host page to navigate around a blocked port 80. Set the IP address and the port you would like http requests sent to. If your IP address is dynamic (one that changes and is not always the same) be sure to run (Keep your current IP address in sync with your No-IP host or domain with your Dynamic Client and select this host).

Its not not that late bbertrand :-D

thx for great information man. You might think im sarcastic, but im not. KEEEp up THE Goood work! best regards :-)



GOD CAN READ YOUR MIND