rejetto forum

Testing build #181

0 Members and 1 Guest are viewing this topic.

Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13310
    • View Profile
download @ www.dovedove.it/hfs/hfs181.exe

what's new
+ URI support in {.save.} and {.append.}
+ now also external template files should be converted to the new syntax
+ disallowed some bad filenames like . .. {. | .}
+ new template macro: any macro marker
+ macros are allowed to be loaded through {.load.} and {.section.} if the file resides in the hfs folder
+ "addresses ever connected" moved to external file hfs.ips.txt, and hopefully fixed performance problems with many addresses www.rejetto.com/forum/?topic=5716
* [special:begin] now applies to other pages as well
- {.postvar.} was not working with utf-8


Offline TSG

  • Operator
  • Tireless poster
  • *****
    • Posts: 1935
    • View Profile
    • RAWR-Designs
RAWR-Template-0.1.0 and ToG-4.0.0 will be released as soon as I have bug tested them. ;)

I am testing TPGen 3 also at the moment, we should have that out within a few weeks.


Offline TSG

  • Operator
  • Tireless poster
  • *****
    • Posts: 1935
    • View Profile
    • RAWR-Designs
MAJOR BUG I don't know what caused it. But HFS got stuck in some loop of exceptions. It might have been the ip checker... or external address connecting. Those 2 events occured.

And I just found out that people cant connect... after a restart.
« Last Edit: March 05, 2008, 06:49:06 AM by That_Stevens_Guy »


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13310
    • View Profile
ok i will look at this problem, but couldn't you tell me an easy way to reproduce it ?
i will disable autoupdate in the while


Offline TSG

  • Operator
  • Tireless poster
  • *****
    • Posts: 1935
    • View Profile
    • RAWR-Designs
Simple, start HFS... wait a while... then it just crashes. It seems to be either on an IP update, or when somebody tries to connect to HFS. It really goes insane, just constant loop of crashes.


Offline traxxus

  • Occasional poster
  • *
    • Posts: 62
    • View Profile
Same here. After auotupdate it crashes.....  ???

I got many of this errors in log:

############# ERROR ON: 05.03.2008 09:32:04
C:\Programme\HFS\hfs.exe
Access violation at address 00528B80 in module 'hfs.exe'. Read of address 2D2D2D5D
HFS 2.3 beta (181)
#############

But after start HFS again it works without crash.
« Last Edit: March 05, 2008, 02:20:59 PM by traxxus »
traxxus.dyndns.org:100