rejetto forum

The "Takeback" template - A different & modern taste

NaitLee · 63 · 16609

Poll

Do you want a tool for creating templates easily?

Yes, I know nothing about coding, but I can do Windows Paint
2 (33.3%)
Yes, I can do HTML/CSS, but not javascript nor macro
0 (0%)
Yes, I can do Web basics, but not HFS macro
3 (50%)
No, I'm a full-code developer
1 (16.7%)

Total Members Voted: 6

0 Members and 1 Guest are viewing this topic.

Offline NaitLee

  • Tireless poster
  • ****
    • Posts: 165
  • Computer brained boy
    • View Profile
    • A Normal Webpage
The results show that the "Takeback" template works well until RC4. This problem only occurs in versions RC4 and above. What's more, in RC7 (the latest version currently), this problem occurs even when I'm using the default template, and this time you will get a page of javascript from the server.

My test conclusion:

- The default template of RC7 is doing the wrong thing: post selection data to a javascript data section, so the server did nothing other than sending javascript.
  - Please wait for rejetto to fix this :)

- My template have a bug, the helper.getFilename() function returns an empty string for folder names (which ends with a slash /, not considered ::)), and after that sends an empty selection to server, then server think it should do nothing
  - This will be my another job ;)

Thank you for doing a lot of work testing 🎉
Check out my template and PHFS ;)


Offline 9M127

  • Occasional poster
  • *
    • Posts: 5
    • View Profile
My test conclusion:

- The default template of RC7 is doing the wrong thing: post selection data to a javascript data section, so the server did nothing other than sending javascript.
  - Please wait for rejetto to fix this :)

- My template have a bug, the helper.getFilename() function returns an empty string for folder names (which ends with a slash /, not considered ::)), and after that sends an empty selection to server, then server think it should do nothing
  - This will be my another job ;)

Thank you for doing a lot of work testing 🎉

Hi! More problems was found in HFS 2.4 recently. Since HFS 2.4 RC2, There's a problem that the function "Archive" rarely works as expected.
No matter what template I was using, after clicking "Archive", I will usually get either a broken compressed file, or a weird compressed file.
For example, yesterday when I was trying to archive a folder with two "*.xlsx" files (created by Microsoft Excel), the server did gave me a "*.tar" file.
But after I extracting it, I got some strange files and folders, as if I was trying to unzipping a "*.docx" file or a "*.xlsx" file!

So I rolled back to HFS 2.3m, and now everything looks fine again.
Except, when you click "Archive", you will get a "*.tar" file containing only files shown in the list, but not folders.


Offline 9M127

  • Occasional poster
  • *
    • Posts: 5
    • View Profile
Hi! More problems was found in HFS 2.4 recently. Since HFS 2.4 RC2, There's a problem that the function "Archive" rarely works as expected.
No matter what template I was using, after clicking "Archive", I will usually get either a broken compressed file, or a weird compressed file.
For example, yesterday when I was trying to archive a folder with two "*.xlsx" files (created by Microsoft Excel), the server did gave me a "*.tar" file.
But after I extracting it, I got some strange files and folders, as if I was trying to unzipping a "*.docx" file or a "*.xlsx" file!

So I rolled back to HFS 2.3m, and now everything looks fine again.
Except, when you click "Archive", you will get a "*.tar" file containing only files shown in the list, but not folders.
By the way, I'm hoping for a progress bar in the upload page of your template!
Looking forward to the next version of HFS.
Love you guys! :-*