rejetto forum

Can't pass self-test; tried everything

Guest · 8 · 4164

0 Members and 1 Guest are viewing this topic.

Andrew

  • Guest
Hi, hopefully someone on here can give me some advice. First of all, these are my specs: I'm behind a Linksys WRT54G firewall, am using Window's built-in firewall and have set my static IP address to 192.168.1.10. Now, when I used HFS before, I did have to do some configuring, but it worked out in the end, now after I've disabled the "filter anonymous internet requests" on the router, set up the port forwarding to 31028 (which is the port I set in HFS), created an exception for the program hfs.exe in Window's firewall as well as an exception for port 31028 I still cannot pass the self-test. I've looked at all the ports in use to make sure that I'm not using one that's already listed and I've tried changing up the port and port forwarding accordingly, but nothing is working. Any insight would be greatly appreciated.


Walter

  • Guest
have set my static IP address to 192.168.1.10.
That's your internal lan address.  Use your external internet address.


Offline AvvA

  • Tireless poster
  • ****
    • Posts: 135
    • View Profile
You didn't say if you've switched off the firewall inside your router.
Try to look at your router's logs and your windows firewall logs, at the time when you did the self-test, to see if they have blocked an IP on port 31028.

You can also test your port opening here : http://corz.org/probe?tcp_port=31028
With HFS running, you should success, HFS stopped, you should fail.

If you failed in both cases, try to alternatively switch off windows firewall, router's firewall, then both, and see if any combination make your server accessible.


Andrew

  • Guest
Walter: it would be impossible for me to use my external IP address for two reasons. A: like almost everyone else, I don't have a static *external* IP address, if I did I wouldn't have a need for this software and B: my router only allows me to forward ports within the context of it's own network (ie. 192.168.1.xxx) thanks for your suggestion though.

AvvA: I've disabled every option in my router's firewall and run the self-test and still nothing. Furthermore, the testing page you linked to gave me this feedback: "connexion timed out. (probably stealthed)" Also, I looked at the log for my router and found NO incoming connections.

So I'm guessing that means the problem probably lies with the Windows firewall, but I've created exceptions for the program, opened the correct port and tried disabling the whole darn thing, but it still won't pass.


Offline r][m

  • Tireless poster
  • ****
    • Posts: 347
    • View Profile
Just an FYI:
I have a WRT54G and I can connect to my server using my external or internal IP address
from inside my LAN.
Some brands of routers wont, the one I have will.
For purposes of testing not having a static external IP doesn't matter.
Static internal IP is necessary.

No doubt something is blocking. You have set static IP address 192.168.1.10 in
the computer hfs is running on, (not just in the router) and thats the address
you port forwarded.
Do you have any access restrictions set in the router?

Are you using wireless to connect to the router or ether net cable?
Do you have security/encription set up in the router?
Do you have any wireless devices like a PS3, etc connecting to the router?
Under certain condions these can cause problems, but its easy to fix.
« Last Edit: June 10, 2009, 03:29:59 PM by r][m »


Offline bacter

  • Operator
  • Tireless poster
  • *****
    • Posts: 681
    • View Profile
Welcome Andrew:

Quote
, I don't have a static *external* IP address, if I did I wouldn't have a need for this software
The type of your external ip, static or dinamic, has nothing to do with hfs. To access your server from wan, the external address must be used. However, you are right that yor server-pc needs to use a fixed IP on your lan to forward the used port from the router to your pc.

But if your hfs is running and the selftest does not work, you have not done the setup in a correct way.
If you look at portforward.com, you will find the needed steps for your router there. If your router is WRT54G, there is even a page for configuring portforwarding for hfs:

http://portforward.com/english/routers/port_forwarding/Linksys/WRT54G/Http_File_Server-HFS.htm

Once your server works, you might want to use a domain name to access it from wan. Look for free domains that work with dinamic ip's for example on http://www.dyndns.com/ or  http://www.no-ip.com/. If you have questions about this, google or use the search-function on this forum before posting, you have a good chance to find answers there . ;)

Good luck! :)
your computer has no brain - use your own !


Andrew

  • Guest
No doubt something is blocking. You have set static IP address 192.168.1.10 in
the computer hfs is running on, (not just in the router) and thats the address
you port forwarded.
Do you have any access restrictions set in the router?

Are you using wireless to connect to the router or ether net cable?
Do you have security/encription set up in the router?
Do you have any wireless devices like a PS3, etc connecting to the router?
Under certain condions these can cause problems, but its easy to fix.
sorry for the late response; there are no access restrictions set. it is set for WEP encryption and occasionally there are wireless devices that connect to the network, such as my PSP and laptop, and my Tivo and Wii are also connected wirelessly 24/7. so how do I fix this? oh, and I tried using my external ip as well just for the better part of valor: no luck.


Offline r][m

  • Tireless poster
  • ****
    • Posts: 347
    • View Profile
Andrew
It's hard to diagnose from here but....
The way I'm set up:
The computer hfs is on is connected to the WRT54G by ethernet cable,
The network card properties is set to a specific ip, 192.168.1.10, subnet mask
255.255.255.0, gateway 192.168.1.1. In DNS I have a host name (name of the
computer) and my dns server addresses from my isp and thats all.
The router in basic setup has starting ip address and max number of dhcp users
set to the max number of devices, wired and wireless I have, plus static dns server addresses
from my isp.
In router firewall everything is checked except NAT redirection.
In Apps & Gaming, start and end port is same (your 31028) ip is (your 192.168.1.10) enable
checked.
If the computer HFS is on is wired then the wireless router settings wont effect it.
In hfs set to expert mode be sure hfs is switched "on" and port is set to port you set in router.(31028)
An address of http://192.168.1.10:31028 in your browser should show you hfs.
An address of http://your numerical external address:31028 in your browser should also.
WRT54G list's external ip on status page. I'm on cable, so my external ip rarely to never
changes, even though its dynamic. (i don't know anything about dsl, though)
If it still doesn't work try shuting down windows firewall AND all wireless devices. Un plug
them if possible.
Wireless devices set to connect automatically will grab the first address available from the router,
usually the lowest numerically. I set my hfs computer's lan static address to the numerically highest
available from the router. If a wireless has grabbed the address, in my experience, nothing else can use it.
Hope this helps. Please let us know what happens.
« Last Edit: July 30, 2009, 03:45:48 PM by r][m »