rejetto forum

hfs template not generating when accessing thru nginx

Win_7 · 6 · 1991

0 Members and 1 Guest are viewing this topic.

Offline Win_7

  • Occasional poster
  • *
    • Posts: 19
    • View Profile
Hello im trying to add ssl cert by proxying connections thru nginx and its working apart from hfs homepages they just dont generate and show the nginx 502 bad gateway but any of my custom html pages do load & work + has ssl but interestingly the hfs not found page does display is there any way to fix this?

heres my nginx config:
   location / {
      proxy_pass http://192.168.0.100:80;
      proxy_set_header Host $http_host;
      proxy_set_header X-Real-IP $remote_addr;
      proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

      proxy_set_header X-Forwarded-Proto $scheme;
      proxy_buffering off;
      proxy_redirect off;
   }


btw what does "Return to th is topic" do?


Offline LeoNeeson

  • Tireless poster
  • ****
    • Posts: 840
  • Status: On hiatus (sporadically here)
    • View Profile
    • twitter.com/LeoNeeson
Hi, :)

If you are running Nginx on the same PC that runs HFS (along with it, on the same OS), then instead of using:

Code: [Select]
proxy_pass http://192.168.0.100:80;
Use the following:

Code: [Select]
proxy_pass http://127.0.0.1:80;
Check if this solves your problem (and then please report back the results here).

btw what does "Return to this topic" do?
If you check this when posting a new thread/post, instead of going back to the message index, you return to the topic (and see your new post).

Cheers,
Leo.-
HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
» Currently taking a break, until HFS v2.4 get his stable version.


Offline Win_7

  • Occasional poster
  • *
    • Posts: 19
    • View Profile
Hi, :)

If you are running Nginx on the same PC that runs HFS (along with it, on the same OS), then instead of using:

Code: [Select]
proxy_pass http://192.168.0.100:80;
Use the following:

Code: [Select]
proxy_pass http://127.0.0.1:80;
Check if this solves your problem (and then please report back the results here).
If you check this when posting a new thread/post, instead of going back to the message index, you return to the topic (and see your new post).

Cheers,
Leo.-

yes both are on the same pc and host os but i have found that using the lan ip works better than 127 even for local stuff but sadly no matter the proxy pass url it wont work


Offline LeoNeeson

  • Tireless poster
  • ****
    • Posts: 840
  • Status: On hiatus (sporadically here)
    • View Profile
    • twitter.com/LeoNeeson
yes both are on the same pc and host os but i have found that using the lan ip works better than 127 even for local stuff but sadly no matter the proxy pass url it wont work
:-[ To tell the truth, I'm not an Nginx expert, so it's hard to tell you what the exact problem is (and why it doesn't work for you). Rejetto has released a Nginx package HERE (to have HTTPS support). You can try his package, or you can 'extract' the correct setting from it. I haven't tested it, but perhaps using it you could solve your issue. Unfortunately I have no other solution in mind. :-\
HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
» Currently taking a break, until HFS v2.4 get his stable version.


Offline Win_7

  • Occasional poster
  • *
    • Posts: 19
    • View Profile
:-[ To tell the truth, I'm not an Nginx expert, so it's hard to tell you what the exact problem is (and why it doesn't work for you). Rejetto has released a Nginx package HERE (to have HTTPS support). You can try his package, or you can 'extract' the correct setting from it. I haven't tested it, but perhaps using it you could solve your issue. Unfortunately I have no other solution in mind. :-\

thanks :)
its 1am already so ill test it tomorrow and post the results here ;D


Offline Win_7

  • Occasional poster
  • *
    • Posts: 19
    • View Profile
Hi, :)

If you are running Nginx on the same PC that runs HFS (along with it, on the same OS), then instead of using:

Code: [Select]
proxy_pass http://192.168.0.100:80;
Use the following:

Code: [Select]
proxy_pass http://127.0.0.1:80;
Check if this solves your problem (and then please report back the results here).
If you check this when posting a new thread/post, instead of going back to the message index, you return to the topic (and see your new post).

Cheers,
Leo.-

this one fully works thank you and rejetto!