rejetto forum

MD5 files won't show on folders

0 Members and 1 Guest are viewing this topic.

Offline alfablac

  • Occasional poster
  • *
    • Posts: 11
    • View Profile
Tried to find a thread that talks about files that are present on the server, but won't show on hfs.
I have a folder with a bunch of md5 files that won't show when they are accessed via hfs.
Folder is set as virtual, if I change the extension to txt it shows. Looks like there's some setting of filemask that won't allow me to access *.md5 files.

How can I change that?!

Thanks in advance.


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 901
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
i recall leo having the same issue. had something to do with HFS already having md5 files...

http://www.rejetto.com/wiki/index.php?title=HFS:_scripting_commands
md5 file | A
computes and expands to the MD5 hash for file A.

http://www.rejetto.com/forum/hfs-~-http-file-server/macro-md5-and-create-file/

this thread may be of help to the solutions:
http://www.rejetto.com/forum/hfs-~-http-file-server/fingerprints-support/

Leo may be of better help here:
http://www.rejetto.com/forum/bug-reports/uploading-a-md5-file-is-forbidden/msg1061095/#msg1061095
« Last Edit: October 15, 2016, 04:35:05 PM by bmartino1 »
Files i try to keep and share can be found on my google drive:

https://drive.google.com/drive/folders/1FOWi3Gqaldld6JLXvZ-biDv4RSguf0IC


Offline LeoNeeson

  • Tireless poster
  • ****
    • Posts: 776
  • Status: On hiatus (sporadically here)
    • View Profile
    • twitter.com/LeoNeeson
Yes, bmartino1 is right, the MD5 extension is forbidden by default (to avoid conflicts with an internal HFS function). This was the solution given by rejetto:

it's configurable.
By default these files are NOT allowed:
hfs.*;*.htm*;descript.ion;*.comment;*.md5;*.corrupted

You can right click on the upload folder, go to "upload mask" and enter a custom mask, like
\hfs.*;*.htm*;descript.ion;*.comment;*.corrupted

you see i removed the md5 part.
Please, mind the initial slash, it means: DON'T allow these

Cheers,
Leo.-
« Last Edit: October 16, 2016, 05:46:00 AM by LeoNeeson »


Offline alfablac

  • Occasional poster
  • *
    • Posts: 11
    • View Profile
Sorry for the late response, but it did allow me to upload a md5 file to the server, but I don't see the previously md5 files and the uploaded one in the folder when I browse through HFS, even though they are there in the server.



Offline LeoNeeson

  • Tireless poster
  • ****
    • Posts: 776
  • Status: On hiatus (sporadically here)
    • View Profile
    • twitter.com/LeoNeeson
but I don't see the previously md5 files and the uploaded one in the folder when I browse through HFS, even though they are there in the server.
Did you applied the 'custom mask'? Because I think this is the normal behavior (not listing MD5 files when browsing through HFS). Try applying that 'custom mask' and see if it shows those files on HFS.


Offline alfablac

  • Occasional poster
  • *
    • Posts: 11
    • View Profile
I must be editing in the wrong place. I set the options here, but nothing happens. What do you mean by "custom mask"? I think I'm not finding this option.


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 901
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
it's configurable.
By default these files are NOT allowed:
hfs.*;*.htm*;descript.ion;*.comment;*.md5;*.corrupted

You can right click on the upload folder, go to "upload mask" and enter a custom mask, like
\hfs.*;*.htm*;descript.ion;*.comment;*.corrupted

you see i removed the md5 part.
Please, mind the initial slash, it means: DON'T allow these

only the upload mask needs the line.
*upload permissions need to be set first (account/anyone/anonymous...)etc...

your mask is now saying to not allow the files...

with this upload mask, a md5 file is now upload able...

also for other md5 file stuff, it better to edit the default template as stated here:

http://www.rejetto.com/forum/bug-reports/uploading-a-md5-file-is-forbidden/msg1061163/#msg1061163

@Mars: Thank you. :) Thanks to your "replace" macro trick, I've removed the "full path" and used %item-resource% instead of %item-name%. Now works beautifully with any file I throw in (even works with another unicode symbols I've tested). This is the final result (with some cosmetic changes marked in green):
-----------
Code: [Select]
[upload-success]
{.inc|ok.}
{.comment|Reset md5 var.}
{.set|md5.}
<li> <a href="%item-url%">%item-name%</a>
<br /><b>Size & Speed:</b> %item-size% @ %smart-speed%B/s
{.if|{.>|%item-size%|0.}|{:
   {.comment|Calculate md5.}
   {.set|md5|{.md5 file|%item-resource%.}.}
   {.comment|Create a new md5 file.}
   {.save|%item-resource%.md5|{.^md5.} {.replace |%folder-resource%\|*|%item-resource%.} /save.}
   {.comment|View md5 on Upload Result.}
   <br /><b>MD5 Checksum:</b> {.^md5.}
:}.}
{.if| {.length|%user%.} |{: {.comment|.append|%folder-resource%\hfs.comments.txt |{.filename|%item-resource%.}=uploaded by %user%
/append.}
{.set item|%item-url%|comment=uploaded by %user%.}
:}/if.}
----------

« Last Edit: October 24, 2016, 07:40:47 PM by bmartino1 »
Files i try to keep and share can be found on my google drive:

https://drive.google.com/drive/folders/1FOWi3Gqaldld6JLXvZ-biDv4RSguf0IC


Offline alfablac

  • Occasional poster
  • *
    • Posts: 11
    • View Profile
Added these lines, but I still can't see the md5 in the folder, even though they are on the server.
Pretty strange. Thanks anyway for everyone.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13354
    • View Profile
by default files that have "system" or "hidden" flag are not displayed.
I'm talking about the attributes you see in the file properties from the file manager (WIN+E)