rejetto forum

HFS file sharing does *not* work for some users across the globe.

0 Members and 1 Guest are viewing this topic.

Offline HenrikoMagnifico

  • Occasional poster
  • *
    • Posts: 9
    • View Profile
Hi! I've been getting more than a dozen reports of users not being able to download files from my public Windows 10 HFS server which I'm hosting from my own Wifi network. For the vast majority of users, it works fine, but it seems that for about ~5% of users the URL doesn't lead anywhere (presumably blocked). I've of course port forwarded my router, both on the default port 80 and also on a custom port 8080- none of them yield any different results. My guess is HFS is blocked by these users ISP, which would be very unfortunate. Is there any work around? I'm out of ideas, any help would be much appreciated!

Cheers!
~Henriko


Offline LeoNeeson

  • Tireless poster
  • ****
    • Posts: 744
  • Status: On hiatus (sporadically here)
    • View Profile
    • twitter.com/LeoNeeson
Hi, and welcome to the forum! :)

What dynamic DNS service are you using? (how ends your URL, for example, do you use *.no-ip.com?). I can search for a solution if you comment what DNS service you use. Also, do you know from what country are those ~5% of blocked users? (perhaps there is a block at country level). If you share more details, it would be easier to try to help you.

Cheers,
Leo.-
HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
» Currently taking a break, until HFS v2.4 get his stable version.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13309
    • View Profile
it's probably not related to HFS. Your dns/domain or your ip may be unreachable for censorship or similar.
You can verify that by trying something that's not hfs.


Offline HenrikoMagnifico

  • Occasional poster
  • *
    • Posts: 9
    • View Profile
it's probably not related to HFS. Your dns/domain or your ip may be unreachable for censorship or similar.
You can verify that by trying something that's not hfs.

Hi! Sorry for the slow response.

I've done further analysis and it appears that this is an issue with the Technic Launcher platform, which I use to distribute the files to my users. Entering the IP and DNS manually into a browser (i.e. Google Chrome) and it works like intended for all users that have tried it. I will be getting in contact with Technic shortly. Thanks for your help!

Cheers!
~Henrik