rejetto forum

RAWR-Template-0.0.3 BETA

TSG · 39 · 15180

0 Members and 1 Guest are viewing this topic.

Offline TSG

  • Moderator
  • Tireless poster
  • *****
    • Posts: 1935
    • View Profile
    • RAWR-Designs
RAWR-Template-0.0.3 Released.



[new] Black theme.
[new] Language files, 7 available languages, en, es, fr, it, ru, de, nl.
[new] Macro driven shoutbox.
[new] Macro driven check update feature.
[new] Template Settings: theme, language, shoutbox toggle (on-off), admin (admin account for deleting posts).
[upd] More thumbnail and preview support for long extensions & tif filetype (ready for T&P Gen 3).
[upd] Small CSS changes included for easier language implementation.
[upd] CSS class added for search and shoutbox input fields.
[chg] {{$theme}} now {{!theme}} for easier setup.

[to-do] Moderator accounts for shoutbox.

NOTE: Shoutbox doesn't work too well with special characters. They appear as ??, its a bug with HFS. Hopefully will be fixed by 179.

EDIT: Forgot to mention, the shoutbox also supports 11 emoticons. These are triggered by common MSN inputs.
« Last Edit: February 19, 2008, 10:33:08 PM by Giant Eagle »



Offline TSG

  • Moderator
  • Tireless poster
  • *****
    • Posts: 1935
    • View Profile
    • RAWR-Designs
Do you disable browsing or hide everything in the template directory? You need only hide /template. Don't protect the template directory either.
« Last Edit: February 07, 2008, 03:04:46 PM by That_Stevens_Guy »


GANGE_)

  • Guest
Regards by all. we have some problems with mapping of Russian names it is file and the commentaries


Offline TSG

  • Moderator
  • Tireless poster
  • *****
    • Posts: 1935
    • View Profile
    • RAWR-Designs
It might be a HFS bug. HFS doesn't fully support Unicode as rejetto has stated many times. Comments are out of my control.


GANGE_)

  • Guest
It does mean necessary to 4 so I do understand to learn coding commentaries and names it is file?


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13438
    • View Profile
HFS doesn't load uncode filenames from the server's disk.
Unicode characters in comments are not involved.


GANGE_)

  • Guest
this is what I attained after changing coding. everything show normally except the statistics



Offline TSG

  • Moderator
  • Tireless poster
  • *****
    • Posts: 1935
    • View Profile
    • RAWR-Designs
Hmm. I don't understand this one, cause the language file is UTF-8 and the template is UTF-8, and all characters in your language show correctly. Comment is converted to UTF-8 when HFS generates a page... So why your non-ascii Russian characters are not showing has confused me.

I ran some tests. In this screenshot, you can see i get a similar result. Language var works fine, direct input into comment field... well i cant even see the chars (this is apparently cause the interface isn't unicode).

Run some tests using actual .comment (UTF-8 saved) files in real folders. See what they come up with.

ladiko, remove 'hide tree' thats why its doing it lol. Just 'hide' /template.

Nice work GANGE, But I do not know why that is happening with the statistics either :P, it might be because stats.htm is not encoded correctly, for some reason, mine corrected itself. I will disable updating statistics for Russian in next build if this cannot be resolved. Are you using 178?
« Last Edit: February 07, 2008, 04:13:10 PM by That_Stevens_Guy »


GNAGE_)

  • Guest
I simply changed the parameter to lv_charset=UTF-8 to lv_charset=windows-1251 and transferred into Ansi coding.


Offline ladiko

  • Occasional poster
  • *
    • Posts: 75
    • View Profile
sorry, i misunderstood your last reply vice versa. problem is still there:
reloading the page with [ctrl]+[r] or [f5] doesnt help. loading the shoutbox keeps the page loading and loading and i'm very confused cause after half a minute or so, my router disconnects my wlan ^^

if i dont reload the page, everything works great. never had an similar issue.

also interesting: http://localhost works, but dyndns adress fails.

using hfs178

btw:
why is browsing needed? without browsing, it doesnt work.
« Last Edit: February 07, 2008, 04:43:35 PM by ladiko »


Offline Foggy

  • Tireless poster
  • ****
    • Posts: 806
    • View Profile
why is browsing needed? without browsing, it doesnt work.

you need browsing enabled because the shout box is an iframe that calls the folder /template/shoutbox which has a diff template in it.


Offline ladiko

  • Occasional poster
  • *
    • Posts: 75
    • View Profile

Offline TSG

  • Moderator
  • Tireless poster
  • *****
    • Posts: 1935
    • View Profile
    • RAWR-Designs
btw:
why is browsing needed? without browsing, it doesnt work.

i still have the problem =(

You just said it works when you enable browsing? You must not hide the template folder tree or disable browsing, otherwise it will not work. Other than that I have no idea what your problem is there.