rejetto forum

HFS and COMODO Personal Firewall

0 Members and 1 Guest are viewing this topic.

Offline Smazzulatore

  • Occasional poster
  • *
    • Posts: 8
    • View Profile
Hello.
I'm trying to configure COMODO Personal Firewall for making HFS work properly, but I don't manage it.
With the default COMODO configuration, HFS Self Test fails.
I've tried with the task "Scan for known applications" = no results;
I've specified HFS as trusted application (without specifing a parent application) = no results;
Checking the Application Control Rules, HFS results with TCP/UDP In and Out allowed on any port and destination.
Does anybody help me.
Thanks.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13438
    • View Profile
already answered in italian, but re-doing here for it may help other users.

the firewall is not the only obstacle you have to configure.
ok, you did right with comodo, now you probably have to configure your router.
go on www.portforward.com and follow their guide.


Offline Smazzulatore

  • Occasional poster
  • *
    • Posts: 8
    • View Profile
Thank you, but my ADSL modem (Aethra EB1070 Alice pack) isn't in the Portforward.com list.
Just for info, here's the message at the end of the self test: "The test failed: server does not answer. You may be behind a firewall. Ensure nothing is blocking HFS."
 
My PC runs HFS ver. 2.1a.
 
Self test is OK only if the COMODO Network Monitor is TURNED OFF or if the Securuty Level is low (Allow All) or if the firewall is down.


Offline maverick

  • Tireless poster
  • ****
    • Posts: 1052
  • Computer Solutions
    • View Profile
Self test is OK only if the COMODO Network Monitor is TURNED OFF or if the Securuty Level is low (Allow All) or if the firewall is down.

If the self test is OK when the firewall is turned off, that tells me the problem you are having has to do with your firewall configuration.  I'm not familiar with that firewall, but you have to allow HFS internet access with the port you are using and also allow HFS access on the internet as a server.
« Last Edit: November 07, 2006, 08:18:46 PM by maverick »
maverick


Offline Smazzulatore

  • Occasional poster
  • *
    • Posts: 8
    • View Profile
Solved.
In the Network Control Rules Panel I've created a new rule with the following options: Allow TCP - Any Source/Destination IP - Any Source Port - Destination Port 80. Pay attention! Allow only "TCP", not "TCP or UDP".
Bye.
« Last Edit: November 08, 2006, 11:47:56 AM by Smazzulatore »