rejetto forum

Duplicate entry 'unknown,' for key 'PRIMARY'

0 Members and 1 Guest are viewing this topic.

Offline ykhandoo

  • Occasional poster
  • *
    • Posts: 1
    • View Profile
Greetings good people.

I installed HFS version 2.2F (155) yesterday. It was my first-time install.  Everything worked fine, self test was successful. Today I rebooted my laptop, reconnected and got new IP address from my ISP.  Now when I tried the self-test, I got the error:

The test failed: server does not answer. Duplicate entry 'unknown,' for key 'PRIMARY'

I'm not totally sure, but the IP address mentioned in the error looks like the one I got yesterday from my ISP.  However when I go to "Menu > IP address", I see the IP address selected here, which seems to be the new IP address, namely at the moment

Ok just to be sure, I now just disconnected again from my ISP, reconnected, and the new IP address again shows correctly in the main display and is also ticked under IP address in the main menu, namely this time The port defaults to 8080 as always.
Again when I try self-test, I get exact same error as before, including that old IP address mentioned in the initial error
On this laptop I'm not behind a router, and I have agreed to allow when the Windows Firewall asked to allow or deny the HFS server access.

I'm also getting a similar error on another PC with a more complex setup, namely behind my home Linksys WRT160N router.  In that configuration (btw which is totally separate from the one described earlier with my laptop), there I have opened both ports 1000 and 7000 to the computer assigned as in the router's DHCP settings.  I did this because the self test recommended this.  I also am using a dynamic DNS host which the router itself updates, so I have manually added my static dyndns hostname into the HFS "Menu > IP address > Custom" entry, and selected that entry as active.

Interestingly, when I run the self-test on that computer connected to the linksys router, I get the same error as I am getting on the laptop, and would you believe, I just checked again because I had a suspicion, and yes, even the IP address is the exact same  How is that!
"The test failed: server does not answer. Duplicate entry 'unknown,' for key 'PRIMARY'"

Any help will be appreciated.  I was wondering if perhaps this has something to do with my ISP blocking web servers. But then yesterday when I ran the self-test on my laptop it succeeded so that throws me for a loop.
More info:

My laptop is an HP Elitebook 8440P running Windows 7 32 bit.  My desktop which is on the router is running Windows XP with Asus dual-core motherboard (if this could have anything to do with it)!.  HFS version on both machines is 2.2F(155).

Thanks all over the place, people.

Regards, Yogan.

Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13517
    • View Profile
That's clearly a bug, preventing you from using the test. If your setup is correct you can still use HFS.