rejetto forum

Help please with accessing HFS Server on the internet

Guest · 14 · 3878

0 Members and 1 Guest are viewing this topic.

Drok

  • Guest
I have managed to get everything working except accessing HFS from a remote computer over the internet. I can enter my public ip address in my internet explorer and access it, but I cant from a remote computer. Maybe im typing the URL wrong or something, but im not sure. Any help is greatly appreciated.


Drok

  • Guest
I have tried EVERYTHING I can think of or have seen on this site to get HFS working from remote locatons. I have even disabled norton firewall, and enabled DMZ on my computers Private IP Address just to see if it would work....nope. I have port fowarded on port 80, both UDP + TCP, setup a dns name at dyndns.org, setup my host file for this. Everything I can thing of, except one thing I saw someone post they said that norton worm blocker was acting as a firewall. I dont see that in norton. Is this true, if so how do I disable it? I been workin at this thing for 2 days now. Please help me anyone. Thanks


Offline maverick

  • Tireless poster
  • ****
    • Posts: 1052
  • Computer Solutions
    • View Profile
I assume that you are port forwarding correctly for your router.  If not search the forum as there are posts that describe where to go or how to do that.

Make sure that nothing is blocking the port you are using with HFS.

I would suggest for now just to forget about using dyndns.org etc.  Just do the basics right now so you know "first" that you got everything else configured correctly and that you can access your server from the internet.

Maybe you aren't using the correct IP addresss.  (you didn't say much about this).  Don't use your LAN address with HFS as that won't work over the internet.

Here is a small utility that works very well in determining your internet IP address.

http://www.rejetto.com/forum/viewtopic.php?t=2664&sid=df4524895764e8a95e18feb75b5c4219

Good Luck.
maverick


Drok

  • Guest
You said dont use your LAN Address with HFS. Do you mean at the top of the HFS App where it says address? Because that is set to my LAN Address(192.168.....), not Public. And i know my public because HFS can find it and I can find it on my router. Thanks


Offline maverick

  • Tireless poster
  • ****
    • Posts: 1052
  • Computer Solutions
    • View Profile

Drok

  • Guest
Thats funny. All that time spent doin nothin. But lemme get this straight. In HFS, I set the Address to my Public IP Address. Then port to 80 (or w/e else). Setup my router to port foward to port 80, UDP and TCP, on my Private IP. Disable any other firewalls. Then it should work?


Drok

  • Guest
Still didnt work. I even turned off Norton Internet Security Completely w/ DMZ on router to unblock computer. I dunno what to do anymore.


Offline maverick

  • Tireless poster
  • ****
    • Posts: 1052
  • Computer Solutions
    • View Profile
You keep saying it doesn't work.  Are you getting an error and if so what kind of error?  

Have you tried the self-check option within HFS?  If so, what were the results?

Have you checked how to port forward with your brand of router?  If not go here -> http://www.portforward.com/english/routers/port_forwarding/routerindex.htm

Maybe it's a port issue.  Try a different port in HFS.  Example 10000.  Your url would then look like this ... http://xxx.xxx.xxx.xxx:10000 . In this example you would have to configure your firewall to open port 10000 for HFS use and of course you would also have to port forward in your router.  Get a friend to check it.  

I'm not a Norton user.  I read a post in this forum that says norton worm blocker can be turned off.  So there must be an option within the program to do that.  I have no idea if that worm blocker would block access to HFS but I don't think it would.
maverick


Drok

  • Guest
Sorry, havent been up here in a few days, been busy. But anyway, the self test doesnt work. It says, The test failed: server does not answer. You may be behind a router. I will try different ports and see if that works and I will let you know.


Drok

  • Guest
Iv done everything I can think of. Tried different ports. Tried using Guardster... I can type my PC's local IP into web broser, and my public IP into web browser and access HFS server. But i cant get any of my friends to be able to do it. One thing I did notice in my D-Link DI-524 router was that port 80 is being fowarded on to other occasions.

Virtual Server HTTP 0.0.0.0 TCP 80/80 always
DCS-1000 0.0.0.0 TCP 80/80 always

These 2 were already there when I got the router. Also, why is the IP Address 0.0.0.0? Could these 2 be conflicting with HFS? If so, how can I fix this without screwing anything else up? Any more help is greatly appreciated cuz im pulling out my hair to get this to work. Thanks


Drok

  • Guest
From using the info above, seeing that port 80 TCP was already fowarded to adress 0.0.0.0, I port fowarded port 80 to UDP 0.0.0.0. I went to another computer in my house and typed my public IP:port....

http://xxx.xxx.x.xxx:80

And it worked. I got the login screen. I even used my PSP and typed in public IP address and got to the HFS server. But none of my friends from around the world can access it. Im goin crazy, i dunno what to do n e more. Plz help plz.


Mike

  • Guest
If you have ALL firewalls turned OFF and you have your router configured CORRECTLY for port forwarding and your HFS is turned ON and PASSES the SELF-CHECK there is NO reason why it shouldn't be working. Are you sure you have internet access?

You just mentioned something you didn't mention before in this thread and that is PSP.  If this is a PSP issue that you can't figure out, find the appropriate forum to discuss those issues.


Drok

  • Guest
Thats the thing, the self check doesnt work either on HFS. Always says
"The test failed: server does not answer. You may be behind a router" I think im jus doomed and have been from the start.


Offline maverick

  • Tireless poster
  • ****
    • Posts: 1052
  • Computer Solutions
    • View Profile
Before starting the Self-Test make sure that the correct IP address is shown in the HFS address bar.  Also make sure the port you are using isn't being used by something else and is properly port forwarded in your router.  

If you can't pass the Self-Test you have an IP and/or router configuration problem.  There is more than enough information in this thread to help you solve the problem.  

Have you studied this page (it was suggested early on in this thread) -->
http://www.portforward.com/english/routers/port_forwarding/Dlink/DI-524/Http_File_Server-HFS.htm
maverick