rejetto forum

Folder and File Icons not showing up for users

0 Members and 1 Guest are viewing this topic.

Offline sittingduck

  • Occasional poster
  • *
    • Posts: 3
    • View Profile
Sorry if this has been asked already.

When I and others access HFS, Folder and File icons do not display.  Sometimes they are just a dot (as in pic), most of the times they are a black X.

Refreshing the page a couple times usually brings back the icons, but wondering if there was something I could do so they would appear the first time the page loads.



« Last Edit: July 01, 2015, 12:40:11 PM by sittingduck »


Offline Mars

  • Operator
  • Tireless poster
  • *****
    • Posts: 1988
    • View Profile

Offline sittingduck

  • Occasional poster
  • *
    • Posts: 3
    • View Profile
Ok, are you saying that will correct the issue?

Installed 2.3e, and did not like the "create folder" option when "upload" was enabled....
Also, as I am very used to the 2.2 interface, wanted to stick with it.


Offline sittingduck

  • Occasional poster
  • *
    • Posts: 3
    • View Profile
and, btw, installed v2.3e and it didn't help,  have to refresh several times to get all the folder or files icons.


Offline Mars

  • Operator
  • Tireless poster
  • *****
    • Posts: 1988
    • View Profile
with hfs2.3e

it is possible to disable the creation of a new folder when the upload is active, it means going into the properties of the real file and add in the "diff template"

[+special:strings]
option.newfolder=0


to disallow new folder entire the vfs , change  the value of option.newfolder in the template

and, btw, installed v2.3e and it didn't help,  have to refresh several times to get all the folder or files icons.

have you tested with several browsers
« Last Edit: July 01, 2015, 07:53:21 PM by Mars »


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 901
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
icons are quote "dynamical cache" Meaning that the web browser you use is at fault when trying to view the files.

Since this is a cache issue, i would try to force a rest of cache , on windows depending on browser, ctrl + f5 /or shift + f5
http://refreshyourcache.com/en/cache/

For a hfs add icons workaround:
I would review some old forum post, i recall a temple / HTML thing to put custom icons in...

http://www.rejetto.com/forum/bug-reports/add-icons/msg1022824/#msg1022824

http://www.rejetto.com/forum/html-templates/custom-icons-for-file-types/msg1053599/#msg1053599

http://www.rejetto.com/forum/hfs-~-http-file-server/how-to-add-icons/msg1026293/#msg1026293

http://www.rejetto.com/forum/hfs-~-http-file-server/icon-transparant-bacground-bug/

http://www.rejetto.com/forum/hfs-~-http-file-server/displaying-poster-art-for-movies/

Good luck
« Last Edit: July 02, 2015, 02:10:04 PM by bmartino1 »
Files i try to keep and share can be found on my google drive:

https://drive.google.com/drive/folders/1FOWi3Gqaldld6JLXvZ-biDv4RSguf0IC


Offline LeoNeeson

  • Tireless poster
  • ****
    • Posts: 712
  • Status: On hiatus (sporadically here)
    • View Profile
    • twitter.com/LeoNeeson
@sittingduck: Just wondering, how about sharing your HFS Server address, so we can test it and see what's going on? (and try to help you). Thank you... :)
HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
» Currently taking a break, until HFS v2.4 get his stable version.


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 901
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
<img src="/~img_folder">

Leo has private messaged me about your HFS site, according to the Web console, you have a "~" chacter, in which i believe is preventing you form accessing the folder path for your images.

eventual hfs does load the picture: .net:192/~img_folder I think the "~" is a programming Break  that is stopping hfs to going to the folder path to get icon for images...

my next question would be, if you temp close your current hfs, download the new version put it in a another folder and re add the files to test, do the icons reaper? or do they take forever to load like this HFS is doing?
« Last Edit: July 03, 2015, 08:33:49 PM by bmartino1 »
Files i try to keep and share can be found on my google drive:

https://drive.google.com/drive/folders/1FOWi3Gqaldld6JLXvZ-biDv4RSguf0IC


Offline LeoNeeson

  • Tireless poster
  • ****
    • Posts: 712
  • Status: On hiatus (sporadically here)
    • View Profile
    • twitter.com/LeoNeeson
...eventual hfs does load the picture: .net:192/~img_folder I think the "~" is a programming Break that is stopping hfs to going to the folder path to get icon for images...
The "~" is perfectly normal in HFS, even in the latest version.
HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
» Currently taking a break, until HFS v2.4 get his stable version.


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 901
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
then there are limits set in HFS that are preventing connection to the server.. see picture, this is default form latest version...
Files i try to keep and share can be found on my google drive:

https://drive.google.com/drive/folders/1FOWi3Gqaldld6JLXvZ-biDv4RSguf0IC


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13294
    • View Profile
yes, it's some limit you set.
Use the limit on "downloads" only, not on connections.


Offline Kushner

  • Occasional poster
  • *
    • Posts: 1
    • View Profile
yes, it's some limit you set.
Use the limit on "downloads" only, not on connections.

Your tips worked perfect for me. Thanks for help.
« Last Edit: November 11, 2016, 11:33:24 AM by Kushner »