Author Topic: Pb avec index.html  (Read 2502 times)

0 Members and 1 Guest are viewing this topic.

infinity1888

  • Guest
Pb avec index.html
« on: January 14, 2011, 07:52:12 PM »
Bonjour j'essaye de mettre à la racine un fichier index.html, jusqu'à là aucun pb, le fichier charge correctement le CSS, le javascript bref tout est parfait MAIS une fois le fichier chargé imaginons que j'aille www.monsite.com/data le background a changé de couleur blanc au lieu de bleu, le cadre user s'étend sur toute la page (au lieu d'être a gauche par défaut) les fonctions javascript ne marches presque plus, impossible d'afficher les boutons, bref on dirait que le CSS est complétement mort... Pour les curieux j'ai même essayer un index.html vide et ça me fait le pb, dès que je met un html tout bug et dès que je l'enleve tout revient a sa place... des idées ?

Offline Mars

  • Moderator
  • Tireless poster
  • *****
  • Posts: 1936
    • View Profile
Re: Pb avec index.html
« Reply #1 on: January 14, 2011, 09:14:03 PM »
pour commencer , bienvenue à toi sur le forum.

si tu veux mettre un fichier index.html dans la racine, j'en déduis que tu as converti le répertoire home du vfs en dossier réel

pour répondre à ta question, il est possible que ta page affichée pour data utilise les paramêtres CSS du template de hfs et non ceux que tu as pu mettre dans index.html

si tu veux faire de ton index.html ta page principale et que tes autres pages se basent sur ce modèle, il faudra alors renommer le html en hfs.diff.tpl en respectant le système des sections du template de hfs.

Il ne faut pas oublier que pour tout fichier .html, hfs se comporte comme une passerelle et n'effectue aucune tache dessus, il présente la page au navigateur distant, c'est une des raisons pour laquelle par exemple que le php ne peut être utilisé avec hfs, ce dernier peut effectuer des taches serveur assimilées au php à condition d'utiliser le template fourni ou compatible. Un dossier réel peut être personnalisé avec un template portant le nom suivant hfs.diff.tpl   ;)

infinity1888

  • Guest
Re: Pb avec index.html
« Reply #2 on: January 14, 2011, 09:34:21 PM »
Bonjour Mars,

Merci pour ton accueil et pour cette rapide réponse ! :)

En fait tout se passe comme tu le dis en effet ma page index s'affiche a l'ouverture du site et charge "mon" CSS puis dans dans le dossier Data il charge le CSS de HFS puisque je n'ai pas mis de fichier index.html a ce niveau.

Mon problème en fait ne se situe pas ici, je vais reformuler : a la base le fichier html d'HFS fourni un "design" au serveur lorsqu'on navigue dessus. La je suis avec le theme étendu "d'origine" on voit donc que par exemple la couleur de fond est le violet, lorsqu'on est logué on a accès aux différents boutons javascript etc... lorsque je navigue sur le serveur tout se passe bien, les couleurs se chargent bien, les images aussi, les boutons, le javascript bref tout :)
Mais lorsque je rajoute un fichier index.html a la racine (quelle soit en dossier réel ou pas j'ai essayé les deux) si je me remets a naviguer sur le serveur soudainement les couleurs change il me met du blanc au lieu du bleu les boutons ne sont plus affichés les CSS, javascript bug complètement...

J'aimerais donc comprendre pourquoi...

D'autant que j'ai essayé avec tous les autres thèmes rien ne change mais pour celui là (et malheureusement désolé de vous embêter c'est celui qui m’intéresse..) je ne sais pas pourquoi ça change... :s

Je vous ai mis en PJ une screen avec et sans index pour que vous voyez la différence

Dites moi ce que vous en pensez...

infinity1888

  • Guest
Re: Pb avec index.html
« Reply #3 on: January 14, 2011, 09:35:55 PM »
Désolé celle là n'est pas passée... :s

Offline Mars

  • Moderator
  • Tireless poster
  • *****
  • Posts: 1936
    • View Profile
Re: Pb avec index.html
« Reply #4 on: January 14, 2011, 10:07:52 PM »
il semble que le référencement du fichier css pour ton fichier html ne fasse pas partie de la racine du vfs.

un peu comme cela
   <link rel="stylesheet" href="/style.css" type="text/css">

si tu veux personnaliser un répertoire sans que les sous-répertoires en soient affectés, seule l'utilisation d'un fichier index.htm* ou default.htm* est possible en raison de la codification de hfs. ainsi un index.html dans la racine n'affectera pas l'affichage des sous-dossiers basé sur le template chargé.

si tous tes parametres css sont dans un fichier à part alors ajoute le au vfs et mets lui l'attribut hidden avec le chemin qui convient dans index.html.

il serait plus simple d'utiliser une astuce dans la section principale du template en ajoutant les lignes suivantes juste après la ligne contenant []

[]
{.if|{.%folder% = /.}|

<html>
ici le contenu de la page index
</html>

|{.section|main.}
/if.}

[main]

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN">
<html>
<head>
   <meta http-equiv="content-type" content="text/html; charset=UTF-8">
   <title>HFS %folder%</title>
......



c'est une possibilité parmi tant d'autres. ;)
« Last Edit: January 14, 2011, 10:10:02 PM by Mars »

infinity1888

  • Guest
Re: Pb avec index.html
« Reply #5 on: January 14, 2011, 11:40:33 PM »
Mon fichier CSS est dans le dossier /CSS/style.css et je ne veux pas que mon style s'applique au dossier /. ou à tous les sous-dossiers je veux juste qu'il s'applique a mon fichier index (ce qui est le cas) et justement je veux garder le style par défaut (le template d'origine) sur tout le serveur... Et le pb c'est que quand je mets un fichier index.html sur le serveur sans savoir pourquoi le style par défaut change... d'ou les screens au dessus.

Sans mon fichier index tout s'affiche bien et quand je le met il me bouscule tout et c'est ça qui me gene... Je pense en effet que ta dernière solution marcherait a savoir écrire ma page html dans le template mais
1) je gère beaucoup d'index html sur le serveur et question pratique je préfère avoir des fichiers distincts
2) pourquoi pour les autres templates tout se passe bien et pas pour celui là... c'est surtout ça le pb... :s

Offline Mars

  • Moderator
  • Tireless poster
  • *****
  • Posts: 1936
    • View Profile
Re: Pb avec index.html
« Reply #6 on: January 14, 2011, 11:47:30 PM »
ajoute ton dossier CSS en mode réel à la racine du vfs et attribue lui les flags hidden et hidden tree dans ses propriétés, tout devrait rentrer dans l'ordre
 ;)

sur ce bonne nuit.
« Last Edit: January 14, 2011, 11:49:14 PM by Mars »

infinity1888

  • Guest
Re: Pb avec index.html
« Reply #7 on: January 14, 2011, 11:53:32 PM »
Merci Mars, c'est parfait :D

Bonne nuit à toi aussi :)