Author Topic: Testing build #271  (Read 11582 times)

0 Members and 1 Guest are viewing this topic.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Testing build #271
« on: October 11, 2010, 12:45:18 AM »
download @ www.dovedove.it/hfs/hfs271.exe

what's new
- VFS context menu broken in build #270 [link]
- possible "error" in the port [link]
- memory leak in {.set speed limit for connection.}

Offline SilentPliz

  • Operator
  • Tireless poster
  • *****
  • Posts: 1234
  • ....... chut ! shh!
    • View Profile
Re: Testing build #271
« Reply #1 on: October 12, 2010, 03:17:03 AM »
Hi ! :)

There are some bugs with the "move" feature:

- classic bugs with folders / files containing accented characters into their name: files renamed incorrectly during displacement ... etc ...

- If you try to move a folder, it is moved to the folder of hfs.exe

The following changes seem to fix bugs with accented characters.
By cons, I am not able to solve the problem of displacement of folders.

Quote
[ajax.move|no log]
{.set|dst|{.postvar|dst.}.}
{.break|if={.not|{.and|{.can move.}|{.get|can delete.}|{.get|can upload|path={.^dst.}.}/and.}.} |result={.!forbidden.}.}
{.set|log|{.!Moving item(s) to.} {.force ansi|{.^dst.}.}.}
{.for each|fn|{.replace|:|{.no pipe||.}|{.postvar|files.}.}|{:
    {.set|x|%folder%{.^fn.}.}
    {.set|y|{.force ansi|{.^dst.}/{.^fn.}.}.}
       {.if not |{.exists|{.^x.}.}|{.^x.}{.!:.} {.!not found.}|{:
        {.if|{.exists|{.^y.}.}|{.^y.}{.!:.} {.!already exists.}|{:
            {.if|{.length|{.move|{.^x.}|{.^y.}.}.} |{:
            {.set|log|{.replace|{.chr|13.}| |/{.force ansi|{.^fn.}.}.}|mode=append.}
                {.move|{.^x.}.md5|{.^y.}.md5.}
                {.move|{.^x.}.comment|{.^y.}.comment.}
            :} | {:
            {.set|log|{.replace|{.chr|13.}| |/{.force ansi|{.^fn.}.}.} ({.!failed.})|mode=append.}
                {.^fn.}{.!:.} {.!not moved.}
            :}/if.}
        :}/if.}
    :}.}
    ;
:}.}
{.add to log|{.^log.}.}
« Last Edit: October 12, 2010, 03:18:52 AM by SilentPliz »

Lagger

  • Guest
Re: Testing build #271
« Reply #2 on: October 13, 2010, 11:42:30 AM »
Hi,

The #271 just like a carcharias!It eats about 70% memory on every download!
It makes the Windows become unstable.

Please face squarely.Thank you.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Testing build #271
« Reply #3 on: October 14, 2010, 03:06:51 PM »
@sp
i got to fix those problems.
i will release asap.

@lagger
how often do you get the problem?
try reverting to #270 and see if it disappears.

Lemming

  • Guest
Re: Testing build #271
« Reply #4 on: October 15, 2010, 01:58:13 AM »
I run Apache and PHPBB3 and I've found that the PHPBB3 cookie conflicts with the HFS one using this version.
(I assume because they are both using the same URL as a cookie name)

If I've been on my forum and then try to access HFS then the browser keeps loading forever
and HFS lists the connection status as 'Requesting' but nothing gets any further.

However if I clear cookies and then try to access HFS with my browser it works fine.

To double check this was the cause I cleared the cookies, accessed HFS (successfully)
and then went to my forum and then refreshed the HFS tab
and sure enough Firefox got stuck trying to access HFS.

This doesn't happen with the previous version.

I understand that running Apache as well as HFS is an odd setup but HFS can do things that Apache can't
and I'm sure other people will want to use it alongside other servers.

As a crude fix I can use another free domain name for HFS but since it works perfectly with the older version
it would be great if you could fix this - maybe give the HFS cookie an 'hfs' prefix?

Anyway thanks very much for HFS. It's one of the best programs I've ever used and I'm really grateful for all the time you have put into it.  

Keep up the good work!
:)

Offline MarkV

  • Tireless poster
  • ****
  • Posts: 746
    • View Profile
Re: Testing build #271
« Reply #5 on: October 15, 2010, 03:45:50 AM »
On the other hand, the Auto-update bug is gone.
http://worldipv6launch.org - The world is different now.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Testing build #271
« Reply #6 on: October 15, 2010, 10:47:46 AM »
guys, this is delaying because i'm a little stuck experimenting with session based logins.
in the while, use the attached file to fix the "move" bugs

This doesn't happen with the previous version.

it's strange because current release doesn't use cookies in any way i know.
in need to know: is this statement based just on previous use of #270 before you updated to #271, or did you try to revert from 271 to 270 and the problem was gone?

On the other hand, the Auto-update bug is gone.

thanks for reporting
« Last Edit: October 15, 2010, 10:54:10 AM by rejetto »

Offline SilentPliz

  • Operator
  • Tireless poster
  • *****
  • Posts: 1234
  • ....... chut ! shh!
    • View Profile
Re: Testing build #271
« Reply #7 on: October 15, 2010, 12:29:18 PM »
Thank you for the .tpl rejetto! ;)
"Move" works fine now!

Detail:
It lacks a / here:

{.set|log|{.!Moving items to.} {.^dst.}/.}

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Testing build #271
« Reply #8 on: October 15, 2010, 05:46:12 PM »
that's necessarily a folder, i don't think the extra slash will be of any help to the user

Lemming

  • Guest
Re: Testing build #271
« Reply #9 on: October 15, 2010, 11:17:17 PM »
I used to use the previous version before without any issues alongside the PHPBB3.
Then I updated to the beta version of HFS and the problem appeared - so I downgraded and it was fine again.

Then when I updated to the beta to try get that working - again I found nobody could access HFS
(running on a separate port) as they also had cookies from my PHPBB3 forum - and it was the same for me.

It seems whenever the PHPBB3 cookie is present and you try access HFS the page just gets stuck loading - yet clearing the PHPBB3 cookie and refreshing the HFS page makes it load perfectly.

I had a look at the HFS HTML template as that creates a cookie with the 'paged' setting in
(to toggle the pages view option)
so I commented out all the cookie code in the template and tried again but oddly it didn't help at all
- whenever the PHPBB3 cookie was there, trying to access anything hosted with HFS
just kept going forever and never loaded.
(even trying to access a gif hosted by HFS failed - and that doesn't involve the HTML template does it?)

I'm puzzled
- if HFS itself isn't trying to access cookies and nor is the HTML template then why does a PHPBB3 cookie stop you loading anything hosted by HFS?
(the cookie just contains a few IDs for the forum)
Doesn't make sense to me.  ???

Offline SilentPliz

  • Operator
  • Tireless poster
  • *****
  • Posts: 1234
  • ....... chut ! shh!
    • View Profile
Re: Testing build #271
« Reply #10 on: October 16, 2010, 01:19:03 AM »
that's necessarily a folder, i don't think the extra slash will be of any help to the user

Sorry for the inconvenience, you're right ... I confused my setting and the your.
You display the "result" on two lines, me on one, that's why I put the / ... it suited me for what I wanted to do.

 ;)

Aaron

  • Guest
Re: Testing build #271
« Reply #11 on: November 01, 2010, 06:17:54 AM »
can someone create a rename button for the files?
and also a option to overwrite a file that already exists or delete a file on hfs.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Testing build #271
« Reply #12 on: November 01, 2010, 01:08:22 PM »
can someone create a rename button for the files?
and also a option to overwrite a file that already exists or delete a file on hfs.

the default template has these features. I guess you are using a different or customized template. You get notified about this in the bottom bar (also called status bar).
the overwrite is an option in Menu > upload

Offline nukie

  • Occasional poster
  • *
  • Posts: 6
    • View Profile
Re: Testing build #271
« Reply #13 on: November 03, 2010, 08:09:26 PM »
It crashed on me :(

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Testing build #271
« Reply #14 on: November 09, 2010, 05:21:02 PM »
It crashed on me :(

should be fixed in next release (272)

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
« Last Edit: November 09, 2010, 05:31:07 PM by rejetto »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Testing build #271
« Reply #16 on: November 09, 2010, 05:28:50 PM »
I used to use the previous version before without any issues alongside the PHPBB3.
Then I updated to the beta version of HFS and the problem appeared - so I downgraded and it was fine again.

you can see if the problem is in the template by trying a different template, like RAWR.
if the problem disappears, then it's up to the template. (the opposite is not necessarily true)