Author Topic: Testing build #262  (Read 6485 times)

0 Members and 1 Guest are viewing this topic.

Offline Roessi

  • Tireless poster
  • ****
  • Posts: 107
    • View Profile
Re: Testing build #262
« Reply #15 on: July 17, 2010, 04:08:22 AM »
xP
np *g*
the problem is, i dont want the folder "personen" to be displayed on web
so i drag every subfolder of the folder  "personen" into the vfs
as realfolder as an subfolder of Uploads ^^

and in that case when i use %folder-resource%
it doesnt give me the absolute path on the harddrive ( E:\Tools\Hfs\Uploads\Personen\Lissy)
, it gives me an path to the harddisk (E:\Tools\Hfs\Uploads\Lissy) instead
equivalent to the structure of the VFS
but on the harddrive the path doesnt exist :/
xD

Offline SilentPliz

  • Operator
  • Tireless poster
  • *****
  • Posts: 1243
  • ....... chut ! shh!
    • View Profile
Re: Testing build #262
« Reply #16 on: July 17, 2010, 08:22:37 AM »
Ok, I see (but I have not the solution).

I tried to reproduce the same conditions that your VFS ... and I reached the same finding as yours, by examining the macro-log.html file, after an unsuccessful attempt to rename a file.

It's I believe, as I thought; we can use %folder-resource%, only in and from a real folder corresponding to a real absolute path of Windows.

If we displace a real folder in the VFS, from a real folder to another one, but which do not belong in the same absolute path, we can with %folder-resource% display the location information for the folder displaced, but we can not act on it (e.g rename it).

Maybe I'm wrong, but that seems logical ... by proceeding in this way it's like duplicating the information on resource in two places, one path would be real (absolute), but not the one wich we want. :)

I think if there is a workaround, it's in the Delphi code that will find it.

On the condition that I not say some stupid things.

« Last Edit: July 17, 2010, 09:12:23 AM by SilentPliz »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Re: Testing build #262
« Reply #17 on: July 27, 2010, 04:30:30 PM »
ok, i found that commands rename,copy,move were not supporting web paths.
next release will (263).
give it a look http://www.sendspace.com/file/5pi08x
« Last Edit: July 27, 2010, 04:33:06 PM by rejetto »

Offline SilentPliz

  • Operator
  • Tireless poster
  • *****
  • Posts: 1243
  • ....... chut ! shh!
    • View Profile
Re: Testing build #262
« Reply #18 on: July 27, 2010, 11:36:22 PM »
give it a look http://www.sendspace.com/file/5pi08x

Everything is ok now.
The "bug" reported by Roessi seems fixed with your modifications.

Thanks  ;)
« Last Edit: July 28, 2010, 02:00:59 PM by SilentPliz »