Author Topic: I used AppToService to make hfs.exe run as a service. I cannot access hfs site  (Read 6847 times)

0 Members and 1 Guest are viewing this topic.

Offline dragon_ex

  • Occasional poster
  • *
  • Posts: 58
    • View Profile
I used AppToService to make hfs.exe run as a service. I have done this job successfully.

A service named "ApptoService hfs" runned correctly. See the image below:


and I've checked the TASKMANAGER , the hfs.exe was runned correctly by the service "ApptoService hfs".


So, I typed the URL of my HFS Site  http://10.0.255.5:8888  in IE . ( I had changed the TCP port to 8888 early)

Failed! I cannot access the web site.

How can I solve the problem?
« Last Edit: June 13, 2010, 09:28:41 AM by dragon_ex »

Offline Mars

  • Operator
  • Tireless poster
  • *****
  • Posts: 1895
    • View Profile
localy you have to use the url http://127.0.0.1:8888

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
since you cannot see the HFS window while it is running as a service, use a program like this to see the port it is actually listening to
http://technet.microsoft.com/en-us/sysinternals/bb897437.aspx

Offline dragon_ex

  • Occasional poster
  • *
  • Posts: 58
    • View Profile
localy you have to use the url http://127.0.0.1:8888

No. I tried to access hfs website on a client in a LAN, not on the server.

Offline dragon_ex

  • Occasional poster
  • *
  • Posts: 58
    • View Profile
since you cannot see the HFS window while it is running as a service, use a program like this to see the port it is actually listening to
http://technet.microsoft.com/en-us/sysinternals/bb897437.aspx


I have tried the tool you suggested, But I find no program with port 8888 listening in the tool.


But in the TASKMANAGER , I indeed saw that hfs.exe was running in backgroud.


By the way,I tried an experiment like below:

With the hfs.exe running in backgroud, I manually double clicked the hfs.exe to run it.
And then, there were two hfs.exe running ,which was showed in the TASKMANAGER window. the one was started by the "ApptoServerice hfs" service ,and the other one was started by myself manually just then.
In this condition, I can access the hfs website on client in LAN with URL 10.0.255.5:8888

It seemed that the hfs.exe which was started by the  "ApptoServerice hfs" service did not work correctly,while the one I started manually had taken effect.

What should I do now?

Offline maverick

  • Tireless poster
  • ****
  • Posts: 1052
  • Computer Solutions
    • View Profile
Sounds to me like you have something blocking access to app2service hfs and port 8888 on your computer system.

Check your firewall settings and make sure to allow access to hfs on port 8888 when using app2service.  Check other computer applications that run in the background on your system to make sure access isn't blocked to that port.
maverick

Offline dragon_ex

  • Occasional poster
  • *
  • Posts: 58
    • View Profile
Sounds to me like you have something blocking access to app2service hfs and port 8888 on your computer system.

Check your firewall settings and make sure to allow access to hfs on port 8888 when using app2service.  Check other computer applications that run in the background on your system to make sure access isn't blocked to that port.


But when I started hfs.exe manually,everything went well。 And, when I manually started hfs.exe,a window of hfs.exe appeared.

On the contrary, the hfs.exe running in background which was started by the service “ApptoService hfs”  took no effect。Also, no windows came out.

Offline maverick

  • Tireless poster
  • ****
  • Posts: 1052
  • Computer Solutions
    • View Profile

I just tried it here.  Everything works perfectly.
1.  HFS vfs loads automatically at bootup.
2.  App2service and HFS show up in Windows Services and Task Manager.
3.  The HFS icon is in the system tray.  I can access the HFS gui like normal.
4.  No problem at all.

Try a different port like 80 to see if the problem goes away.
maverick

Offline dragon_ex

  • Occasional poster
  • *
  • Posts: 58
    • View Profile
I just tried it here.  Everything works perfectly.
1.  HFS vfs loads automatically at bootup.
2.  App2service and HFS show up in Windows Services and Task Manager.
3.  The HFS icon is in the system tray.  I can access the HFS gui like normal.
4.  No problem at all.

Try a different port like 80 to see if the problem goes away.

I think I should post the whole course snapshots of my operating to show if I did something wrong.  ( I did all steps of making hfs.exe run as a service again, keeping using the TCP port 8888,for the TCP port 80 was already used by another web application on the same server)

By the way, my OS is Windows server 2003 R2 X64 Enterprise Edition.
« Last Edit: June 22, 2010, 10:13:13 AM by dragon_ex »

Offline dragon_ex

  • Occasional poster
  • *
  • Posts: 58
    • View Profile
I just tried it here.  Everything works perfectly.
1.  HFS vfs loads automatically at bootup.
2.  App2service and HFS show up in Windows Services and Task Manager.
3.  The HFS icon is in the system tray.  I can access the HFS gui like normal.
4.  No problem at all.

Try a different port like 80 to see if the problem goes away.



But I see nothing relatived to hfs.exe in the System tray. And I also cannot access the website through port 8888.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Also, no windows came out.

that's normal.
services have no windows.

I have tried the tool you suggested, But I find no program with port 8888 listening in the tool.

check for any listening port by HFS. If you find no port, then the server is not working, and othere tests are useless.
you must find why it is not working, like firewall, permissions, working directory, etc.

Offline dragon_ex

  • Occasional poster
  • *
  • Posts: 58
    • View Profile
that's normal.
services have no windows.

check for any listening port by HFS. If you find no port, then the server is not working, and othere tests are useless.
you must find why it is not working, like firewall, permissions, working directory, etc.

Dear rejetto admin

From the above,the screenshots of the course,can you tell me what my fault was?  

But it is strange that ,when I logined Windows with administrator account and I double clicked HFS.exe to manually run it, a window of HFS appeared and I could successfully access the HFSwebsite with http://10.255.5:8888 on any clients in my LAN. In this situation, it seemed that there were nothing wrong with HFS,such as firewall permissions or working directory or any more~

Why?
« Last Edit: June 22, 2010, 04:02:55 PM by dragon_ex »

Offline maverick

  • Tireless poster
  • ****
  • Posts: 1052
  • Computer Solutions
    • View Profile
This is a HFS forum.  The problem is not with HFS.  I proved it above in my reply where I ran HFS as a service.

The problem is in your system somewhere.  If the HFS icon does not show up in your system tray, your system can't find it so it could be a path problem.

According to one of your screenshots above, you installed app2service to e:/Http_File_Server/hfs.exe and it started successfully.  Now all you have to do is make sure your system can find the hfs working directory on your drive e:\ and that should solve your problem.
« Last Edit: June 23, 2010, 01:59:55 AM by maverick »
maverick

Offline dragon_ex

  • Occasional poster
  • *
  • Posts: 58
    • View Profile
This is a HFS forum.  The problem is not with HFS.  I proved it above in my reply where I ran HFS as a service.

The problem is in your system somewhere.  If the HFS icon does not show up in your system tray, your system can't find it so it could be a path problem.

According to one of your screenshots above, you installed app2service to e:/Http_File_Server/hfs.exe and it started successfully.  Now all you have to do is make sure your system can find the hfs working directory on your drive e:\ and that should solve your problem.

First of all,Thank you for your patient replies all along these days.

How should I understand these words "Now all you have to do is make sure your system can find the hfs working directory on your drive e:\" ?
Give some explanation?
« Last Edit: June 23, 2010, 06:12:55 AM by dragon_ex »

Offline dragon_ex

  • Occasional poster
  • *
  • Posts: 58
    • View Profile
Now problem seemed to be solved。But there are still some strange things. Please Look at the TCPVIEW window below


From the TCPVIEW window, I could see HFS.exe which was started by "AppToService HFS" service was listening to the standard http tcp port 80. How funny it is!!!  Everybody on the earth knows that I had changed the port to 8888!


Igoring this , I typed "http://10.0.255.5" in browser to have a try, Aha~ HFS Web page appeared, although, I could not see my shared files! 【hfs.exe did not automatically load vfs】


So,there are 3 problems:

1、What should I do to make vfs automatically be loaded at "AppToService hfs" service startup?
2、Although I had changed TCP Port to 8888 manually in hfs window,saved file system and saved options, why was hfs.exe started by  "AppToService HFS" service  listening to TCP 80???
3、After I double clicked hfs.exe to run it,there were 2 "hfs.exe"s running in the backgroud. In this situation, I could access hfs webpage with both TCP port 80 and port 8888。When using TCP 80, I could not see my shared files(it seem that vfs was not correctly loaded), while when I use port 8888 ,I  could open the hfs page and see my shared files successfully.
 
« Last Edit: June 23, 2010, 07:19:15 AM by dragon_ex »