Author Topic: I used AppToService to make hfs.exe run as a service. I cannot access hfs site  (Read 6715 times)

0 Members and 1 Guest are viewing this topic.

Offline maverick

  • Tireless poster
  • ****
  • Posts: 1052
  • Computer Solutions
    • View Profile
First of all, look at the following HFS menu items in expert mode...
1.  menu -> start/exit -> make sure 'only 1 instance' is checked.
2.  menu -> tray icons -> make sure 'show main tray icon is checked.

One of the very first things that should happen when you bootup is you should see the HFS popup loading the virtual file system.  You aren't seeing this.

When you double click on hfs.exe you are actually bypassing apptoservice by running another copy of HFS and that is probably the one that shows up on port 80 because port 80 is the default.  This other copy isn't configured to use port 8888.  That is not what you should do.  Make those menu changes I mention above which includes 'only one instance'.

You have to many things going on here that are causing your problems and they have to do with installation and configuration.

I would suggest you START OVER.
1. Save your virtual file system to a file and Exit from HFS.  If HFS works correctly with IP localhost on port 8888 and there is no problem with your virtual file system you should be ok there.  If there are problems with HFS or your virtual file system, re-install it.
2. Remove the app2service from services and re-configure it.  Reboot to clear the cache.   Make sure that the path to the HFS working directory is correct.  Otherwise, your computer won't be able to find your virtual file system to load at bootup.  If that doesn't happen you will have the same type of problem.
3. It might be a good idea to move the HFS working directory to another drive like c:\
4. When finished configuring apptoservice, Reboot.  Go to Windows Services and make sure apptoservice is set to 'automatic' in properties.  Also in properties check the path to see if it is correct.
5. Reboot again and cross your fingers that it works.
« Last Edit: June 23, 2010, 08:23:49 AM by maverick »
maverick

Offline dragon_ex

  • Occasional poster
  • *
  • Posts: 58
    • View Profile
First of all, look at the following HFS menu items in expert mode...
1.  menu -> start/exit -> make sure 'only 1 instance' is checked.
2.  menu -> tray icons -> make sure 'show main tray icon is checked.

One of the very first things that should happen when you bootup is you should see the HFS popup loading the virtual file system.  You aren't seeing this.

When you double click on hfs.exe you are actually bypassing apptoservice by running another copy of HFS and that is probably the one that shows up on port 80 because port 80 is the default.  This other copy isn't configured to use port 8888.  That is not what you should do.  Make those menu changes I mention above which includes 'only one instance'.

You have to many things going on here that are causing your problems and they have to do with installation and configuration.

I would suggest you START OVER.
1. Save your virtual file system to a file and Exit from HFS.  If HFS works correctly with IP localhost on port 8888 and there is no problem with your virtual file system you should be ok there.  If there are problems with HFS or your virtual file system, re-install it.
2. Remove the app2service from services and re-configure it.  Reboot to clear the cache.   Make sure that the path to the HFS working directory is correct.  Otherwise, your computer won't be able to find your virtual file system to load at bootup.  If that doesn't happen you will have the same type of problem.
3. It might be a good idea to move the HFS working directory to another drive like c:\
4. When finished configuring apptoservice, Reboot.  Go to Windows Services and make sure apptoservice is set to 'automatic' in properties.  Also in properties check the path to see if it is correct.
5. Reboot again and cross your fingers that it works.



Thank you very much!

I did all the steps again.And I am comfirmed in these things below:
1.  menu -> start/exit -> 'only 1 instance' is checked.
2.  menu -> tray icons -> 'show main tray icon is checked.
3.  I moved e:\hfs to c:\
4.  I configured app2service again
5.  I have made "apptoservice hfs" service "automatic", and I am sure that the path of hfs.exe and apptoservice.exe is correct.
6.  I can access hfs webpage on localhost on TCP 8888  when a manually launched instance of ”hfs.exe“ existed and webpage correctly showed files I shared.
7.  I saved vitual file system to a file named "share.vfs" in the same directory of hfs.exe.

And then I rebooted system. What I saw are listed below:
1. After I login Windows with an administrator account,there wasn's popup loading the virtual file system
2. I saw hfs.exe and apptoservice.exe were running in the Taskmanager
3. I saw in the Service managment window, "Apptoservice hfs" was running
4. I launched TCPVIEW.exe and I saw hfs.exe was running and listening to TCP port "SERVERNAME:http" ,not "SERVERNAME:8888"
5. On a workstation in the LAN, I could access http://10.0.255.5 not http://10.0.255.5:8888
6. Webpage "http://10.0.255.5" showed no files I shared. It did not load vfs
8. Although menu -> start/exit -> 'only 1 instance' is checked, I could also launched another instance of hfs.exe,and then " http://10.0.255.5:8888" took effect and showed the very files I shared.


From all the facts above, I come to these conclutions below:

1. Although I set TCP port to 8888, the instance starting in the form of a service will still use TCP 80 as its listening port.
2. At least  two instances of hfs.exe can work correctly in the same time if the two instances use different TCP port for listening. And you can successfully access the webpage of either instance when you use the right TCP port
3. "AppToService hfs" service won't load virtual file system file on its startup.

Please help me,Thank you so much!

Offline Wasserfloh

  • Occasional poster
  • *
  • Posts: 81
    • View Profile
Switch to Expert Mode and  Menu > Save options > to file

Offline maverick

  • Tireless poster
  • ****
  • Posts: 1052
  • Computer Solutions
    • View Profile
Check these HFS menu settings....

1. Menu -> load recent files -> select -> 'share.vfs'
2. Menu -> start/exit -> select -> 'reload on startup VFS file previously open' and select -> 'auto-save vfs on exit'
maverick

Offline dragon_ex

  • Occasional poster
  • *
  • Posts: 58
    • View Profile
Thank  maverick Wasserfloh and rejetto very much!!!

Especially appreciate maverick's patient replies in my troubleshooting!!!

I announce that the problem has been absolutely sovled by Wasserfloh's way.

Options must be saved to file ,thus options,including TCP port settings and virtual file system loading, can take effect when hfs.exe starts in the form of a service.
Saved in registry,  options  cannot take effect when hfs.exe starts in the form of a service with the SYSTEM account. In this situation,options only work with the instance of hfs.exe launched with current desktop USER account.
So, remember, service form of "hfs.exe" works correctly only with "hfs.ini" which stores all your HFS options.
« Last Edit: June 23, 2010, 04:10:37 PM by dragon_ex »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
right, probably because options are saved by default to the user space (in the registry), and services run (by default) with a different user.


so, my advice of changing the service's user could have solved as well.

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 864
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1