Author Topic: Problems with invisibility exploit  (Read 1821 times)

0 Members and 1 Guest are viewing this topic.

Offline alkimiya

  • Moderator
  • Tireless poster
  • *****
  • Posts: 315
    • View Profile
Problems with invisibility exploit
« on: June 29, 2003, 01:00:04 AM »
It seems I get invisible to ANY user when checking automsgs whether they're away, online, invisible or offline. I.e. the +invisible or -visible is sent but not altering the invisibility/visibility lists.

Also.. when the client uses ICQ2GO an ICBM Error (family 9)  is received telling you that the client doesn't understand msgtype 2. This is shown in &rq as if the contact is offline (when invisible).

Please fix this soon as we cannot check automsgs anymore.
I'll revert to .12 until then.

Offline alkimiya

  • Moderator
  • Tireless poster
  • *****
  • Posts: 315
    • View Profile
Problems with invisibility exploit
« Reply #1 on: June 29, 2003, 01:10:50 AM »
Also.. a suggestion.

There really is no need to send the -invis+invis/+vis-vis packets until you know if the person is invisible or not. If he/she is is invisible (works with automsg responses as well) AND you should not be visible to him/her then and only then send them.

nihilanth

  • Guest
Problems with invisibility exploit
« Reply #2 on: June 29, 2003, 12:12:34 PM »
i think i have the same problem...i get invisible to all users i read the away message....but i got no errors....i'll go back to 0.9.4.12

cu nihilanth

Offline alkimiya

  • Moderator
  • Tireless poster
  • *****
  • Posts: 315
    • View Profile
Problems with invisibility exploit
« Reply #3 on: June 29, 2003, 12:26:57 PM »
Quote from: "nihilanth"
i think i have the same problem...i get invisible to all users i read the away message....but i got no errors....i'll go back to 0.9.4.12

cu nihilanth

the error is shown in the log window.. it's an error packet sent from the icq server, not an error in &rq.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Problems with invisibility exploit
« Reply #4 on: June 29, 2003, 04:54:13 PM »
all fixed in 0.9.4.14