rejetto forum

Running HFS as a service in XP

0 Members and 1 Guest are viewing this topic.

Offline WhereEaglesDare

  • Occasional poster
  • *
    • Posts: 17
    • View Profile
Hey guys, I've been working with HFS for a while, recently my server lost power and required a login to start HFS again.  I need HFS and sTunnel to run as a service.

I used the following batch file to install the service:

ECHO OFF
CLS
ECHO "INSTALLING SERVICE"

sc create HFS-4300 binPath= "G:\Server\HFS - Port 44300\HFS - Port 44300.exe"

PAUSE

it follows with success or something like that.

and I checked the services panel under my control panel and it was there, sat to automatic and should have started HFS upon startup without a login, but it doesn't.  I did the same for my sTunnel software with no success.  Any help?


Offline crazyboris

  • Tireless poster
  • ****
    • Posts: 140
    • View Profile
why dont you just put them in autostart folder..
i do that on my server and it works perfect.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13275
    • View Profile
if you search the forum you will find several working solutions for "services".
i remember microsoft gave a 2-programs solution (instsrv+srvany), maybe this "sc" command is replacing just one of them.

for those who have low security needs at home, they can auto-login their windows user, so that the startup is run automatically.
an additional step may be to auto-lock the computer after the startup has finished. you can use nircmd to do this: nircmd lockws
« Last Edit: June 11, 2009, 10:41:59 AM by rejetto »


Offline cmatte

  • Occasional poster
  • *
    • Posts: 31
    • View Profile
    • ErMeglio WebSite
i remember microsoft gave a 2-programs solution (instsrv+srvany), maybe this "sc" command is replacing just one of them.
Just some days ago I tried this MS solution with no luck.
HFS did run, but it did not "read" the same permissions left there when I opened HFS normally and configured it.
It simply run with the default options, so it ""worked"" with no personalized port, settings, shares, users.
This could be understood letting the service interact with desktop (it's an option in the service properties), to see the hfs application after agreeing to see "a service message" hidden in the background: windows opens an empty environment with HFS only and you can see what happens there.

Well, gotta say I had similar problems with another network service which shares my media for the PS3. It could not read the folders it had to share: it wrote in the logs the folders did not exist. I solved adding a permission in the interested folders' properties for "SYSTEM" to allow this "user" to read the files over there.
I'd guess all the trick would work if you do the same with HFS, its VFS, its settings in the ini file, and all the shares...
« Last Edit: June 11, 2009, 05:56:36 PM by cmatte »


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13275
    • View Profile
yes, it must be something about permissions or "working folder".