Author Topic: Testing build #199  (Read 2921 times)

0 Members and 1 Guest are viewing this topic.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12931
    • View Profile
Testing build #199
« on: September 01, 2008, 11:00:48 PM »
i messed around a little too much with the code, i hope i didn't introduce any major problem :P

download @ www.dovedove.it/hfs/hfs199.exe

what's new
+ Menu -> HTML template -> "Enable macros"
+ "Restore default" template disabled when template is not customized
+ show header(http_x_forwarded_for) instead of IP, but only if IP in a customizable ip-mask (127.0.0.1 by default) www.rejetto.com/forum/?topic=5811
* Renamed "Quit without asking to save" -> "Force quitting (no dialogs)"
- menu with IE broken in build #198
- ini command "load-tpl-from" now works as "change file" for template
- error pages used resources not necessarily available www.rejetto.com/forum/?topic=6097

Offline TEA-Time

  • Occasional poster
  • *
  • Posts: 48
    • View Profile
Re: Testing build #199
« Reply #1 on: September 02, 2008, 05:20:10 PM »
Hi rejetto,

I'm getting this error when the No-IP dynamic DNS updater tries to update.  It worked fine in 198.  I'll try 200 here in a few.

Access violation at address 0053F60C in module 'hfs.exe'. Read of address 00000030
HFS 2.3 beta (199)
----------------------------------------------------------------
Stack list, generated 9/2/2008 10:10:27 AM
[0053F60C]{hfs.exe     } main.TmainFrm.add2log (Line 4695, "main.pas" + 28) + $3D
[00500055]{hfs.exe     } GIFImage.TGIFImage.Optimize (Line 11499, "zlibex.pas" + 160) + $E
[00533DBE]{hfs.exe     } main.updateDynDNS (Line 2096, "main.pas" + 9) + $2C
[0054DE04]{hfs.exe     } main.everySec (Line 7576, "main.pas" + 13) + $0
[0054E4B2]{hfs.exe     } main.everyTenth (Line 7708, "main.pas" + 45) + $15
[0054E5ED]{hfs.exe     } main.TmainFrm.timerEvent (Line 7731, "main.pas" + 19) + $F
[0045ACAB]{hfs.exe     } ExtCtrls.TTimer.Timer (Line 2250, "ExtCtrls.pas" + 1) + $13
[0045AB17]{hfs.exe     } ExtCtrls.TTimer.WndProc (Line 2208, "ExtCtrls.pas" + 4) + $7
[0042AB9C]{hfs.exe     } Classes.StdWndProc (Line 11572, "classes.pas" + 8) + $0
[0046C410]{hfs.exe     } Controls.FindControl (Line 2103, "Controls.pas" + 6) + $C
[00494DB2]{hfs.exe     } Forms.TApplication.ProcessMessage (Line 7670, "Forms.pas" + 23) + $4
[00494DF7]{hfs.exe     } Forms.TApplication.HandleMessage (Line 7689, "Forms.pas" + 1) + $6
[00495092]{hfs.exe     } Forms.TApplication.Run (Line 7773, "Forms.pas" + 16) + $3
[0056288F]{hfs.exe     } hfs.hfs (Line 94, "" + 21) + $2
----------------------------------------------------------------
System   : Windows XP Home Edition, Version: 5.1, Build: A28, "Service Pack 2"
Processor: Intel,          Mobile Intel(R) Celeron(R) CPU 1.50GHz, 1500 MHz MMX
Display  : 1024x768 pixels, 32 bpp
----------------------------------------------------------------
----------------------------------------------------------------
Product Versions

hfs.exe: Build: 0 9/1/2008 11:00:08 PM
hfs.v2.2d.exe: Build: 0 2/4/2008 12:48:18 AM

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12931
    • View Profile
Re: Testing build #199
« Reply #2 on: September 02, 2008, 09:00:24 PM »
you'll find this problem fixed in #201