rejetto forum

Adding HFS to Shell context menu

selkov · 33 · 13363

0 Members and 1 Guest are viewing this topic.

Offline selkov

  • Tireless poster
  • ****
    • Posts: 120
    • View Profile
Mars, Either that command does not work or i could not interpret its usage correctly.
That did not fix either of my issues.
FYI: HFS is installed to  [H:\HFS]

Can you tell me how to paste an image into this thread and i will supply a pic of the setup screen?




Offline selkov

  • Tireless poster
  • ****
    • Posts: 120
    • View Profile
Whooo,Who
Success.
Syntax was tricky.
Think it was more a Firedaemon sytanx than HFS.
But the "Add to HFS works"   Whooo Who.

Thanks.


Offline MarkV

  • Tireless poster
  • ****
    • Posts: 760
    • View Profile
I know that this issue is resolved, I just have a remark to the 'HFS.ini' thingy:

Services by default write their .ini files to the \Windows\System32 directory. The main reason beeing that directory is the working directory of the service manager (svchost.exe) and probably of Firedaemon, too.
http://worldipv6launch.org - The world is different now.


Offline selkov

  • Tireless poster
  • ****
    • Posts: 120
    • View Profile
That is true. However I assume that is why the Firedaemon set allows to set a working directory. Must be for the service. I then ALSO needed to point HFS there for its path.....all seems good now


Offline selkov

  • Tireless poster
  • ****
    • Posts: 120
    • View Profile
OK...I am now totally confused and truly frustrated.

As I posted earlier, I got this to work, but on the XP pc.
I went to do so also on the w2k pc and it will NOT work.....
Even when I exported the config file from the XP pc it does not work.
Somehow I an not getting the proper path statement.....

How can I post a pic here so that I can show you what I am doing?



Also,  this is the info from the manual regarding paths:
-i <PATH>  load/save hfs.ini in folder <PATH>

Is this a command line parameter or is it in the .ini file?
« Last Edit: March 14, 2008, 02:09:06 PM by selkov »


Offline MarkV

  • Tireless poster
  • ****
    • Posts: 760
    • View Profile
Simply attach the image to your post.
http://worldipv6launch.org - The world is different now.


Offline selkov

  • Tireless poster
  • ****
    • Posts: 120
    • View Profile
Here is the setup screen for the Daemon service.
under parameters i have tried with and without quotes....does not make a differance.



Offline MarkV

  • Tireless poster
  • ****
    • Posts: 760
    • View Profile
Here is the setup screen for the Daemon service.
under parameters i have tried with and without quotes....does not make a differance.



No brackets, they are only for emphasize.

-i H:\HFS
« Last Edit: March 19, 2008, 04:45:27 PM by MarkV »
http://worldipv6launch.org - The world is different now.



Offline selkov

  • Tireless poster
  • ****
    • Posts: 120
    • View Profile
I tried:

"-i H:\HFS\"
"-i H:\HFS"
-i H:\HFS\
-i H:\HFS

And none worked.


Offline MarkV

  • Tireless poster
  • ****
    • Posts: 760
    • View Profile
There are no spaces in the path, so there should be no quotes needed. And the parameter -i is never included in the quote.

Try -i "H:\HFS". If it does still not work, try saving to registry instead of file.

Q: Under which account do the services created by FD run?
http://worldipv6launch.org - The world is different now.


Offline selkov

  • Tireless poster
  • ****
    • Posts: 120
    • View Profile
Sadly that did not work either.
There is only 1 account on this pc, admin.
Saving to the registry also does not work as it will not remember the path correctly. That is why i am trying to specify its location.


LET ME CLARIFY...
Using the parameter -i H:\hfs it does correctly update and store the INI file in the folder I specify.
The problem i am getting is when I use the shell extension to "Add To HFS" I still get a monolib error.

I am quite sure this is related to the path / working directory because when I start HFS manually it works fine. The problem only occurs when I use Firedaemon to start it. I really want to use Firedaemon so I can be sure that HFS is always running. But in reading thru the tutorial , I think, it seems there is some way to have it turn itself on when a call is made. is this true? My purpose is that i am using HFS to support a forum. I need to be sure that when a member or guest chooses a link that HFS will deliver. that is why I choose to run it as a service.

So is there another way to accomplish this?

If I have not said it before, thank you for all your help. All of you.
 
« Last Edit: March 20, 2008, 01:00:24 PM by selkov »



Offline Mars

  • Operator
  • Tireless poster
  • *****
    • Posts: 1985
    • View Profile
Yes, your problem is engendered by the use of two different accounts for the execution of hfs and the use of ' add to hfs ',

If you look at the account used to launch hfs, by using taskmgr.exe (process), and that the answer is: system, then it is impossible to use ' Add to HFS ' correctly in reasons of authorizations on the processes in memory.


Offline selkov

  • Tireless poster
  • ****
    • Posts: 120
    • View Profile
MARS,


Thank you so much. Now I understand the reason it will not work. I have confirmed what you thought is correct. Now I can try to solve this problem!

Thanks