Author Topic: Testing build #174  (Read 13269 times)

0 Members and 1 Guest are viewing this topic.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Re: Testing build #174
« Reply #15 on: January 19, 2008, 02:40:01 PM »
Hello you people having the problem at address 00555690 :)
Sorry for the problem.
I need to know if you have any *.md5 file in your folders (the ones you have in the virtual file system)

Offline Giant Eagle

  • Tireless poster
  • ****
  • Posts: 535
  • >=3 RAWR!
    • View Profile
    • RAWR-Designs.com
Re: Testing build #174
« Reply #16 on: January 19, 2008, 04:30:19 PM »
can rename be used to replace items?

e.g. rename "test.zip" to "../test.zip"?


Also, is there an option to set "no delete" or "Read only" to files and folders. So that i can't accidently press the delete button on my shared D:\ drive
« Last Edit: January 19, 2008, 04:33:04 PM by Giant Eagle »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Re: Testing build #174
« Reply #17 on: January 19, 2008, 04:33:34 PM »
replace? i think it won't overwrite. you'll need to delete first.

what "delete button" are you talking of?

Offline Giant Eagle

  • Tireless poster
  • ****
  • Posts: 535
  • >=3 RAWR!
    • View Profile
    • RAWR-Designs.com
Re: Testing build #174
« Reply #18 on: January 19, 2008, 04:36:25 PM »
Quote
what's new
+ new template macros: add folder, set item, postvar, delete, rename, random number

Or is it not related to files?

Offline blackmetal

  • Occasional poster
  • *
  • Posts: 9
    • View Profile
Re: Testing build #174
« Reply #19 on: January 19, 2008, 05:07:07 PM »
Ey rejetto the problems concerns this build. Updating to this build was the source of all my problems. I was getting errors each second. When a beta was not working, i would use the stable one. Same thing. Same errors. I mean when someone downloads from me, HFS freezes. I had to unistall all versions of HFS on my PC n reinstall them. Now I have only one version n its the #174 one. I hope it'll be ok. When getting the errors with the older builds(#165...etc), I just had to close the error n it was fine. Now when I get the errors with build #174, it crashes everything. When I got these errors, I happen to look at how many connections were there in HFS. Holy god!!!! I set max connections to 20 and max download from single ip to 2. The same ip was using all 20 connections. I removed the limit of max connections n guess what???? It increased to 310 n then HFS freezes. Think it has increased to a greater number. I think the bug is there. When someone uses download manager, it creates the problem. I'm not an expert but I guess so.

Offline TCube

  • Tireless poster
  • ****
  • Posts: 445
    • View Profile
Re: Testing build #174
« Reply #20 on: January 19, 2008, 09:52:57 PM »
Quote
On httpEvent(6)
Access violation at address 00555690 in module 'hfs.exe'. Read of address 00000000

dito overhere : started at 171 then upper to the latest.  So I had to go back to #169.
Happened when I moved out - then put back - a whole HD directory [same external HD with HFS on] no matter real or virtual - 
At #169 I can still move out & back in with no problem.

Edit

Quote
I need to know if you have any *.md5 file in your folders (the ones you have in the virtual file system)

Yes, removed md5 files and now works with #174 - virtual /real out & back in.

TCube
« Last Edit: January 19, 2008, 10:02:29 PM by TCube »
Make it idiot-proof and I will make a better idiot

Offline Mars

  • Operator
  • Tireless poster
  • *****
  • Posts: 1899
    • View Profile
Re: Testing build #174 missing
« Reply #21 on: January 20, 2008, 12:04:21 AM »
Rejetto will know about what I want to speak

function setItem()

{{set item | filename | [no log|hide|hide tree)] }}

if cmd = 'hide tree' then
    include(f.flags, FA_HIDDENTREE);

Offline blackmetal

  • Occasional poster
  • *
  • Posts: 9
    • View Profile
Re: Testing build #174
« Reply #22 on: January 20, 2008, 12:42:45 PM »
Code: [Select]
############# ERROR ON: 1/20/2008 4:35:09 PM
E:\Documents and Settings\blackmetal\Desktop\hfs174.exe
Access violation at address 00404568 in module 'hfs174.exe'. Read of address
FFFFFFDD
HFS 2.3 beta (174)
----------------------------------------------------------------
Stack list, generated 1/20/2008 4:35:07 PM
(00003568){hfs174.exe  } [00404568]
(00141982){hfs174.exe  } [00542982]
(000AA160){hfs174.exe  } [004AB160]
(000AA323){hfs174.exe  } [004AB323]
(00057CAB){hfs174.exe  } [00458CAB]
(00057B17){hfs174.exe  } [00458B17]
(0002A3CC){hfs174.exe  } [0042B3CC]
(00069410){hfs174.exe  } [0046A410]
(00091DB2){hfs174.exe  } [00492DB2]
(00091DF7){hfs174.exe  } [00492DF7]
(00092092){hfs174.exe  } [00493092]
(001575BB){hfs174.exe  } [005585BB]
----------------------------------------------------------------
System   : Windows XP Professional, Version: 5.1, Build: A28, "Service Pack 2"
Processor: Intel,               Intel(R) Pentium(R) 4 CPU 1.70GHz, 1700 MHz MMX
Display  : 800x600 pixels, 32 bpp
----------------------------------------------------------------
----------------------------------------------------------------
Product Versions

169.21_forceware_winxp_32bit_international_whql.exe:4.0.100 Build: 1190 1/20/2008
11:53:58 AM
Combined-Community-Codec-Pack-2007-07-22.exe:0.0.0 Build: 0 1/20/2008 9:44:24 AM
hfs174.exe: Build: 0 1/19/2008 9:18:14 PM
### END LOG



What version should I use to stop getting these errors?????????

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Re: Testing build #174
« Reply #23 on: January 20, 2008, 06:24:07 PM »
Or is it not related to files?

rename is for files, yes. it is not related to the VFS.

{{set item | filename | [no log|hide|hide tree)] }}

ok

Offline westwoon

  • Occasional poster
  • *
  • Posts: 18
    • View Profile
Re: Testing build #174
« Reply #24 on: January 22, 2008, 12:25:04 PM »
After I download the HFS build #174, then I run it after exit the HFS build #165. I dint encounter any problem at all. But me now very scared about the error that blackmetal mention earlier, seem like very serious. :-[ :-[ Until now i dint see any error appear. Anyway, anyone can teach me how to use the rename, add folder and delete file function? thank  :)

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Re: Testing build #174
« Reply #25 on: January 22, 2008, 01:55:22 PM »
I forgot to say, set item and add folder, are macros meant to be used by template makers inside section [special:import]
Could you please TSG post the example code?

Offline SilentPliz

  • Operator
  • Tireless poster
  • *****
  • Posts: 1243
  • ....... chut ! shh!
    • View Profile
Re: Testing build #174
« Reply #26 on: January 22, 2008, 05:03:14 PM »
I forgot to say, set item and add folder, are macros meant to be used by template makers inside section [special:import]
Could you please TSG post the example code?


[special:import]
{{add folder|real|template}}
{{set item|/template|hide}}
{{set item|/template|no log}}

« Last Edit: January 22, 2008, 06:52:10 PM by SilentPliz »

Offline westwoon

  • Occasional poster
  • *
  • Posts: 18
    • View Profile
Re: Testing build #174
« Reply #27 on: January 23, 2008, 05:01:44 AM »


[special:import]
{{add folder|real|template}}
{{set item|/template|hide}}
{{set item|/template|no log}}



Sorry~~ me here still duno how to use the function  :-\ could any1 explain further more specific please?  :)
« Last Edit: January 23, 2008, 05:03:33 AM by westwoon »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Re: Testing build #174
« Reply #28 on: January 23, 2008, 05:07:07 AM »
You don't have to use it.
It will be included in templates.

jerome

  • Guest
Re: Testing build #174
« Reply #29 on: January 23, 2008, 06:51:56 AM »
Hello everybody,

A little trouble appears on “one” login and pass,
Curiously one login and pass was locked and not working,
Every time you try to register, it show the ~log alert box and the login failed
I returned to 171 to check it on it, same result….
I write again the pass last number, open 174, close, return 171,return174….
And curiously now it works….
This trouble is only on “one” login when all other are working.
Strange ! I have been alerted by a user trying to log in vain who send me a mail.
I have not changed the pass and now all is OK-

We have gremlins hacking HFS ? Or a regedit cleaner*** result? Or a windows joke?
***All is saved in a.tpl  file.( +hfs.ini secured RaR copy) the login's are in.

This is the only trouble encountered on HFS 174, placed in “a clean empty folder” since v169…

A log out button should be cool to test all the pass without closing IE.
( it is not really needed, only useful for a fast live check )