rejetto forum

small bug/inconvinence (0943)&(unofficial0944)

joxy · 11 · 4533

0 Members and 1 Guest are viewing this topic.

Offline joxy

  • Occasional poster
  • *
    • Posts: 88
    • View Profile
in the chatwindow, when i click "close & add to ignore list", the ignored user is not deleted from a contact list.

i think, it is more useful to delete it from a contact list.


Offline joxy

  • Occasional poster
  • *
    • Posts: 88
    • View Profile
another bug/inconvinience: when there is a keyboard activity, &rq does not switch from auto-N/A-on-idle back to online.

imho, it is more convinient to do that.

note: &rq does switch from auto-Away-on-idle back to online.


Offline alkimiya

  • Moderator
  • Tireless poster
  • *****
    • Posts: 315
    • View Profile
Another inconvenience I've noted for quite some time is when the chat window has been open long (with a number of tabs) and I click the close all button I get access violation (actually when I press the downarrow-button next to close). If the chat window is recently opened I won't get the AV.


Offline joxy

  • Occasional poster
  • *
    • Posts: 88
    • View Profile
correction to my post:

&rq does not automatically switch from auto-N/A-on-idle back to online.


Offline Off.Just.Off

  • Occasional poster
  • *
    • Posts: 35
    • View Profile
Quote from: "joxy"
correction to my post:

&rq does not automatically switch from auto-N/A-on-idle back to online.
Hm .... My unofficial 0.9.4.4 did it as well as from "away" ...


Offline joxy

  • Occasional poster
  • *
    • Posts: 88
    • View Profile
okay, one more correction to my post then:

&rq 0943 does not automatically switch from auto-N/A-on-idle back to online.

i did not test "0944unofficial", now testing.


Offline joxy

  • Occasional poster
  • *
    • Posts: 88
    • View Profile
one more thing, 0943+"0944u":

in history, doubleclick on message body does not open a plaintext window with msg text.


Offline joxy

  • Occasional poster
  • *
    • Posts: 88
    • View Profile
correction to my doubleclick on message body post:

- when i click within msg text, it opens
- when i click past end of line (i.e. click the point to the right of the text), it doesn't.  imho, it should.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13308
    • View Profile
i tested the autoexit from autoaway and it worked both in away and NA status

about the 2click on an empty area, i will try to...


Offline joxy

  • Occasional poster
  • *
    • Posts: 88
    • View Profile
Quote
it worked... in... NA status

i just noticed (0944unofficial_old) --

example sequence:

- &rq status: Online
- i go afk for a long time
- &rq sets autoNA
- &rq receives "you are logged on from another computer"
- i return to this &rq instance, and doubleclick system tray icon
- &rq performs login with initial NA status

I dont know how to handle this best.  One way to handle this is:

In the last step of the above sequence, &rq may login with status which is last set by the user.  And not with the on-idle status.


Offline joxy

  • Occasional poster
  • *
    • Posts: 88
    • View Profile
hey rejetto.  thanks for releasing 0944official; good work...

i tested the "(untested)" bugfix for autoexit from auto-N/A-on-idle, it was fixed only partially.

Environment

* dialup modem
* [checked] Auto-reconnect (when conn is lost)
* [unchecked] Connect on conn available
* Auto-away after [1] idle minute
* Auto-N/A after [2] idle minutes
* [checked] Auto-exit from auto-idle status

Sequence 1

This seq shows the correct part of &rq's behavior.

- i manually set X status
- i wait for autoNA
- &rq sets autoNA
- i switch the modem off
- &rq shows Offline status
- i doubleclick the tray icon
- (modem is still not switched on)
- &rq shows Connecting icon; then quickly replaces it by Disconnected icon
- i turn the modem on
- i connect Windows to the ISP
- &rq auto-reconnects its link
- &rq automatically shows the X status

I repeated this seq twice:
* with X=Online, and
* with X=DND

Sequence 2

This seq shows the incorrect part of &rq's behavior.

- i manually set X status
- i wait for autoNA
- &rq sets autoNA
- i switch the modem off
- &rq shows Offline status
- i turn the modem on
- i connect Windows to the ISP
- &rq auto-reconnects its link
- &rq automatically shows the N/A status

I repeated this seq twice:
* with X=Online, and
* with X=DND