Author Topic: Upload broken with small files  (Read 21193 times)

0 Members and 1 Guest are viewing this topic.

Offline Foggy

  • Tireless poster
  • ****
  • Posts: 806
    • View Profile
Re: Upload broken with small files
« Reply #30 on: July 08, 2007, 09:24:53 AM »
Thanks for explaining the problem, I tested uploading 4 different files locally they were of varying size between 42bytes and 10.6kb.
I uploaded 2 of them seperatly and all was fine.
I also uploaded all 4 at once and everything was sucessful.
I was using build 088 on an XP Pro machine with SP2.

I just dont get why it works for some and not for others. ???

Offline maverick

  • Tireless poster
  • ****
  • Posts: 1052
  • Computer Solutions
    • View Profile
Re: Upload broken with small files
« Reply #31 on: July 08, 2007, 11:11:09 AM »
I did some testing here too.  Latest build 112.  Uploaded 4 small files ranging in size from 65b to 15kb.  Tried this a few times with different small files.  All files uploaded successfully without error.  WinXP Pro SP2.

I have never seen the problem described in this thread with any version or build.
maverick

Offline Foggy

  • Tireless poster
  • ****
  • Posts: 806
    • View Profile
Re: Upload broken with small files
« Reply #32 on: July 08, 2007, 01:01:32 PM »
KalleB you said you tried on different computers, was there any antivirus\firewall that is on all the computers you tried? it could just be you have some software blocking the upload for some reason.

Offline KalleB

  • Occasional poster
  • *
  • Posts: 97
    • View Profile
Re: Upload broken with small files
« Reply #33 on: July 08, 2007, 01:31:22 PM »
No I don't think those have any effect since bigger files ~500kB and above always succeed...it's only the small ones that fail.

I've tested on two machines with WinXP SP2 Home, HFS b110-112, Firefox, Opera & IE,
other has F-Secure suite and the another Avast & Kerio.

I've mostly used the same machine as client (connecting to 127.0.0.1) but I also tried Kubuntu Feisty with Firefox as client and got the same results... will try it soon also as host using WINE.

EDIT: Using Kubuntu as host..surprise, surprise..uploading works perfect.
« Last Edit: July 08, 2007, 01:45:15 PM by KalleB »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Upload broken with small files
« Reply #34 on: July 17, 2007, 05:59:59 PM »
Please, test the last build and tell me...

Offline KalleB

  • Occasional poster
  • *
  • Posts: 97
    • View Profile
Re: Upload broken with small files
« Reply #35 on: July 17, 2007, 07:24:09 PM »
I wish I could say it's fixed...and I almost did since the first time I tried with 119 it worked! ..BUT any of the tests after that not. No matter if I restart HFS. It's still almost impossible to upload three small files, uploading only two succeeds in about 60% of the cases and one in about 90%.  :-\

But I'm quite happy with the current situation since afterall it's not really HFS bug but something about Windows XP because it works with WINE and not many people (Wasserfloh and me) have reported this...don't let this delay next stable release.

I'll just have to figure out what is the common factor in three of my machines that causes this in them...
« Last Edit: July 17, 2007, 07:27:42 PM by KalleB »

Offline Foggy

  • Tireless poster
  • ****
  • Posts: 806
    • View Profile
Re: Upload broken with small files
« Reply #36 on: July 18, 2007, 02:42:53 AM »
An idea I had but I was too lazy to go back and read the whole thread to see if its been answered already.
What browser are you using?

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Upload broken with small files
« Reply #37 on: July 18, 2007, 02:44:57 AM »
it's written in the first post of the thread

Offline Foggy

  • Tireless poster
  • ****
  • Posts: 806
    • View Profile
Re: Upload broken with small files
« Reply #38 on: July 18, 2007, 03:45:14 AM »
I downloaded the latest version of opera and I started to get the same results as KalleB with some uploading succesfully and others not.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Upload broken with small files
« Reply #39 on: July 18, 2007, 03:46:28 AM »
i use the last opera version too

Offline KalleB

  • Occasional poster
  • *
  • Posts: 97
    • View Profile
Re: Upload broken with small files
« Reply #40 on: July 18, 2007, 09:18:08 AM »
I've tested with Opera9, FF2 and IE7 so I don't think it's has much to do with the browser...
And only thing these machines have in common it the Finnish language setting really :D
« Last Edit: July 18, 2007, 09:32:19 AM by KalleB »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Upload broken with small files
« Reply #41 on: August 18, 2007, 10:02:24 AM »
too many people is getting this problem.
we must find what is causing it, so i can fix it  :'(

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Upload broken with small files
« Reply #42 on: August 31, 2007, 03:13:01 PM »
Guys... we need to test build #128
there is a chance it was fixed.

Offline Wasserfloh

  • Occasional poster
  • *
  • Posts: 81
    • View Profile
Re: Upload broken with small files
« Reply #43 on: September 01, 2007, 12:49:28 AM »
Problem continues to exist here unfortunately.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Upload broken with small files
« Reply #44 on: September 01, 2007, 01:39:24 PM »
 :'(
someone else reported it was fixed
can you confirm you tested build #128 please?