Author Topic: Upload broken with small files  (Read 21567 times)

0 Members and 1 Guest are viewing this topic.

Offline Wasserfloh

  • Occasional poster
  • *
  • Posts: 81
    • View Profile
Upload broken with small files
« Reply #15 on: July 04, 2007, 11:03:47 PM »
can you test 2.0b ? www.rejetto.com/files/hfs/hfs2.0b.zip
The problem exists also here.

can i also ask you how did you set the default options for the test? the best way is to hold the SHIFT key while HFS starts. but this way you will loose your settings if you do not backup before.
That does not make a difference.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Upload broken with small files
« Reply #16 on: July 04, 2007, 11:07:22 PM »
version 2.0 is 2 years old
i wonder why only now people came with this problem  :-\

i see you are testing on 127.0.0.1
what if you try over a network? (LAN or internet)

Offline Wasserfloh

  • Occasional poster
  • *
  • Posts: 81
    • View Profile
Upload broken with small files
« Reply #17 on: July 04, 2007, 11:44:30 PM »
i see you are testing on 127.0.0.1
what if you try over a network? (LAN or internet)
No difference.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Upload broken with small files
« Reply #18 on: July 05, 2007, 12:37:27 AM »
anyway... this means this bug is not a reason to delay official publishing of 2.2, since it is present by all previous versions.
i hope we'll find what it is.

Offline KalleB

  • Occasional poster
  • *
  • Posts: 97
    • View Profile
Upload broken with small files
« Reply #19 on: July 05, 2007, 08:37:40 AM »
The problem persists here on other PC with HFS B111 with default settings and firefox..

Uploading small txt-files randomly gets stuck at 99% or "receiving". Only difference is that in this machine the files upload completely when "Uploading small_test_file_X.txt" appears...does not seem to need that "Fully uploaded" notification.

Offline MarkV

  • Tireless poster
  • ****
  • Posts: 746
    • View Profile
Upload broken with small files
« Reply #20 on: July 05, 2007, 06:02:39 PM »
version 2.0 is 2 years old
i wonder why only now people came with this problem  :-\

Maybe because Mikkisoft has been sending us broken 'updates' for the TCP/IP stack? Just guessing...
http://worldipv6launch.org - The world is different now.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Upload broken with small files
« Reply #21 on: July 06, 2007, 11:17:10 AM »
nice try ...
kalleb, what service pack is installed on your win2000 ?
and can you try enabling: log what -> disconnection
and see who is actually breaking the connection. if no "by server" is specified, then it is the client.


Offline KalleB

  • Occasional poster
  • *
  • Posts: 97
    • View Profile
Upload broken with small files
« Reply #22 on: July 06, 2007, 01:01:05 PM »
Um, I have WinXP SP2 with all the latest updates..on both my machines ..never have had Win2k.

Using Firefox and latest HFS 111 I made HFS log almost everything and this is what I got:

Code: [Select]
15:35:08 10.100.4.47:1799 Connected
15:35:08 10.100.4.47:1799 Got 407 bytes
15:35:08 10.100.4.47:1799 Requested GET /NewFolder/
15:35:08 10.100.4.47:1799 Request dump
15:35:08 10.100.4.47:1799 Sent 1049 bytes
15:35:08 10.100.4.47:1799 Served 1,02 KB
15:35:17 10.100.4.47:1799 Requested GET /NewFolder/~upload
15:35:17 10.100.4.47:1799 Request dump
15:35:17 10.100.4.47:1799 Sent 1279 bytes
15:35:17 10.100.4.47:1799 Served 1,30 KB
15:35:17 10.100.4.47:1799 Got 733 bytes
15:35:26 10.100.4.47:1799 Uploading small_test_file_1.txt
15:35:26 10.100.4.47:1799 Fully uploaded -  428 B @ 8 KB/s
15:35:26 10.100.4.47:1799 Uploading small_test_file_2.txt
15:35:26 10.100.4.47:1799 Fully uploaded -  1,72 KB @ 176 KB/s
15:35:26 10.100.4.47:1799 Uploading small_test_file_3.txt
15:35:26 10.100.4.47:1799 Got 1172 bytes
15:36:26 10.100.4.47:1799 Disconnected by server: inactivity - 4976 bytes sent
15:36:26 10.100.4.47:1821 Connected
15:36:26 10.100.4.47:1821 Got 453 bytes
15:36:26 10.100.4.47:1821 Uploading small_test_file_1.txt
15:36:26 10.100.4.47:1821 Fully uploaded -  428 B @ 21 KB/s
15:36:26 10.100.4.47:1821 Uploading small_test_file_2.txt
15:36:26 10.100.4.47:1821 Fully uploaded -  1,72 KB @ 58 KB/s
15:36:26 10.100.4.47:1821 Uploading small_test_file_3.txt
15:36:26 10.100.4.47:1821 Fully uploaded -  5,53 KB @ 283 KB/s
15:36:26 10.100.4.47:1821 Requested POST /NewFolder/
15:36:26 10.100.4.47:1821 Request dump
15:36:26 10.100.4.47:1821 Sent 1026 bytes
15:36:26 10.100.4.47:1821 Served 1,00 KB
15:36:26 10.100.4.47:1821 Disconnected by server - 2413 bytes sent
15:36:26 10.100.4.47:1822 Connected
15:36:26 10.100.4.47:1822 Got 407 bytes
15:36:26 10.100.4.47:1822 Sent 809 bytes
15:36:26 10.100.4.47:1822 Disconnected by server - 809 bytes sent
15:36:26 10.100.4.47:1823 Connected
15:36:26 10.100.4.47:1823 Got 407 bytes
15:36:26 10.100.4.47:1823 Sent 809 bytes
15:36:26 10.100.4.47:1823 Disconnected by server - 809 bytes sent


The uploading got stuck "receiving" on the third file again...it was there for a minute and then all of a sudden uploaded all three files again and showed the OK notifications. So now I had those uploded files duplicated:

Offline KalleB

  • Occasional poster
  • *
  • Posts: 97
    • View Profile
Upload broken with small files
« Reply #23 on: July 06, 2007, 01:13:55 PM »
Tested second time with the same setup:

Code: [Select]
16:08:00 10.100.4.47:2457 Requested GET /NewFolder/
16:08:00 10.100.4.47:2457 Sent 1201 bytes
16:08:00 10.100.4.47:2457 Served 1,03 KB
16:08:00 10.100.4.47:2457 Got 363 bytes
16:08:01 10.100.4.47:2457 Requested GET /NewFolder/~upload
16:08:01 10.100.4.47:2457 Sent 2331 bytes
16:08:01 10.100.4.47:2457 Got 370 bytes
16:08:01 10.100.4.47:2457 Served 1,30 KB
16:08:01 10.100.4.47:2473 Connected
16:08:01 10.100.4.47:2473 Got 370 bytes
16:08:01 10.100.4.47:2474 Connected
16:08:01 10.100.4.47:2474 Got 370 bytes
16:08:07 10.100.4.47:2457 Uploading small_test_file_1.txt
16:08:07 10.100.4.47:2457 Got 7430 bytes
16:08:07 10.100.4.47:2457 Fully uploaded -  2,14 KB @ 43 KB/s
16:08:07 10.100.4.47:2457 Uploading small_test_file_3.txt
16:09:02 10.100.4.47:2473 Disconnected by server: inactivity - 623 bytes sent
16:09:02 10.100.4.47:2474 Disconnected by server: inactivity - 111 bytes sent
16:09:08 10.100.4.47:2457 Disconnected by server: inactivity - 5448 bytes sent
16:09:08 10.100.4.47:2491 Connected
16:09:08 10.100.4.47:2491 Got 453 bytes
16:09:08 10.100.4.47:2491 Uploading small_test_file_1.txt
16:09:08 10.100.4.47:2491 Fully uploaded -  428 B @ 20 KB/s
16:09:08 10.100.4.47:2491 Uploading small_test_file_2.txt
16:09:08 10.100.4.47:2491 Fully uploaded -  1,72 KB @ 88 KB/s
16:09:08 10.100.4.47:2491 Uploading small_test_file_3.txt
16:10:08 10.100.4.47:2491 Disconnected by server: inactivity

HFS received the first one and got stuck on the third (skipped second) file. Then after a minute it uploaded all three again successfully...but this time no OK notifications..only white screen in Firefox.

Edit: Out of curiosity, I also tested with small (>1kB) binary files and got about the same results as so far with text files.

Edit2: Same thing with a bit bigger (~10kB) files...

Edit3: Big (~1MB) files still upload is a split second without any problems:

Code: [Select]
16:25:53 10.100.4.47:2804 Connected
16:25:53 10.100.4.47:2804 Got 407 bytes
16:25:53 10.100.4.47:2804 Requested GET /NewFolder/
16:25:53 10.100.4.47:2804 Sent 1051 bytes
16:25:53 10.100.4.47:2804 Served 1,03 KB
16:25:54 10.100.4.47:2804 Requested GET /NewFolder/~upload
16:25:54 10.100.4.47:2804 Sent 1279 bytes
16:25:54 10.100.4.47:2804 Served 1,30 KB
16:25:54 10.100.4.47:2804 Got 733 bytes
16:26:04 10.100.4.47:2804 Uploading big_binary_file_1.pdf
16:26:04 10.100.4.47:2804 Got 8236 bytes
16:26:04 10.100.4.47:2804 Fully uploaded -  1,33 MB @ 11642 KB/s
16:26:04 10.100.4.47:2804 Uploading big_binary_file_2.pdf
16:26:04 10.100.4.47:2804 Fully uploaded -  1,81 MB @ 10566 KB/s
16:26:04 10.100.4.47:2804 Uploading big_binary_file_3.pdf
16:26:04 10.100.4.47:2804 Fully uploaded -  1,98 MB @ 9397 KB/s
16:26:04 10.100.4.47:2804 Requested POST /NewFolder/
16:26:04 10.100.4.47:2804 Sent 2650 bytes
16:26:04 10.100.4.47:2804 Served 1,00 KB
16:26:05 10.100.4.47:2804 Disconnected by server - 7396 bytes sent
16:26:05 10.100.4.47:2809 Connected
16:26:05 10.100.4.47:2809 Got 407 bytes
16:26:05 10.100.4.47:2809 Sent 809 bytes
16:26:05 10.100.4.47:2809 Disconnected by server - 809 bytes sent
16:26:05 10.100.4.47:2810 Connected
16:26:05 10.100.4.47:2810 Got 407 bytes
16:26:05 10.100.4.47:2810 Sent 809 bytes
16:26:05 10.100.4.47:2810 Disconnected by server - 809 bytes sent


So this obviously seems to be a size related issue...
« Last Edit: July 06, 2007, 01:33:46 PM by KalleB »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Upload broken with small files
« Reply #24 on: July 06, 2007, 05:25:22 PM »
hmm, the point is: i tried with 3byte files, and got no problem :(
do you have a sniffer, so you could send me a dump of the whole traffic? you can use even smaller files, to make it easy to read.
you find many free sniffers on snapfiles.
« Last Edit: July 06, 2007, 05:43:58 PM by rejetto »

Offline KalleB

  • Occasional poster
  • *
  • Posts: 97
    • View Profile
Upload broken with small files
« Reply #25 on: July 07, 2007, 06:24:08 PM »
I tried with 3 byte files and got pretty much the same results as so far... sent you the sniff via gmail.

Offline MarkV

  • Tireless poster
  • ****
  • Posts: 746
    • View Profile
Upload broken with small files
« Reply #26 on: July 07, 2007, 06:38:30 PM »
rejetto you should split the topic as this problems is with later builds also.
http://worldipv6launch.org - The world is different now.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Upload broken with small files
« Reply #27 on: July 07, 2007, 06:40:34 PM »
as far as they say, it's with every version since 2.0

Offline Foggy

  • Tireless poster
  • ****
  • Posts: 806
    • View Profile
Re: Upload broken with small files
« Reply #28 on: July 08, 2007, 08:01:53 AM »
I dont quite understand what the problem is. Is it where uploads to HFS get broken? Sorry but im a little thick, just askin so that i may try and reproduce it.

Offline KalleB

  • Occasional poster
  • *
  • Posts: 97
    • View Profile
Re: Upload broken with small files
« Reply #29 on: July 08, 2007, 08:46:05 AM »
Basically uploading small files (0,001-10 kB) does not work. Try uploading three of these files and only first and second one might upload... normally only the first one. Sometimes (on my other PC) HFS even uploads the files twice so that first round gets stuck on some file, but then all of a sudden all three upload again successfully. This has to be an OS related issue since the results vary a bit on different machines.
« Last Edit: July 08, 2007, 08:51:44 AM by KalleB »