Author Topic: Upload broken with small files  (Read 21393 times)

0 Members and 1 Guest are viewing this topic.

Offline Wasserfloh

  • Occasional poster
  • *
  • Posts: 81
    • View Profile
Upload broken with small files
« on: May 31, 2007, 07:08:13 PM »
Problems with the Upload

I have here again and again problems with the uupload of files on HFS. The browser waits then up to the timeout for answer of the server. Sometimes the files are correctly uploaded. Often the files are however also incomplete and with the upload of several files are missing which and the files are partly joined.
 
The problem arises with the most different files and both locally and over the InterNet.

OS: Win2k
Browser: Opera 9.2x, FF 2.0.0.3
HFS: 2.1d build 88, 2.2 build 100, 2.2 build 101, default template, default preferences, vitual file system only upload folder

The Logs is inserted as attachments. When inserting as code a server error prevents the post.

Log1
The Upload in line 4 and 5 were actually 2 files. I do not exclude an error of the browser Opera here however.

Log2
Here Opera up to timeout waited for an answer of the server. Both files were completely transferred. More did not come in the log.
 
Log3
Opera hung also here again and waited for answer of the server. Were 3 files, about which both first were completely high-loaded and added together. Third is missing completely.

Log4
That was not an allegedly successful attempt with FF however 013vi.jpg is 120.79 KB largely. Here again 2 files were joined. That is no Opera problem thus probably nevertheless.
 
Result: The Upload is here nearly useless. Only if with the Upload only RAR-, ZIP- and TAR archives and executable files (* exe) were involved, gabs so far no problems.

[attachment deleted by admin]

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Upload broken with small files
« Reply #1 on: June 24, 2007, 03:24:30 PM »
Log1
The Upload in line 4 and 5 were actually 2 files. I do not exclude an error of the browser Opera here however.

> 4:  22:20:13 127.0.0.1:1444 Uploading Mailansicht.png
> 5:  22:20:24 127.0.0.1:1444 Fully uploaded -  145,88 MB @ 13043 KB/s

you mean that this was not a 145MB png fle, but actually 2 files?

Quote
Log4
That was not an allegedly successful attempt with FF however 013vi.jpg is 120.79 KB largely. Here again 2 files were joined. That is no Opera problem thus probably nevertheless.

joined?

anyway.... i studied the upload code, and found no apparent problem. i can speculate about it not handling the upload if a disconnection is issued in the while, so i made a little change that may solve this.

Offline Wasserfloh

  • Occasional poster
  • *
  • Posts: 81
    • View Profile
Upload broken with small files
« Reply #2 on: June 26, 2007, 05:32:28 PM »
Log1
 The Upload in line 4 and 5 were actually 2 files. I do not exclude an error of the browser Opera here however.
 

 > 4:  22:20:13 127.0.0.1:1444 Uploading Mailansicht.png
 > 5:  22:20:24 127.0.0.1:1444 Fully uploaded -  145,88 MB @ 13043 KB/s
 
 you mean that this was not a 145MB png fle, but actually 2 files?
yes
 
 
Quote
Log4
 That was not an allegedly successful attempt with FF however 013vi.jpg is 120.79 KB largely. Here again 2 files were joined. That is no Opera problem thus probably nevertheless.
 

 joined?
yes
 
 
anyway.... i studied the upload code, and found no apparent problem. i can speculate about it not handling the upload if a disconnection is issued in the while, so i made a little change that may solve this.
We want to hope that that solves the problem.
 
 Unfortunately I can reproduce it also only on a computer with Win2k. With Windows 98 on another this problem does not arise. Further Windows installations do not stand for me to the test for order. I am afraid that also because of the Windows installation is. Only which causes the problem? I use neither a on-acces virus scan still another personal firewall or the other data traffic filtering software. Router could the problem to cause?

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Upload broken with small files
« Reply #3 on: June 27, 2007, 01:05:59 AM »
it's so strange i can't imagine anything

anyway, try the new build and see

Offline Wasserfloh

  • Occasional poster
  • *
  • Posts: 81
    • View Profile
Upload broken with small files
« Reply #4 on: June 28, 2007, 11:38:24 AM »
anyway, try the new build and see
Unfortunately no change.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Upload broken with small files
« Reply #5 on: June 28, 2007, 11:45:15 AM »
what build did you test?

Offline Wasserfloh

  • Occasional poster
  • *
  • Posts: 81
    • View Profile
Upload broken with small files
« Reply #6 on: June 29, 2007, 11:55:50 AM »
Build 107 and Build 108
« Last Edit: June 29, 2007, 12:18:29 PM by Wasserfloh »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Upload broken with small files
« Reply #7 on: July 02, 2007, 10:29:42 PM »
another user is experiencing your problem.
i was not able to reproduce it yet.
it may be related to some option. can you please furnish your options? menu -> other options -> show customized options
« Last Edit: July 02, 2007, 10:35:21 PM by rejetto »

Offline Wasserfloh

  • Occasional poster
  • *
  • Posts: 81
    • View Profile
Upload broken with small files
« Reply #8 on: July 03, 2007, 03:09:15 PM »
Code: [Select]
window-max=yes
default: no

easy=no
default: yes

log-date=yes
default: no

log-server-start=yes
default: no

log-server-stop=yes
default: no

log-connections=yes
default: no

log-disconnections=yes
default: no

log-replies=yes
default: no

log-progress=yes
default: no

log-banned=yes
default: no

custom-ip=192.168.30.20;127.0.0.1
default:

listen-on=127.0.0.1
default:

dynamic-dns-updater=......
default:

search-better-ip=no
default: yes

auto-save-vfs=yes
default: no

use-comment-as-realm=no
default: yes

modal-options=no
default: yes

rename-partial-uploads=%name%_part
default:

recursive-listing=no
default: yes

list-protected-items=yes
default: no

enable-no-default=yes
default: no

browse-localhost=no
default: yes

last-update-check=39229,0324770949
default: 0

speed-limit=8
default: -1

max-ips-downloading=4
default: 0

max-connections=64
default: 0

max-connections-by-ip=8
default: 0

max-contemporary-dls=4
default: 0

max-contemporary-dls-ip=1
default: 0

connections-timeout=180
default: 60

no-reply-ban=yes
default: no

last-file-open=N:\Programme\HFS\VFS\test.vfs
default:

reload-on-startup=no
default: yes

only-1-instance=no
default: yes

mime-types=*.htm;*.html|text/html|*.jpg;*.jpeg;*.jpe|image/jpeg|*.gif|image/gif|*.png|image/png|*.bmp|image/bmp|*.ico|image/x-icon|*.mpeg;*.mpg;*.mpe|video/mpeg|*.avi|video/x-msvideo|*.txt|text/plain|*.css|text/css|*.zip|application/zip|*.rar|application/x-rar-compressed|*.7z|application/x-7z-compressed|*menu*.ini|application/x-opera-configuration-menu|*toolbar*.ini|application/x-opera-configuration-toolbar|*keybord*.ini|application/x-opera-configuration-keyboard|*.mp3|audio/mpeg|*.torrent|application/x-bittorrent
default: *.htm;*.html|text/html|*.jpg;*.jpeg;*.jpe|image/jpeg|*.gif|image/gif|*.png|image/png|*.bmp|image/bmp|*.ico|image/x-icon|*.mpeg;*.mpg;*.mpe|video/mpeg|*.avi|video/x-msvideo|*.txt|text/plain|*.css|text/css

address2name=joerg|192.168.22.71|Validom|212.162.14.235
default:

recents=N:\Programme\HFS\VFS\test.vfs;N:\Programme\HFS\VFS\hfs.vfs;N:\Programme\HFS\VFS\00000002.vfs;N:\Programme\HFS\VFS\0000000000000001.vfs;N:\Programme\HFS\VFS\0000000000000002.vfs
default:

ips-ever-connected=127.0.0.1;87.188.224.192;91.5.223.223;87.188.207.76;87.188.216.254;212.162.14.235;192.168.30.20
default:

leave-disconnected-connections=yes
default: no

tray-instead-of-quit=yes
default: no

use-iso-date-format=yes
default: no

number-files-on-upload=no
default: yes

out-total=11942152
default: 0

in-total=212472822
default: 0

hits-total=273
default: 0

upload-total=66
default: 0

many-items-warning=no
default: yes

connections-columns=IP;179|Filename;180|Status;180|Speed;60|Time left;55|%;371|
default: IP;120|Filename;180|Status;180|Speed;60|Time left;55|%;50|

update-daily=no
default: yes

tester-updates=yes
default: no

copy-url-on-addition=no
default: yes

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Upload broken with small files
« Reply #9 on: July 03, 2007, 04:09:43 PM »
shit, i used your settings and still it works perfectly here :(

the last chance i see, is for you to determine in exactly which build the problem was introduced, so i can study the changes.
all builds are available at www.rejetto.com/temp/hfsXXX.exe
i would be grateful if you find the time to do this, and will be happy to try to fix it.
« Last Edit: July 04, 2007, 11:30:11 AM by rejetto »

Offline Wasserfloh

  • Occasional poster
  • *
  • Posts: 81
    • View Profile
Upload broken with small files
« Reply #10 on: July 03, 2007, 05:36:04 PM »
the last chance i see, is for you to determine in exactly which build the problem was introduced, so i can study the changes.
The problem arises at least since Build 088. I have older Builds only briefly, but uses without Upload.

all builds are available at www.rejetto.com/test/hfsXXX.exe
Everything? No, only the test versions. In addition the www.rejetto.com/temp/hfsXXX.exe would have to be called.

i would be grateful if you find the time to do this, and will be happy to try to fix it.
Thus it looks probably bad. I do not know, how I am to otherwise still help. All Builds starting from 088 has here the problem. Both under Windows 98 and 2000 with different Browsern. On another computer with Win98 I cannot reconstruct that also.

Offline KalleB

  • Occasional poster
  • *
  • Posts: 97
    • View Profile
Upload broken with small files
« Reply #11 on: July 03, 2007, 10:25:34 PM »
Let me try to help you with this.

My settings are:
Code: [Select]
easy=no
default: yes

port=8900
default:

log-font-name=Trebuchet MS
default:

log-font-size=8
default: 0

confirm-exit=yes
default: no

dynamic-dns-updater=......
default:

search-better-ip=no
default: yes

start-minimized=yes
default: no

files-stay-flagged-for-minutes=900
default: 0

auto-save-vfs=yes
default: no

modal-options=no
default: yes

delete-partial-uploads=yes
default: no

auto-save-vfs-every=3600
default: 0

last-update-check=39215,5131065509
default: 0

tray-shows=connections
default: downloads

tray-message=%url%\nLatauksia: %downloads%\nPyyntöjä: %hits%
default: %ip%\nUptime: %uptime%\nDownloads: %downloads%

speed-limit=800,1
default: -1

max-contemporary-dls=15
default: 0

max-contemporary-dls-ip=7
default: 0

open-in-browser=*.htm;*.html;*.jpg;*.jpeg;*.gif;*.png;*.txt;*.swf
default: *.htm;*.html;*.jpg;*.jpeg;*.gif;*.png;*.txt;*.swf;*.svg

graph-rate=100
default: 10

last-file-open=C:\Program Files\HFS\hfs.vfs
default:

mime-types=*.htm;*.html|text/html|*.jpg;*.jpeg;*.jpe|image/jpeg|*.gif|image/gif|*.png|image/png|*.bmp|image/bmp|*.ico|image/x-icon|*.mpeg;*.mpg;*.mpe|video/mpeg|*.avi|video/x-msvideo|*.txt|text/plain
default: *.htm;*.html|text/html|*.jpg;*.jpeg;*.jpe|image/jpeg|*.gif|image/gif|*.png|image/png|*.bmp|image/bmp|*.ico|image/x-icon|*.mpeg;*.mpg;*.mpe|video/mpeg|*.avi|video/x-msvideo|*.txt|text/plain|*.css|text/css

icon-masks=*.!ut|10001||
default:

min-disk-space=500
default: 0

out-total=396186180
default: 0

in-total=335991
default: 0

upload-total=1
default: 0

many-items-warning=no
default: yes

connections-columns=IP;170|Filename;209|Status;170|Speed;80|Time left;55|%;313|
default: IP;120|Filename;180|Status;180|Speed;60|Time left;55|%;50|

update-daily=no
default: yes

copy-url-on-addition=no
default: yes

This is my log when I try to upload 3 small txt files for the first time:
Code: [Select]
1:13:09 127.0.0.1:1945 Uploading small_test_file_1.txt
1:13:10 127.0.0.1:1945 Fully uploaded -  1,16 KB @ 37 KB/s
1:13:10 127.0.0.1:1945 Uploading small_test_file_2.txt

And this is what I experience:
Code: [Select]
- First file uploads is a sec
- Second file uploads until 99% and gets stuck there
- Stuck there for about a minute, then disappear
- Opera displays error that the page is not available

When I try second time after this I get this log:
Code: [Select]
1:19:26 127.0.0.1:2062 Uploading small_test_file_1.txt
1:19:26 127.0.0.1:2062 Fully uploaded -  1,16 KB @ 74 KB/s
1:19:26 127.0.0.1:2062 Uploading small_test_file_2.txt
1:19:26 127.0.0.1:2062 Fully uploaded -  647 B @ 20 KB/s
1:19:26 127.0.0.1:2062 Uploading small_test_file_3.txt

And this is what I experience:
Code: [Select]
- First file uploads is a sec
- Second file uploads is a sec
- At connections I see "receiving" for the third file but no percentage bar
- Stuck there for about a minute, then disappear
- Opera displays error that the page is not available

Third time is even more funnier:
Code: [Select]
1:21:42 127.0.0.1:2100 Uploading small_test_file_1.txt
1:21:42 127.0.0.1:2100 Fully uploaded -  1,16 KB @ 74 KB/s
1:21:42 127.0.0.1:2100 Uploading small_test_file_2.txt

And this is what I experience:
Code: [Select]
- First file uploads is a sec
- Second file is somehow skipped (!)
- Third file uploads until 99% and gets stuck there (!!!)
- Stuck there for about a minute, then disappear
- Opera displays error that the page is not available

Fourth time exactly the same as third, but I don't want to wait the minute so I cancel upload and try fifth time: All files SUCCEED!

Code: [Select]
1:23:48 127.0.0.1:2152 Uploading small_test_file_1.txt
1:23:48 127.0.0.1:2152 Fully uploaded -  1,16 KB @ 79 KB/s
1:23:48 127.0.0.1:2152 Uploading small_test_file_2.txt
1:23:48 127.0.0.1:2152 Fully uploaded -  647 B @ 40 KB/s
1:23:48 127.0.0.1:2152 Uploading small_test_file_3.txt
1:23:48 127.0.0.1:2152 Fully uploaded -  2,25 KB @ 153 KB/s
1:23:48 127.0.0.1:2152 Requested POST /folder/

Weird thing I'd say...Tomorrow I'll test on other machine and browser.

Here's an image what my upload folder looks like after all this:
« Last Edit: July 03, 2007, 10:45:11 PM by KalleB »

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Upload broken with small files
« Reply #12 on: July 04, 2007, 11:35:15 AM »
the last chance i see, is for you to determine in exactly which build the problem was introduced, so i can study the changes.
The problem arises at least since Build 088. I have older Builds only briefly, but uses without Upload.

so, can you confirm that upload in build #087 works?

Quote
all builds are available at www.rejetto.com/test/hfsXXX.exe
Everything? No, only the test versions. In addition the www.rejetto.com/temp/hfsXXX.exe would have to be called.

you're right, sorry

Offline Wasserfloh

  • Occasional poster
  • *
  • Posts: 81
    • View Profile
Upload broken with small files
« Reply #13 on: July 04, 2007, 08:05:08 PM »
The problem arises at least since Build 088. I have older Builds only briefly, but uses without Upload.
so, can you confirm that upload in build #087 works?
In the meantime I tested the also following Builds: #067, #072, #083, #084 and #085. Everywhere there is the problem. That will be in Build #087 probably not different.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Upload broken with small files
« Reply #14 on: July 04, 2007, 10:00:40 PM »
thank you.
can you test 2.0b ? www.rejetto.com/files/hfs/hfs2.0b.zip

can i also ask you how did you set the default options for the test? the best way is to hold the SHIFT key while HFS starts. but this way you will loose your settings if you do not backup before.
« Last Edit: July 04, 2007, 10:02:43 PM by rejetto »