Author Topic: %protected%  (Read 2483 times)

0 Members and 1 Guest are viewing this topic.

Offline maverick

  • Tireless poster
  • ****
  • Posts: 1052
  • Computer Solutions
    • View Profile
%protected%
« on: April 09, 2007, 05:19:54 PM »
+ new template symbol: %protected% expands to [protected] when a file/folder is not public   

This doesn't work correctly if a folder has restrict access set to @anonymous.  The lock is shown in error for both folder & files.  Introduced in build 091 and the same in 092.
maverick

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Re: %protected%
« Reply #1 on: April 10, 2007, 06:52:33 PM »
i'm unable to reproduce the bug in 092.
can you tell me?
try with a clean VFS.

Offline maverick

  • Tireless poster
  • ****
  • Posts: 1052
  • Computer Solutions
    • View Profile
Re: %protected%
« Reply #2 on: April 10, 2007, 07:19:26 PM »
Quote from: rejetto
i'm unable to reproduce the bug in 092.
can you tell me?

It doesn't matter - real or virtual folders.  If you restrict folder access to @anonymous *and* another user(s), the lock shows up in error for both folders and files.

I also noticed problems with the lock showing up in error after a user logs in with login button even though the user has been given access to the folders (~login - tested locally).  Also see here where another user experienced the same problem -> http://www.rejetto.com/forum/index.php?PHPSESSID=8492f7b61271dd6f321e848848ba8767&topic=4371.msg1022975#msg1022975
« Last Edit: April 11, 2007, 10:46:30 AM by maverick »
maverick

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12953
    • View Profile
Re: %protected%
« Reply #3 on: April 26, 2007, 01:56:14 AM »
try 093

Offline maverick

  • Tireless poster
  • ****
  • Posts: 1052
  • Computer Solutions
    • View Profile
Re: %protected%
« Reply #4 on: April 29, 2007, 02:08:33 AM »
Thanks.  Appears to be working. :)
maverick