rejetto forum

HFS v2.1 b16 - Encoding Problem

xiehb · 15 · 4498

0 Members and 1 Guest are viewing this topic.

Offline xiehb

  • Occasional poster
  • *
    • Posts: 1
    • View Profile
2.1b16 does be a nice version,but it cannot display Chinese charaters correctly.
2.0a has no problem with Chinese charaters display.I hope rejetto can fix it in the latest beta version.
Thanks.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13307
    • View Profile
you should provide much more information if you want to fix it, because i'm not chinese.
e.g.: WHERE are those characters? on the browser or on the hfs window? are they filenames? etc


wentens

  • Guest
2.1b16 does be a nice version,but it cannot display Chinese charaters correctly.
2.0a has no problem with Chinese charaters display.I hope rejetto can fix it in the latest beta version.
Thanks.



me too.
up.   

In 2.1b  It cannot display Simple Chinese , But in 2.0, it can.

Thank you.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13307
    • View Profile

Offline gjfmlj

  • Occasional poster
  • *
    • Posts: 6
    • View Profile
only on the browser error! Watch attachments

[attachment deleted by admin]
« Last Edit: December 08, 2006, 03:34:19 AM by gjfmlj »


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13307
    • View Profile
i watched attachments. can you describe the problem with some detail?


Offline gjfmlj

  • Occasional poster
  • *
    • Posts: 6
    • View Profile
2.1a and 2.1b all have this problem. but v2.0 show well


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13307
    • View Profile


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13307
    • View Profile

Offline gjfmlj

  • Occasional poster
  • *
    • Posts: 6
    • View Profile

Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13307
    • View Profile
ok, this new screenshot show the problem.

(expert mode)
menu
edit html template
edit or remove the 4th line

Code: [Select]
<meta http-equiv='content-type' content='text/html; charset=iso-8859-1'>

as you can see it reports a charset incompatible with your language


Offline gjfmlj

  • Occasional poster
  • *
    • Posts: 6
    • View Profile
just I chang code to GB2312 in Maxthon, so that's Ok

[attachment deleted by admin]


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13307
    • View Profile
good, anyway this is a problem that will be fixed in the future