rejetto forum

~login

0 Members and 1 Guest are viewing this topic.

Offline maverick

  • Tireless poster
  • ****
    • Posts: 1052
  • Computer Solutions
    • View Profile
At present, ~login uses only http with a resulting url shown as http://......

Would it be possible for ~login to also recognize https with a resulting url shown as https://...... if commanded to do so? ???
« Last Edit: August 30, 2006, 06:26:13 AM by maverick »
maverick


Offline ~GeeS~

  • Tireless poster
  • ****
    • Posts: 270
  • "The web was made for sharing..."
    • View Profile
Have a look at the proxomitron logs in http://www.rejetto.com/forum/index.php?topic=3682.0
I think HFS is behaving correctly on the 302 redirect with ~login. Behind Stunnel it talks http only and redirects to http correctly. HFS does not know that there is Stunnel. And Stunnel behaves imho also correct, because it doesnt know whether the redirect is http on purpose. So it does what it is told.
But maybe you (we) can nicely ask Rejetto to make an option to switch the redirect to https:// for the ~login redirect when HFS is serving behind Stunnel, by forcing header "Location: https://..."
Tried to find some clues in the source code 2.0a, but i'm missing the experience to draw conclusions.
But still then i'm not sure whether this will work.
Or let Proxomitron do the job by filtering and modifying the outgoing header, but i didn't try it yet.
~GeeS~


Offline maverick

  • Tireless poster
  • ****
    • Posts: 1052
  • Computer Solutions
    • View Profile

But maybe you (we) can nicely ask Rejetto to make an option to switch the redirect to https:// for the ~login redirect when HFS is serving behind Stunnel, by forcing header "Location: https://..."

That's what I meant in my post above when I said "if commanded to do so".

rejetto, we are asking you nicely to please think about such a option to switch the ~login redirect to https://.... when commanded to do so.  It sure would solve a lot of problems.  ;)
maverick


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13310
    • View Profile
i will pay attention at this requirement.
it is connected to the IE login bug.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13310
    • View Profile
check new beta, it shoud be fixed now


Offline maverick

  • Tireless poster
  • ****
    • Posts: 1052
  • Computer Solutions
    • View Profile

Thanks rejetto.  I will check it out.  8)
maverick


Offline ~GeeS~

  • Tireless poster
  • ****
    • Posts: 270
  • "The web was made for sharing..."
    • View Profile
Works flawlessly with IE ! Thx Rejetto for your coding and time
~GeeS~


SamePaul

  • Guest
I've found simple workaround by replacing [login-link]
<a href="https://%host%/~login" class=button><img src="/~img27" /> LOGIN</a>

Note HTTPS at the beginning. Works just fine