Author Topic: HFS 2.1 beta 14 bugs - slowdown, save on exit, ghost header  (Read 2884 times)

0 Members and 1 Guest are viewing this topic.

Offline rawbanana

  • Occasional poster
  • *
  • Posts: 11
    • View Profile
Slowdown when browsing HFS?

I don't know why but when I open up HFS 2.1 beta 14, it tends to hang for about 5 seconds every 5 seconds. It runs fine in the background but if I have it open on the desktop and bring my mouse over anything, it starts the 5 second hang cycle.

It always comes out of the hang but its annoying. The hang also slows down my computer and affects other windows... It doesn't always hang much if I have just rebooted my computer but if I leave it on a couple days, its definately goes through the hang cycle...


I was also wondering if this is a bug but when I shut down my computer, HFS doesn't save the Virtual file system and new options I've selected. I have HFS set to save on exit. It only saves if I manually exit the program or press save while in HFS.


Finally, HFS tends to leave top part of the HFS window on my screen after it minimizes (the blue bar in XP). Not sure if that is HFS or just my computer. It happens on all 4 computers that I have used HFS on... Its not that annoying because if I move another window over it it goes away.


Still great program and keep up the great work!

Anonymous

  • Guest
HFS 2.1 beta 14 bugs - slowdown, save on exit, ghost header
« Reply #1 on: July 18, 2006, 08:07:43 AM »
You seem to have strange problems.  Nothing like that happens here and never did.  Maybe you have a memory issue or a conflict of some type?

Offline rawbanana

  • Occasional poster
  • *
  • Posts: 11
    • View Profile
HFS 2.1 beta 14 bugs - slowdown, save on exit, ghost header
« Reply #2 on: July 18, 2006, 09:01:03 AM »
Well rebooting my computer the slowdown/hang issue goes away as expected. I only brought that issue up because I only experience the slowdown if I have ran HFS several days(maybe a week) without rebooting and then I open up the HFS window I consistently get the slowdown.

As for the "saving my virtual file system on exit", this still doesn't seem to work. Sometimes the options save but not the Virtual File system itself. Not exactly sure what conditions affect it.

This could have something to do with my setup as I run similar programs on all of my computers. But all are decently fast 2+ghz 512+ram XPsp2...

But if no one else has this problem then it must be me... hehe

They aren't major so its no biggie either...

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: HFS 2.1 beta 14 bugs - slowdown, save on exit, ghost hea
« Reply #3 on: July 19, 2006, 02:12:23 AM »
Quote from: "rawbanana"
I don't know why but when I open up HFS 2.1 beta 14, it tends to hang for about 5 seconds every 5 seconds. It runs fine in the background but if I have it open on the desktop and bring my mouse over anything, it starts the 5 second hang cycle.

if you know how to do, investigate on it, and know what exactly is slowing down. i can advice using process explorer.

Quote
I was also wondering if this is a bug but when I shut down my computer, HFS doesn't save the Virtual file system and new options I've selected. I have HFS set to save on exit. It only saves if I manually exit the program or press save while in HFS.

HFS is programmed to detect windows shutting down, and quit gracefully.
i know this doesn't always work, but it is diffused problem. i guess there are ways of shutting down that don't allow software to behave the right way. to workaround this, a timer-ed autosave has been introduce in 2.1

Quote
Finally, HFS tends to leave top part of the HFS window on my screen after it minimizes (the blue bar in XP). Not sure if that is HFS or just my computer.

...and this happens only for HFS on your computer?

Offline rawbanana

  • Occasional poster
  • *
  • Posts: 11
    • View Profile
HFS 2.1 beta 14 bugs - slowdown, save on exit, ghost header
« Reply #4 on: July 19, 2006, 03:33:07 AM »
Most of the problems I mentioned only happen after running HFS and other programs without rebooting for several days. I just rebooted yestarday and everything is fine.

The save-on-shutdown feature does seem to be unreliable whether or not I have rebooted recently.

I will run the process explorer program you suggested next time I have slowdown problems with HFS and see if I can help pinpoint the problem.

Thanks!