rejetto forum

Works With Port But Not Without

0 Members and 1 Guest are viewing this topic.

Offline russian11

  • Occasional poster
  • *
    • Posts: 3
    • View Profile
Please Help

I can type in my web browser http://192.168.1.100:2811/ and it works fine but when I remove the port and type in http://192.168.1.100 it doesn't resolve. Obviously I also can't access it externally. My external IP is http://24.250.35.24/ which also doesn't resolve.

A little background:
I have high speed cable, so DHCP
I'm using a Linksys wireless router
I've tried adding under Application and Gaming/Port Range Forwarding: HTTP  Start: 80 End: 80 Protocol: Both IP Address: 192.168.1.100 and enabling it.

Any help would be greatly appreciated...I am stumped.


ANTS

  • Guest
You must type to port in no matter what if you want to access it.

http://192.168.1.100:2811/ will work.

http://192.168.1.100 will not work

http://24.250.35.24:2811/ will work

http://24.250.35.24/ will not work

http://localhost/ will not work

http://localhost:2811/ will work

http://127.0.0.1/ will not work

http://127.0.0.1:2811/ will work

That's just they way it is.

However, you can use a free server such as www.no-ip.com that will give you your own 'domain name' that will redirect you to your port. For example if you want the name russian11server, you can make an account on www.no-ip.com for an address like russian11server.no-ip.org that when type into a browser will take you to your server and automatically redirect you to your port.


Offline russian11

  • Occasional poster
  • *
    • Posts: 3
    • View Profile
I appreciate you taking the time to explain that to me.

There is still a problem with:
http://24.250.35.24:2811/ will work

It doesn't work so I assume its an issue with my router setting. Any idea besides:   
Under Application and Gaming/Port Range Forwarding: HTTP Start: 80 End: 80 Protocol: Both IP Address: 192.168.1.100 and enabling it.


Anonymous

  • Guest
Most ISPs block Port 80 which is used for WWW/HTTP Servers. I see you have a router. Have you opened up a port for your server to use in your router settings?

If you have trouble with that try http://www.portforward.com/
or post back here and I'll do my best to help you.


Offline russian11

  • Occasional poster
  • *
    • Posts: 3
    • View Profile
The issue appeared to be a DMZ setting in my royter:

DMZ:           
           
            DMZ Host IP Address:    192.168.1.        
 
Now i'm attempting streaming audio utilizing php. Don't suppose if anyone knows if the HFS supports php?


Anonymous

  • Guest
Quote from: "russian11"
I appreciate you taking the time to explain that to me.

There is still a problem with:
http://24.250.35.24:2811/ will work

It doesn't work so I assume its an issue with my router setting. Any idea besides:   
Under Application and Gaming/Port Range Forwarding: HTTP Start: 80 End: 80 Protocol: Both IP Address: 192.168.1.100 and enabling it.
I just tried you address above and it does work.  I got your login screen asking for name and password.  You have to connect from the internet not locally.


Anonymous

  • Guest
russian11 I'm not sure if it supports php. Maybey try it out and see what happens.

Also http://24.250.35.24:2811/ does work because I also get the login screen.


Offline RazTK

  • Occasional poster
  • *
    • Posts: 85
    • View Profile
    • http://raztk.50webs.com
I think you made your router to forward port 80 and not 2811.
This is why you can't get into your server externally.
Also, make sure you entered the correct internal IP address. (it might be changed)
In the main menu of the router configuration, click on Security -> Firewall and make sure the Block Anonymous Internet Requests box is not checked.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13308
    • View Profile
do you think no port = guess the port ?
it is not so

no port = default port = port 80


tj

  • Guest

Offline SiY11

  • Occasional poster
  • *
    • Posts: 73
    • View Profile
According to a couple people it works if you want to access your site from within your LAN you have to type http://HTTP://localhost:PortNumber <--that’s for if your on the computer that has the server on it and want to access the site. I you on another computer, iPOD, PSP, PDA in your LAN you have to type the IP your router assigned to the server computer for example mine is 192.168.2.2. And for people or you when you some ware ells in the world you would use IP 22.xx.xxx:xxxx. I hope you understand what I am trying to tell you.