rejetto forum

"Save as" dialog box appears instead of folder content

0 Members and 1 Guest are viewing this topic.

Offline Markman-B

  • Occasional poster
  • *
    • Posts: 9
    • View Profile
Yesterday I tried to access a folder on my E-partition from a remote computer.
The specific folder contains an .ini file. I have created the following filemask string
for my E drive:

\index.htm*;\default.htm*;\folder.jpg;\*.ini;\*.db

Instead of showing the content of the folder, a dialog box appeared asking if I wanted to open or to save the .ini file.

What did I do wrong? Drive E is added within HFS as a real folder.
I'm using HFS 2.3 b├Ęta build 195 icm with the RAWR Template version 0.1.1




Inverting the logic (\)
So you want to hide filetypes, instead of showing specific filetypes?
Insert a backslash \ before *.ext to achieve opposite logic with the filter, and hide the filetypes you do not want visible to users. E.g \*.db;*.ini

Retrieved from "http://www.rejetto.com/wiki/index.php/HFS:_File_masks"


Offline Wasserfloh

  • Occasional poster
  • *
    • Posts: 81
    • View Profile

Inverting the logic (\)
That is valid obviously for each occurrence of the backslash. Each further turns around the logic again.


\index.htm*;default.htm*;folder.jpg;*.ini;*.db


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13308
    • View Profile
even worst!
you can repeat the "\" inverting operator, but only at the very start of the string (quite useless most of the times).

so, all the following "\" he used in the mask, are treated as normal characters.
the Wasserfloh suggestion is correct, anyway.


Offline Markman-B

  • Occasional poster
  • *
    • Posts: 9
    • View Profile

Offline Markman-B

  • Occasional poster
  • *
    • Posts: 9
    • View Profile
Okay I made some corrections. But do I have to set the filemask for each folder, which contains an ini file (for example), or only in the parent folder?



Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13308
    • View Profile
only the parent.
if you do it on the root, it will be valid for all that's beneath.


Offline Markman-B

  • Occasional poster
  • *
    • Posts: 9
    • View Profile
Thanx Rejetto I appreciate your support. The programs become more and more advanced, so the online manual does not always gives me the answer.
It's nice to hear that the setting only has to be done for the parentfolder. I assume this also applies to the setting don't consider as download.

However...I've noticed some unexpected behaviour in a couple of subfolders for my musicfiles (double cd).
All these folders contain the file folder.jpg; the cover of the cd.  Although I made the setting don't consider as download , for these folder.jpg  files, some of them are still available for download. In single folders (without a subfolder), the setting works fine and the folder.jpg file is not available. Is this normal?




Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13308
    • View Profile
it's don't consider AS download, not FOR download :)
the point is that everything is downloaded, but for some files you want a special handling, like incrementing the total counter. For example you don't consider as download pages & icons.
i'm open to suggestions for a short but more understandable label for the feature.

To hide the files you must use the "Files filter" feature.