Author Topic: "Network Error. Request Failed" for "Menu > Updates > Check for news/updates  (Read 375 times)

0 Members and 1 Guest are viewing this topic.

Offline skb

  • Occasional poster
  • *
  • Posts: 48
    • View Profile
Not sure if this is a bug or merely my problem, but the auto checks for updates had been working fine, and then started getting errors.

As a check, I downloaded the plain HFS.exe onto a different PC on a different network, started it, and checked for updates there, and get the same error.

(Not a big issue, as I can manually update once we go past 2.3m, but I am wondering if it is down for everyone or just me)

I originally thought I broke it with changes to my security settings, but turning off the firewall doesn't make any difference.

On my "production" server, the logs show updates were working fine through June 8,
6/8/2019 11:31:19 AM               Check update: no new version

but then started failing on the next check:
6/9/2019 11:31:59 AM               Check update: failed

Are updates from within HFS working for all of you?

Thanks, Steve

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 880
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
im not experiencing the same error.

but im also getting dns issues and random network drops.

id ask you to manual check it now as there might have been a temp outage and drop in connection.
I'm only trying to help i mean no offense.
thank you for your time and patience,

Offline Mars

  • Operator
  • Tireless poster
  • *****
  • Posts: 1899
    • View Profile
The update request is made using the HTTP protocol by the program,
but the response is done in HTTPS and this is probably what should prevent proper operation.