Author Topic: Template Look Broken Some Of The Time  (Read 928 times)

0 Members and 1 Guest are viewing this topic.

Offline DJboutit

  • Occasional poster
  • *
  • Posts: 34
    • View Profile
Template Look Broken Some Of The Time
« on: February 02, 2019, 03:18:00 AM »
I have setup hfs one computer and tested by connecting with another computer templates from time to time look broken thing are just broken like 65% of the time anybody else noticed this.  I have tried with 5 different templates and the same thing some thing are just broken. 

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 870
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Re: Template Look Broken Some Of The Time
« Reply #1 on: February 02, 2019, 12:10:29 PM »
I have not.
What version of hfs are you running.
Hfs stable 2.3m

Of hfs beta 2.4
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Offline DJboutit

  • Occasional poster
  • *
  • Posts: 34
    • View Profile
Re: Template Look Broken Some Of The Time
« Reply #2 on: February 02, 2019, 09:17:08 PM »
I only use betas

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 870
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Re: Template Look Broken Some Of The Time
« Reply #3 on: February 04, 2019, 05:15:04 PM »
2.4 is messing with the jQuery witch is most likely caiseong the problem. What template are you using, I'll see what f I can setup a fix
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Offline DJboutit

  • Occasional poster
  • *
  • Posts: 34
    • View Profile
Re: Template Look Broken Some Of The Time
« Reply #4 on: February 04, 2019, 10:11:06 PM »
Does not matter which template I use

Offline LeoNeeson

  • Tireless poster
  • ****
  • Posts: 586
  • Solitario...
    • View Profile
    • twitter.com/LeoNeeson
Re: Template Look Broken Some Of The Time
« Reply #5 on: February 05, 2019, 01:14:02 AM »
Try the latest HFS v2.4 RC1 (because Beta 6 and earlier betas had a bug). If that doesn't solve the problem, we need that you post a screenshot of the 'broken' template (take a screenshot of your browser when the problem appears, and please post the image here, on the forum). At the same time, take a screenshot of the main HFS window, so we can have a look of your log, and see what is failing. Without any screenshot, it's almost impossible to help you.
HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
• I'm open to help and share any file you may need (just ask me) ;)

Offline DJboutit

  • Occasional poster
  • *
  • Posts: 34
    • View Profile
Re: Template Look Broken Some Of The Time
« Reply #6 on: February 05, 2019, 07:36:27 AM »
I here is what I am seeing a lot 2nd image I get the message from time to time

Offline LeoNeeson

  • Tireless poster
  • ****
  • Posts: 586
  • Solitario...
    • View Profile
    • twitter.com/LeoNeeson
Re: Template Look Broken Some Of The Time
« Reply #7 on: February 05, 2019, 02:03:45 PM »
Looks like your server is overloaded. How many users are currently connected when this happens?. You forgot to post a screenshot of your HFS's log, to see what's going on there. Anyway, you better wait a reply from Rejetto (currently on holidays) or another more experienced user (just be patient and keep and eye on the forum for a reply).
HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
• I'm open to help and share any file you may need (just ask me) ;)

Offline DJboutit

  • Occasional poster
  • *
  • Posts: 34
    • View Profile
Re: Template Look Broken Some Of The Time
« Reply #8 on: February 05, 2019, 10:23:14 PM »
I am the only one using it I am just testing for now

Offline LeoNeeson

  • Tireless poster
  • ****
  • Posts: 586
  • Solitario...
    • View Profile
    • twitter.com/LeoNeeson
Re: Template Look Broken Some Of The Time
« Reply #9 on: February 13, 2019, 04:54:38 AM »
Try the latest HFS v2.4 RC2 and see if that solves your problem.
HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
• I'm open to help and share any file you may need (just ask me) ;)

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Template Look Broken Some Of The Time
« Reply #10 on: February 13, 2019, 07:24:53 AM »
You should remove the limit on connections and set a limit on "download" instead

Offline DJboutit

  • Occasional poster
  • *
  • Posts: 34
    • View Profile
Re: Template Look Broken Some Of The Time
« Reply #11 on: February 14, 2019, 02:38:07 AM »
Why is the a setting for limit on connections if it breaks HFS??

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Template Look Broken Some Of The Time
« Reply #12 on: February 14, 2019, 12:25:02 PM »
it doesn't break.
It's there for additional security/control.
It's a "harder" limit, not what you want.
I understand it can be confusing, that's why i introduced a warning in the dialog. Take a second look at it.

Offline danny

  • Tireless poster
  • ****
  • Posts: 189
    • View Profile
    • Startfetch
Re: Template Look Broken Some Of The Time
« Reply #13 on: June 28, 2019, 07:51:33 AM »
Automation: Instead of forever, it is just 2 seconds, effectively auto-queue. 
Code: [Select]
[error-page]
{.if|{.match|*.php*|%url%.}|{:{.disconnect.}:}.}{.add header|Cache-Control: no-cache, max-age=0.}<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN">
<html><head><meta http-equiv="content-type" content="text/html; charset=UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1">%content%</html>

[not found]
<META HTTP-EQUIV="Refresh" CONTENT="1;URL=../"><TITLE>404</TITLE><body bgcolor="black" text="white" alink="white" link="white" vlink="white">
<center><h2><br>You have found the 404 page.</h2>Redirecting.</center></body>

[overload]
<META HTTP-EQUIV="Refresh" CONTENT="2;URL=./"><TITLE>Overload</TITLE><body bgcolor="black" text="white" alink="white" link="white" vlink="white">
<center><h2><br>High traffic mode engaged.</h2>Returning to previous page after overload has cleared.</center></body>

[max contemp downloads]
<META HTTP-EQUIV="Refresh" CONTENT="2;URL=./"><TITLE>Downloads</TITLE><body bgcolor="black" text="white" alink="white" link="white" vlink="white">
<center><h2><br>There are ongoing downloads.</h2>More available <i>after</i> current downloads finish.</center></body>

[unauthorized]
<TITLE>Login</TITLE><body bgcolor="black" text="white" alink="white" link="white" vlink="white">
<center><h2><br>Please login to your account.</h2></center><br>
<fieldset id='login'><legend> {.!Login.}</legend>
  <center>
    <input type='text' id='usr' size='20' placeholder=" Username" value=""><br>
    <input type='password' id='psw' size='20' placeholder=" Password" value=""><br>
    <input type='button' id='lognow' style="width:110px;" value="{.!Login.}" onclick="NewLogin();">
  </center>
</fieldset><br>
<script>
function NewLogin() {
  var xhr = new XMLHttpRequest();
  var ThisFolder = window.location;
  var ThisUser = document.getElementById("usr").value;
  var ThisPass = document.getElementById("psw").value;
  var LoginToken = ThisUser+':'+ThisPass;
  xhr.open("GET", "/~login", true);
  xhr.withCredentials = true;
  xhr.setRequestHeader("Authorization", 'Basic ' + btoa(LoginToken));
  xhr.onreadystatechange = function() {
    if (xhr.readyState == 4 && xhr.status == 200) {
      if (window.location.href.indexOf("~login") != -1) {
        window.location.replace('/?success');
        } else {
          window.location.replace(ThisFolder);
      };
    }
    if (xhr.readyState == 4 && xhr.status == 401) {
      alert("Invalid credentials! \(Wrong username or password\)");
    }
  }
  xhr.send();
}
</script>
</body> {.if|%user%|{:{.set|n|{.from table|#tries|%ip%.}.}{.inc|n.}{.if|{.{.^n.} > 20.}|{:{.set ini|{.no pipe|ban-list={.from table|#ini|ban-list.}%ip%#attack? {.time.}|.}.}{.set table|#tries|%ip%=0.}:}|{:{.set table|#tries|%ip%={.^n.}.}:}/if.}:}.}

[deny]
<META HTTP-EQUIV="Refresh" CONTENT="1;URL=../"><TITLE>Denied</TITLE><body bgcolor="black" text="white" alink="white" link="white" vlink="white">
<center><h1><br><br>No</h1></center></body>

[ban]
{.disconnect.}