Author Topic: HFS not able to start.  (Read 1951 times)

0 Members and 1 Guest are viewing this topic.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: HFS not able to start.
« Reply #15 on: November 03, 2018, 04:00:08 PM »
Code: [Select]
  if fileExists('hfs.lng') then
    begin
    FreeLocalizer.AutoTranslate := True;
    FreeLocalizer.LanguageFile := 'hfs.lng';
    end;

this should be enough.
wait for beta6
« Last Edit: November 03, 2018, 04:01:48 PM by rejetto »

Offline korhojoa

  • Occasional poster
  • *
  • Posts: 1
    • View Profile
Re: HFS not able to start.
« Reply #16 on: March 15, 2019, 06:00:55 PM »
Apologies for the post on a older thread. I had this issue.
A working fix (on Windows 10 1809) was to disable the "Beta: Use Unicode UTF-8 for worldwide language support" in Windows Region Settings.
(found under Region -> Administrative tab -> Language for non-Unicode programs -> Change system locale... -> Checkbox - Beta: Use Unicode UTF-8 for worldwide language support)

Follow members gave a thank to your post:


Offline LeoNeeson

  • Tireless poster
  • ****
  • Posts: 579
  • Solitario...
    • View Profile
    • twitter.com/LeoNeeson
Re: HFS not able to start.
« Reply #17 on: March 16, 2019, 06:20:54 AM »
Apologies for the post on a older thread. I had this issue.
A working fix (on Windows 10 1809) was to disable the "Beta: Use Unicode UTF-8 for worldwide language support" in Windows Region Settings.
(found under Region -> Administrative tab -> Language for non-Unicode programs -> Change system locale... -> Checkbox - Beta: Use Unicode UTF-8 for worldwide language support)
@Rejetto: Perhaps THIS article could give some 'light' to make a fix for HFS (a fix for another program is also HERE). It seems a change in Windows 10 1803 update, sets UTF-8 support for single byte character and likely breaks a lot of applications not expecting this (a simply fix could be making HFS ignore this setting?).
HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
• I'm open to help and share any file you may need (just ask me) ;)

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: HFS not able to start.
« Reply #18 on: March 17, 2019, 07:13:38 PM »
ok, thanks a lot, i've been able to reproduce the problem.
Anyway i didn't find a real solution, except from ignoring the error coming from the translation library.
This will at least allow people to run HFS.
The error is deliberate, because the library is not supporting this codepage, or at least not this version of the library.
Maybe people can decide to uncheck this Windows' setting to workaround the problem?


Offline Explorare

  • Occasional poster
  • *
  • Posts: 2
    • View Profile
Re: HFS not able to start.
« Reply #19 on: April 29, 2019, 01:46:39 PM »
Got the same error message on hfs24b1.
Windows 10 1903 (18362.53)
System Language: en-US
So I need to uncheck the UTF-8 thing right?

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 848
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Re: HFS not able to start.
« Reply #20 on: April 29, 2019, 03:50:16 PM »
@Explorare

unfortuanlely this is a windows build beta issue adn only a windows option atm is the fix. as reported form are from poster user, he was able to geta workaround via turning off the win 10 betat utf-8

Control panel > region settin > administrative tab > admin systeym chage for non -unicode > unchek box if check.
see picture

Apologies for the post on a older thread. I had this issue.
A working fix (on Windows 10 1809) was to disable the "Beta: Use Unicode UTF-8 for worldwide language support" in Windows Region Settings.
(found under Region -> Administrative tab -> Language for non-Unicode programs -> Change system locale... -> Checkbox - Beta: Use Unicode UTF-8 for worldwide language support)
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Offline Explorare

  • Occasional poster
  • *
  • Posts: 2
    • View Profile
Re: HFS not able to start.
« Reply #21 on: April 29, 2019, 03:53:55 PM »
@Explorare

unfortuanlely this is a windows build beta issue adn only a windows option atm is the fix. as reported form are from poster user, he was able to geta workaround via turning off the win 10 betat utf-8

Control panel > region settin > administrative tab > admin systeym chage for non -unicode > unchek box if check.
see picture

That fixed the problem. Thanks a lot.  :D