Author Topic: 1.6 comin...  (Read 58063 times)

0 Members and 1 Guest are viewing this topic.

Offline rejetto

  • Administrator
  • Insane programmer
  • *
  • Posts: 12837
    • View Profile
1.6 comin...
« on: December 15, 2003, 10:13:20 PM »
i am testing 1.6, and you?
www.rejetto.com/temp/hfs.zip

temporary what's new
ver: 1.6
+ LOGIN button (browsing)
+ support for external links in the VFS: File Menu -> "New link"
+ customizable 401 and 403 HTTP error pages
+ customizable ban page
+ faster page generation
+ Menu -> Other options -> "Use comment as realm"
+ Menu -> Other options -> "Login realm"
+ Menu -> Limits -> "Connection inactivity timeout"
+ Menu -> Encoding URL -> "Use UNICODE in HTML"
+ Menu -> Help -> "Introduction"
+ Menu -> Virtual File System -> "Reset hits"
+ Menu -> Virtual File System -> "Reset downloads"
+ Menu -> "Abort file addition"
+ File Menu -> Icon
+ File Menu -> Switch to virtual
+ File Menu -> "Customized realm"
+ File Menu -> Access for users -> ALL/NONE
+ Log Menu -> "Log what"
+ Log Menu -> "Log on video"
+ Connections menu -> "Kick idle connections"
+ Users -> User properties: browse protected resources by user
+ complete downloads counting
+ "Time left"
+ more XP styled
+ added Reset button in "Set user/pass" dialog
+ support for default favicon.ico (i saw Mozilla using it)
+ new HTML template symbols: %total-bytes%, %total-kbytes%, %total-size%  (size of listed files)
* connections box: merge of "IP" and "User" fields
* connections box: "Agent" and "Start time" displayed in tip
* folders known before as "autoupdated folders" are now "real folders", others (yellow) are "virtual folders"
* new "let browse" behavior
* options saved to file by default
* "reload open VFS" by default
- problems sending HTTP error pages
- problems with files with corrupted timestamp
- VFS: minor redrawing problem
- "Hide tree" was not propagating to autoupdated folders
- hits were not displayed (in tips) for folders
- it is safer now during long files addition: files are locked and you can quit the program at once
- removed a useless limit on filenames
- drag&drop was restricted to labels area
- inverted ban logic was not applyed on start (but after opening options window)
- the hidden graph was reappearing after a couple of restarts
- fixed possible DoS attack
- 4GB single file limit removed
- whole drives were unsupported
- other minor bugs

Anonymous

  • Guest
1.6 comin...
« Reply #1 on: December 16, 2003, 01:16:22 AM »
ok.thank

Zeca

  • Guest
1.6 comin...
« Reply #2 on: December 16, 2003, 03:52:38 AM »
It's missing sections of the html template

Zeca

  • Guest
1.6 comin...
« Reply #3 on: December 16, 2003, 04:04:18 AM »
The links I create are not apearing in the browser.

Anonymous

  • Guest
1.6 comin...
« Reply #4 on: December 16, 2003, 04:17:06 AM »
When I right click in 'Access to protectect resources' in user properties and the list it's empty there is an error: "Access violation at address 004CCEA1 in module 'hfs.exe'. Read off address 0000000C."

Offline rejetto

  • Administrator
  • Insane programmer
  • *
  • Posts: 12837
    • View Profile
1.6 comin...
« Reply #5 on: December 16, 2003, 05:46:08 AM »
Quote from: "Zeca"
It's missing sections of the html template

the template has changed
if you have your own customized, you have to update it or just use the default one

Offline rejetto

  • Administrator
  • Insane programmer
  • *
  • Posts: 12837
    • View Profile
1.6 comin...
« Reply #6 on: December 16, 2003, 05:56:33 AM »
Quote from: "Anonymous"
When I right click in 'Access to protectect resources' in user properties and the list it's empty there is an error: "Access violation at address 004CCEA1 in module 'hfs.exe'. Read off address 0000000C."

fixed

Offline rejetto

  • Administrator
  • Insane programmer
  • *
  • Posts: 12837
    • View Profile
1.6 comin...
« Reply #7 on: December 16, 2003, 05:56:51 AM »
Quote from: "Zeca"
The links I create are not apearing in the browser.

it does to me
please report how to reproduce the bug

Offline Gobble

  • Experienced poster
  • ***
  • Posts: 55
    • View Profile
1.6 comin...
« Reply #8 on: December 16, 2003, 06:13:57 AM »
+ LOGIN button (browsing)

Does this mean a login button on the main page?

Zeca

  • Guest
1.6 comin...
« Reply #9 on: December 16, 2003, 08:30:26 AM »
I have found the problem.  :idea:
I used this version of hfs.exe in an empty folder. When I start it, the default html template that is used is not the same as the default html template that apears when I press the default button.
That is why i could not see the links, the login button, and the other things.

Offline rejetto

  • Administrator
  • Insane programmer
  • *
  • Posts: 12837
    • View Profile
1.6 comin...
« Reply #10 on: December 16, 2003, 08:46:19 PM »
Quote from: "Gobble"
+ LOGIN button (browsing)
Does this mean a login button on the main page?

yes

Offline rejetto

  • Administrator
  • Insane programmer
  • *
  • Posts: 12837
    • View Profile
1.6 comin...
« Reply #11 on: December 16, 2003, 08:49:11 PM »
Quote from: "Zeca"
I have found the problem.  :idea:
I used this version of hfs.exe in an empty folder. When I start it, the default html template that is used is not the same as the default html template that apears when I press the default button.
That is why i could not see the links, the login button, and the other things.

the template is also saved in the registry (if you don't specify to save options on file)

you had the template saved in the registry, that's it

i guess i should put a warning on the template window, about not be using the default one

Zeca

  • Guest
1.6 comin...
« Reply #12 on: December 17, 2003, 08:20:09 AM »
Got it

I agree with your sugestion.
I could be something in the html window name.
Ex:

HTML template - default
HTML template - c:\hfs\hfs.tpl
HTML template - HKEY_................

Anonymous

  • Guest
Access for Users on a New Link
« Reply #13 on: December 17, 2003, 10:49:16 AM »
You can set 'Access for Users' on a new link. Should that be possible?

TheEtron

  • Guest
Re: Access for Users on a New Link
« Reply #14 on: December 18, 2003, 01:19:33 AM »
Quote from: "TheEtron"
You can set 'Access for Users' on a new link. Should that be possible?

I tried it once more, but it works fine. No problem.


One other thing:

After loggin in, can there be a logout button? The sessoin will remain open if you have a browser open. I think there should be a logout button as well.  ;)

Regards,
The Etron