rejetto forum

Deleted Settings File

0 Members and 1 Guest are viewing this topic.

Offline zigzagman

  • Occasional poster
  • *
    • Posts: 4
    • View Profile
Hi

I don't know if this is a bug with HFS, but i use hotkeys to run programs and do other various tasks in windows and i want HFS to be started via a hotkey. I tried adding a simple LUA script into the hotkeys section of a handy app called StrokesPlus. The problem is when trying to activate HFS via a hotkey, HFS will start but the settings file (ini) gets deleted before it opens up

Maybe StrokePlus has the problem ? Here is the LUA script code. Works fine with all other apps though, so i'm figuring the problem is in HFS

acShellExecute("open", "D:\\Programs\\Internet\\HTTP File Server v2.3i\\hfs.exe")

My hotkey is set as modifier CTRL + SHIFT + key Z


Offline LeoNeeson

  • Tireless poster
  • ****
    • Posts: 712
  • Status: On hiatus (sporadically here)
    • View Profile
    • twitter.com/LeoNeeson
Hi, and welcome! :)

1) If you manually start HFS, does it work fine?...
2) Try to run HFS from a folder without spaces in folder's name.
Example: C:\Server\HFS.exe (instead of C:\My super server\Program\HFS.exe)

Sometimes things gets broken if a folder has spaces.
By the way, what operating system are you using?

StrokesPlus is new for me. I'll install it, and try to reproduce your error (if I have time this weekend). Anyway, perhaps other forum members can help you more, with another ideas.

Good luck! ;)
Leo.-
HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
» Currently taking a break, until HFS v2.4 get his stable version.


Offline zigzagman

  • Occasional poster
  • *
    • Posts: 4
    • View Profile
HI Leo

HFS starts properly when manually started and i have never had an issue with it
I have tested without spaces in the foldername and the problem persists

Right now i am using an old xp machine. The problem happens on my win7 machine too


Offline zigzagman

  • Occasional poster
  • *
    • Posts: 4
    • View Profile
Some further testing makes me change the description of the problem a little bit

What happens is HFS starts with no settings. The ini file exists but as soon as the program is closed, it gets deleted. Either way the problem remains


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 901
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Hi

I don't know if this is a bug with HFS, but i use hotkeys to run programs and do other various tasks in windows and i want HFS to be started via a hotkey. I tried adding a simple LUA script into the hotkeys section of a handy app called StrokesPlus. The problem is when trying to activate HFS via a hotkey, HFS will start but the settings file (ini) gets deleted before it opens up

Maybe StrokePlus has the problem ? Here is the LUA script code. Works fine with all other apps though, so i'm figuring the problem is in HFS

acShellExecute("open", "D:\\Programs\\Internet\\HTTP File Server v2.3i\\hfs.exe")

My hotkey is set as modifier CTRL + SHIFT + key Z

actual becasue it in quots, the exe fiel in folder space should work, i wouldrecomend saving your ini file to a different location and put in thte script to lauch form that ini file see this web link for more info:
https://www.autoitscript.com/forum/topic/154473-shellexecute-run-exe-including-an-ini-file/

example:
Code: [Select]
"C:\Webroot\hfs.exe" -ini:"C:\Webroot\templates\theIniFile.ini
Files i try to keep and share can be found on my google drive:

https://drive.google.com/drive/folders/1FOWi3Gqaldld6JLXvZ-biDv4RSguf0IC


Offline zigzagman

  • Occasional poster
  • *
    • Posts: 4
    • View Profile
Hi bmartino

I tried what you suggested with the alternate settings file (which is actually -a or -i not -ini) and it half works. HFS always starts with the option to add a context menu entry to explorer, which i don't want, then continues normally, but only once. If i close it and try it again, the problem comes back

Anyway, it was suggested to me to try another set of modifier keys and it works !! yaaaaay no more problem. I guess there is a bug somewhere in StrokesPlus or something

Thanks for the help anyway fellas


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13294
    • View Profile
welcome!
your problem is that HFS clears settings when you start it holding the SHIFT key.
you should be fine if you use a different hotkey, without shift.


Offline Fysack

  • Tireless poster
  • ****
    • Posts: 644
  • present picture
    • View Profile
    • Admin

Following members gave a thank to your post:
GOD CAN READ YOUR MIND