Author Topic: "Error: bad session" when creating folders in 2.3f  (Read 1282 times)

0 Members and 1 Guest are viewing this topic.

Offline mrnmrsi.fl

  • Occasional poster
  • *
  • Posts: 2
    • View Profile
"Error: bad session" when creating folders in 2.3f
« on: September 28, 2015, 02:14:38 PM »
Updated to 2.3f over the weekend, and now seeing the "Error: bad session" message whenever I try to create or rename a folder or move a file.  It looks like any operation having to do with the use of the modal overlay box is failing.  Tried both Chrome and IE, cleared all browser cache and cookies and restarted browsers, same message.  Uploading individual files works perfectly and archiving works as well (saw that on another bug post).  Never got this error while using 2.3e.

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 870
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Re: "Error: bad session" when creating folders in 2.3f
« Reply #1 on: October 02, 2015, 12:11:07 AM »
that's strange indeed...

what happen if you download a fresh copy of 2.3 f and re added file and try that HFS, do you still get the "bad" session

i've only seen the "bad" session error when there was a problem with HFS and making a cookie file....

there a post on the forum that had a fix for it...

try adding this to a different template tab inside a folder and go to that path, or the path they made "bad session...."

{.cookie|signedup|value=yes|expires=+10|path=/.}

http://www.rejetto.com/forum/bug-reports/cookies-dont-work/msg1054789/#msg1054789

also tak a look at this forum post:
http://www.rejetto.com/forum/html-templates/troubleshooting-hfs-cookie-issues-on-rename-in-the-default-template/
« Last Edit: October 02, 2015, 12:16:02 AM by bmartino1 »
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Offline mrnmrsi.fl

  • Occasional poster
  • *
  • Posts: 2
    • View Profile
Re: "Error: bad session" when creating folders in 2.3f
« Reply #2 on: October 02, 2015, 04:49:08 AM »
Rolled back to 2.3e, and it's working fine again.  Then, I updated again, and this time, it was fine at first.  But after clearing the HFS cookies, the error came back.  It looks like it's creating different cookies based on the version.  There's a cookie named 'HFS_SID' generated by 2.3e and one named 'HFS_SID_' by 2.3f.  As long as the first cookie is there, it's fine, but it writes the HFS_SID_ cookie and then refuses to locate it.

So then I decided to reset the template, and that appears to have solved the issue with recognizing the new cookie name (HFS_SID_).  I'm guessing changes made to the template for 2.3f didn't carry over when I upgraded for some reason, and I don't remember editing it, but maybe I did.  The clean install would also have solved it (and I was going to do that next).

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: "Error: bad session" when creating folders in 2.3f
« Reply #3 on: October 17, 2015, 06:32:32 PM »
ah, yes, i didn't think of this possible side-effect when renaming the cookie :(
i will see if i can find a workaround