Author Topic: Deconfiguring template  (Read 6711 times)

0 Members and 1 Guest are viewing this topic.

Offline sergio

  • Occasional poster
  • *
  • Posts: 28
    • View Profile
Deconfiguring template
« on: July 11, 2014, 03:39:19 PM »
Hi,
(I do not speak english, I translate by google)

Version hfs 2.3a build 289

my server is configured with html page (home page)
when entering my server are the links to the different folders created
when clicking any link which redirects you to the folders
format  is dropped (Annex image)

How I can fix this?

with the previous version did not happen this

Thanks.

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 870
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Re: Deconfiguring template
« Reply #1 on: July 12, 2014, 03:24:50 AM »
Hello, Serigo

It is my belief that your "home page" is trying to receive resources that it doesn't have access too.

For example:

---html code that is wrong: (it works only on the local machine!)

Take this sample template random download form the internet!
(http://www.quackit.com/goto/?t=/html/templates/download/bryantsmith/slickred.zip)

-------------
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="stylesheet" type="text/css" href="style.css" />
<title>SlickRed | florida web design</title>
</head>

<body>
<div id="container">
      <div id="header">
           <h1>Slick<span class="off">Red</span></h1>
            <h2>A template by Bryant Smith</h2>
        </div>   
       
        <div id="menu">
           <ul>
               <li class="menuitem"><a href="#">Home</a></li>
                <li class="menuitem"><a href="#">About</a></li>
                <li class="menuitem"><a href="#">Products</a></li>
                <li class="menuitem"><a href="#">Services</a></li>
                <li class="menuitem"><a href="#">Design</a></li>
              <li class="menuitem"><a href="#">Contact</a></li>
            </ul>
        </div>
       
        <div id="leftmenu">

        <div id="leftmenu_top"></div>

            <div id="leftmenu_main">   
               
                <h3>Links</h3>
                       
                <ul>
                    <li><a href="#">SEO</a></li>
                    <li><a href="#">PHP</a></li>
                    <li><a href="#">Ajax</a></li>
                    <li><a href="#">jQuery</a></li>
                    <li><a href="#">Web design</a></li>
                    <li><a href="#">Web Programming</a></li>
                    <li><a href="#">Content Creation</a></li>
                    <li><a href="#">Internet Marketing</a></li>
                    <li><a href="#">XHTML Templates</a></li>
                </ul>
</div>
               
               
              <div id="leftmenu_bottom"></div>
        </div>
       
       
       
       
      <div id="content">
       
       
        <div id="content_top"></div>
        <div id="content_main">
           <h2>You may use this template in any manner you like. All I ask is that you leave the link back to my site at the bottom of the page. </h2>
           <p>&nbsp;</p>
              <p>&nbsp;</p>
            <h3>Template Notes</h3>
            <p> Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.</p>
           <p>&nbsp;</p>
<h3>More information</h3>
           <p> Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.</p>
            <p>&nbsp;</p>
           <h3>Template Notes</h3>
            <p> Lorem ipsum dolor sit amet, consectetur adipisicing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.</p>
          <p></p>
<p>&nbsp;</p>
        </div>
        <div id="content_bottom"></div>
           
            <div id="footer"><h3><a href="http://www.bryantsmith.com">florida web design</a></h3></div>
      </div>
   </div>
</body>
</html>
--------------

If you were to paste this html code into hfs, you wouldn't be able to laod any resources such as pictures and other html resources!

To fix this, you must (!Add the needed resources to your HFS!) and put your Public ip address / DNS host name (http://www.ipchicken.com/)

To correct the above html it would be like so:
(as marked by the yellow above!)
You would have to add the "slickred" folder tot he root of your HFS!
-------
"style.css"
changes to:
"http://xxx.xxx.xxx.xxx/slickred/style.css"

To use this template you would also have to open the "styles.css" file and add the hfs path to it!

---------------------
---------------------

Now that the example is out of the way, we now need to fix your template issue!

In your html, you will need to look for:
*css
*jpg / png (picture files)

have them added to a path in your HFS and copy your ip html info to add/change your current html code you are using.

-------------------
-------------------
Good luck! :)
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Offline sergio

  • Occasional poster
  • *
  • Posts: 28
    • View Profile
Re: Deconfiguring template
« Reply #2 on: July 12, 2014, 06:09:48 PM »
Many thanks bmartino1 for your answer.

I make pages with dreamweaver, my knowledge is very basic html
css, javascrip and others, I have no knowledge


This is a simple example, and the only thing I add to this code was:
<link rel="stylesheet" type="text/css" href="http://myip/style.css" /> (and the problem continues)

the rest did dreamweaver.

Quote
Now that the example is out of the way, we now need to fix your template issue!

In your html, you will need to look for:
*css
*jpg / png (picture files)

have them added to a path in your HFS and copy your ip html info to add/change your current html code you are using.

This part I do not understand (but for this simple example, I think it is not necessary?)




<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="stylesheet" type="text/css" href="http://myip/style.css" /> (I added this line to the code according to your explanation)
<title>Documento sin título</title>
</head>

<body>
<a href="http://myip/INGLES/">INGLES
</a>
</body>
</html>

another adjustment should be made?


Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 870
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Re: Deconfiguring template
« Reply #3 on: July 13, 2014, 02:43:53 PM »
no, i don't think it is an issue with your html code!...

After you have it good and ready in dreamweaver, have you tested it via opening the page in a webrowser by double clicking the *.html file itself?

or did you bring it to hfs?


----Then if that is all said and done, we might need to look at your "port forwarding"/IP access:
so:
are you using your public ip example (555.555.555.555)

or

your computer "DHCP" lan ip example (192.168.1.5)

???
-------------------------------------------------------------------------------
-------------------------------------------------------------------------------

and how are you accesing the html page???

the same machine HFS is runining?

or a public host spot that is not connected to your current internet connecting(same internet connection that the hfs machine is on??

---------------------------------------------------------------------------------
*NOTE: Also, if you are trying to connect to your website from "within you routers network via the public iP, it will not load!

If you go to a different place/Public hotpots/ Library and go to you public IP / DNS host name, it should/will be working!

-----------------------------------------

see this post if your need help getting your resources:
ie: your css files/templates...

http://www.rejetto.com/forum/bug-reports/opening-more-than-1-episode-of-hfs-does-not-accept-change-of-template/msg1059234/#msg1059234

post back if you are still experiencing issues
« Last Edit: July 13, 2014, 02:58:59 PM by bmartino1 »
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 870
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Re: Deconfiguring template
« Reply #4 on: July 13, 2014, 02:52:47 PM »
Many thanks bmartino1 for your answer.

I make pages with dreamweaver, my knowledge is very basic html
css, javascrip and others, I have no knowledge


This is a simple example, and the only thing I add to this code was:
<link rel="stylesheet" type="text/css" href="http://myip/style.css" /> (and the problem continues)

the rest did dreamweaver.

This part I do not understand (but for this simple example, I think it is not necessary?)




<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="stylesheet" type="text/css" href="http://myip/style.css" /> (I added this line to the code according to your explanation)
<title>Documento sin título</title>
</head>

<body>
<a href="http://myip/INGLES/">INGLES
</a>
</body>
</html>

another adjustment should be made?

You only need that line if you are going to uses a html css file which loads various "adjustments" to  html...

css help:
http://www.w3schools.com/css/

html help:
http://www.w3schools.com/html/default.asp
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 870
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Re: Deconfiguring template
« Reply #5 on: July 13, 2014, 03:06:19 PM »
Hi,
(I do not speak english, I translate by google)

Version hfs 2.3a build 289

my server is configured with html page (home page)
when entering my server are the links to the different folders created
when clicking any link which redirects you to the folders
format  is dropped (Annex image)

How I can fix this?

with the previous version did not happen this

Thanks.

Are you using a "rarw template"?

If so, sometimes after updating, you have to "change the template and re-added the rarw template file.

the page int he screen shot is the orginal/default hfs template...

and/or you might need to put your html cod into the "root"(/) of HFS
see picture:
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Offline sergio

  • Occasional poster
  • *
  • Posts: 28
    • View Profile
Re: Deconfiguring template
« Reply #6 on: July 13, 2014, 09:48:24 PM »
thanks again, bmartino1

with others templates, no presents problems
the problem is only with this template (hfs 2.3a)

if not attached my html to hfs, the template is displayed very well
but to attach my html to hfs,   the template is displayed very bad

the problem continues

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 870
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Re: Deconfiguring template
« Reply #7 on: July 14, 2014, 12:41:44 PM »
then you might need to "Publish" the website in dreamwaever:

http://support.godaddy.com/help/article/7811/publishing-your-website-with-dreamweaver-cs6

Other than that, i'm lost and don't think i'm able to help you any further. sorry :(

good luck and have fun! :)
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Offline sergio

  • Occasional poster
  • *
  • Posts: 28
    • View Profile
Re: Deconfiguring template
« Reply #8 on: July 14, 2014, 03:54:48 PM »
Thanks, bmartino1

I will continue investigating.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Deconfiguring template
« Reply #9 on: August 11, 2014, 11:47:01 AM »
what do you mean by "configured with html page" ?

anyway, press F12 and you will find useful information about your error, like missing files. As bmartino1 said, all clues are pointing to a missing file.
Consider linking your server here if the content is not private, so that we can give more help.

Offline sergio

  • Occasional poster
  • *
  • Posts: 28
    • View Profile
Re: Deconfiguring template
« Reply #10 on: August 11, 2014, 07:09:59 PM »
Thanks rejetto for your reply.

I refer to the following:

I no add my page web to hfs===Template is very good

I add my page web to hfs===Template is very bad

Add Video: "hfs_video.wmv"
https://mega.co.nz/#!V4RzWCyQ!4dWvUxce5nLAxv2xKgbAGk4vYXKU7LchwXD49w4wi-8

Offline bmartino1

  • Tireless poster
  • ****
  • Posts: 870
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
Re: Deconfiguring template
« Reply #11 on: August 12, 2014, 09:48:29 PM »
ok, thank you for making a video, iu see the problme now...

That is how the web browsers cashes the page...

it is sometimes a problem with hfs default template due to your secreen being a "wide screen"

what is your curent desktop resolution???
at a guess i would say (1920 × 1080)
http://en.wikipedia.org/wiki/Display_resolution

what has happened is that the default hfs template doesn't define where the items look and will look.
so when you go to that page the browser read the cashe and the tpl file in order...

it a fairly easy fix... rejeto would be of beter help as it is hfs default template
but you need to apply a "HTML Layouts"
http://www.w3schools.com/html/html_layout.asp
I'm only trying to help i mean no offense.
thank you for your time and patience,
Bmartino1

Offline sergio

  • Occasional poster
  • *
  • Posts: 28
    • View Profile
Re: Deconfiguring template
« Reply #12 on: August 13, 2014, 12:10:39 AM »
Thanks bmartino1 for your reply.

My desktop resolution is (1440 X 900)

I make pages with dreamweaver, my knowledge is very basic html.

for this case would not know how to make the adjustment.

Offline rejetto

  • Administrator
  • Tireless poster
  • *
  • Posts: 12949
    • View Profile
Re: Deconfiguring template
« Reply #13 on: August 24, 2014, 07:05:06 PM »
what i saw in the video is of little help.
consider the advices i gave you in my previous post.

Offline sergio

  • Occasional poster
  • *
  • Posts: 28
    • View Profile
Re: Deconfiguring template
« Reply #14 on: August 26, 2014, 03:26:02 PM »
what i saw in the video is of little help.
consider the advices i gave you in my previous post.

PM sent.