rejetto forum

If password on file, download stops

Liza784 · 14 · 4058

0 Members and 1 Guest are viewing this topic.

Offline Liza784

  • Occasional poster
  • *
    • Posts: 6
    • View Profile
Users can Login and all the protected files that are hidden from them become available.

But they can't download, as soon as the download starts, it ends.

If I enable the password in the URL (in settings), the download is ok, but the filename is blank on the download client.

If I remove the password, then all is ok and the download begins.


Offline LeoNeeson

  • Tireless poster
  • ****
    • Posts: 719
  • Status: On hiatus (sporadically here)
    • View Profile
    • twitter.com/LeoNeeson
Mmmm... try clearing your browser's cache, and try again.
That may solve your problem. :)
HFS in Spanish (HFS en Español) / How to compile HFS (Tutorial)
» Currently taking a break, until HFS v2.4 get his stable version.


Offline Liza784

  • Occasional poster
  • *
    • Posts: 6
    • View Profile
This is definetely a bug.

A lot of my peers can't download if password is set on files.

Not only me.


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 901
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
It sounds like you set access rights for users to your hidden folder and or other flags...

see pictures...

As you can see i have 3 folders that i'm severing...

templates (which is hidden)
a secure uplaod folder
a secure test folder...

If i do some funky things with the flags and permission i get your issues, in which i have found that i need to "start over"... to fix.

Solutions:
Re-download the latest build.

(preset up you website for easy of access..IE setup a structured folder {c:\webroot\hfs.exe} c:webroot\realfolder1...etc...)

Before adding a anything to hfs:
(if your are using a template, add it now as i recomend Live template 3.0, there are better ones out there and others...)

The very first thing you should do is: (Create Accounts) via opening the accounts page and create your users...

Now add the real folders that you wish to share (helps is there are structured in the paths IE setup a structured folder {c:\webroot\hfs.exe} c:webroot\realfolder1...etc...)...

Now wee setup flags/hidden folders:
if the folder is hidden , but need to be accessed for file! set these flags:
see picture

(*note: even if a client has the path to the hidden folder, if you don't set any html templates, it will default to the next folder up, in my case, root/ my home page...)

if you don't want any one to be able to download it
check the "no download option"

if you want a user to be able to access it once in a while, you will have to add that folder again...(either change its name or etc...) revistit this post..: http://www.rejetto.com/forum/hfs-~-http-file-server/no-download-11246/msg1058499/#msg1058499

i believe it is a http file permissions/flags issues on your end...

You should never have to send the passwords to connect/download!...

Files i try to keep and share can be found on my google drive:

https://drive.google.com/drive/folders/1FOWi3Gqaldld6JLXvZ-biDv4RSguf0IC


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 901
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
This is definetely a bug.

A lot of my peers can't download if password is set on files.

Not only me.

yes you an put passwords on files, but you shouldn't.. passwords should be on folders entering into the files......
Files i try to keep and share can be found on my google drive:

https://drive.google.com/drive/folders/1FOWi3Gqaldld6JLXvZ-biDv4RSguf0IC


Offline Liza784

  • Occasional poster
  • *
    • Posts: 6
    • View Profile
Is anyone actually trying to reproduce this ?

I'm not setting a password on file.

I want multiple people to access their folders. So I have set the "hidden" tag for folders until people login.

Everything works nicely from the viewing side, I can even put image web galleries that work.

But if they try to download a "zip" file inside those folders, it doesn't work. I tried putting the file, putting the folder, creating acounts, or not, etc.

nothing works.

I also started from scratch.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13304
    • View Profile
Liza, since many people are using these features without a problem, there must be something very specific to your case, so we'd better be detailed.

I just added a real folder,
enabled the "list protected items only for allowed users" option.
right clicked on the folder,
set access only for a specific account (with password),
open the browser,
login,
i see the folder,
enter it,
there's a zip file (47MB),
click on it,
downloaded successfully.

Try to give me your instructions to reproduce the problem. Screenshots may help.


Offline Liza784

  • Occasional poster
  • *
    • Posts: 6
    • View Profile
Whenever I do this from my PC, it works as well.

If I go to a computer outside my LAN, it doesn't work.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13304
    • View Profile
right click on the log panel, enable logging of "disconnections" and see who is disconnecting who


Offline Liza784

  • Occasional poster
  • *
    • Posts: 6
    • View Profile

Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13304
    • View Profile

Offline Liza784

  • Occasional poster
  • *
    • Posts: 6
    • View Profile
Disconnected by server:

connection rejected or something like that


Offline bmartino1

  • Tireless poster
  • ****
    • Posts: 901
  • I'm only trying to help i mean no offense.
    • View Profile
    • My HFS Google Drive Shared Link
liz, yes i was trying to "reproduce it" and your post/title says files...

So, Either your not saying your true issues / not taking any advise offered...

so i would sugest screen shots!

alt + Print screen
(Captures curent active windows)

open paint
ctrl+v (Paste)

Scratch out ip/file names things that you don't want us to see...

attach a post re-explaining your issues with attachments of the photos!...

As i have (said/previous posted) before i have reproduced your issues, but it was correctable via a fresh download/proper folder setup!....

Hope to hear back to help if you show wish....  :-\
Files i try to keep and share can be found on my google drive:

https://drive.google.com/drive/folders/1FOWi3Gqaldld6JLXvZ-biDv4RSguf0IC


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13304
    • View Profile
Disconnected by server:
connection rejected or something like that

it's important to have the exact line, sorry