rejetto forum

0.9.4.17

rejetto · 87 · 39177

0 Members and 1 Guest are viewing this topic.

Anonymous

  • Guest
Quote from: "Electr0n"
Downloaded the latest buld of .17...
Executed...
When trying to exit I Have an "access violation"...
Every time after chatting with somebody...
I have XP professional...
The problem is for sure in &RQ as only today I've reinstalled windows from zero and I have still the same bug....

Electron, cannot confirm this... 0.9.4.17 works pretty fine for me... In fact, from 0.9.3.8 i haven't seen this kind of message - "Access violation..."...
Things are the same - XP Pro SP1 (activated), 4mbit/sec DSSS Broadband-modem, Look'N'Stop Firewall... no problems at all... In any time, on my machine I have at least 4 working instances of &RQ, and it works fine...
No idea what's wrong in your case... ;(


Offline Plamen

  • Occasional poster
  • *
    • Posts: 48
    • View Profile
previous two replies was mine... sorry, forgot to log in...;)


Rapid

  • Guest
I Have an "access violation" too. On XP SP2 beta 1204 & on Win2000 SP4    :cry:


Anonymous

  • Guest
do not install any betashit and everything will be fine


Offline alkimiya

  • Moderator
  • Tireless poster
  • *****
    • Posts: 315
    • View Profile
Most access violations I've encountered have been when processing (reading) corrupted history files. Once I got them fixed with some binary patching I've been free.


Offline captor

  • Occasional poster
  • *
    • Posts: 18
    • View Profile
yes, removing histiry can slove the problem of violations.


Anonymous

  • Guest
hmmm some buggy stuff
msgs are not delivered to icq2k3pro using *17 beta
any explanations why ?
/me gone installing miranda


Offline Electron

  • Occasional poster
  • *
    • Posts: 81
    • View Profile
I don't want to remove history as I use it rather often... And I also don't think that it is the solution of the problem...
My world is how I creat it.


Offline Electron

  • Occasional poster
  • *
    • Posts: 81
    • View Profile
So, Rejetto, what do you think? Why are you keepung silence?
My world is how I creat it.


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13304
    • View Profile
there may be a bug in the history.
it is very rare because i never met it.
the best solution ATM is to backup your user from time to time (i do it weekly).
it is very easy, because you just have to ZIP/RAR your UIN folder.
if a history gets corrupted, then you just have to replace it with the one in your backup.
the history file has the UIN of your contact as name.
in facts, you have 1 file for each history/contact.


Offline Electron

  • Occasional poster
  • *
    • Posts: 81
    • View Profile
And if I had not backed my UIN daily... What should I do now?
Delete all my history????
May be there's the sollution wihtout removing all the history?
And the second...
Why are you so sure that the bug is in history...???
I see this error when I'm exiting &RQ, not when reading histrory...  
But not every time... That is too strange... Only after chatting for some time... Or may be with someone special... I don't know...But the bug is very unpleasent :(
My world is how I creat it.


Offline alkimiya

  • Moderator
  • Tireless poster
  • *****
    • Posts: 315
    • View Profile

Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13304
    • View Profile
no, it was related to the bug alki was talking about

the bug would have been quickly fixed if i was able to reproduce it


Offline rejetto

  • Administrator
  • Tireless poster
  • *****
    • Posts: 13304
    • View Profile
Quote from: "Suicide"
msgs are not delivered to icq2k3pro using *17 beta
any explanations why ?

i guess it is a problem of older versions too
i shall investigate on it


Offline Electron

  • Occasional poster
  • *
    • Posts: 81
    • View Profile
Ok, Alkimiya... Can you tell me how to know what exactly history file is corrupted?
Or may be tell me what to patch... Binary :)
My world is how I creat it.