rejetto forum

Problème d'affichage de certain icone dans les pages web [Frex]

Frex · 6 · 2531

0 Members and 1 Guest are viewing this topic.

Offline Frex

  • Occasional poster
  • *
    • Posts: 11
    • View Profile
Bonjour à tous,

J'utilise maintenant depuis plusieurs années HFS version 2.3 béta 282a.

J'avoue être pleinement satisfait de l'outil très facile à utiliser,

cela dit j'ai un petit soucis avec des icônes qui reste grisé dans l'affichage de certaines de mes pages web,
le chemin est pourtant bon <img src="/images/bannis.jpg"/> mais la page affiche ceci :



au lieu de ceci :



j'ai dé-validé tous mes antivirus mais aucun changement ?

Avez vous un conseil , merci


Offline Mars

  • Moderator
  • Tireless poster
  • *****
    • Posts: 1994
    • View Profile
en première approche, je vérifierai que /images/ apparaisse bien dans le VFS et qu'il soit en mode caché sans mot de passe et que l'image est accessible en utilisant l'url  http://......./images/bannis.jpg

edit:

j'obtiens bien une erreur - Erreur 404 - Donnée Non Trouvée -  en testant ton serveur hfs avec ton ip web mais en usant de http://........./images/erreur_404.gif j'obtiens bien l'image gif correcte
Code: [Select]
<img src="/images/erreur_404.gif"/>donc soit ton image bannis.jpg a quelque chose qui ne va pas (format) soit elle est absente :)

essaie de remplacer <img src="/images/bannis.jpg"/> par <img src="/images/erreur_404.gif"/>
pour voir si l'image continue à ne pas s'afficher

sinon le serveur fonctionne bien

Quote
Bible Technique Automobile Multimarques

- Serveur Http [Frex] -

Vous connaissez ma devise maintenant "La connaissance ne vaut que si elle est partagée !"
Now you know my motto "Knowledge is only valid if it is shared!"
« Last Edit: April 04, 2013, 10:00:28 PM by Mars »


Offline Frex

  • Occasional poster
  • *
    • Posts: 11
    • View Profile
Merci pour ta réponse, je viens de faire des essais avec d'autres images mais même résultat ?

Je ne comprends ou ça bloque, j'ai vérifié ce que tu m'as dit et les reste c'est bon ?

quand je tape le chemin direct avec http j'ai bien l'image d'affichée ?

http://......../images/bannis1.gif

Je viens de découvrir quand tapant le chemin complet <img src="http://........./images/bannis1.gif"/> ça fonctionne ?
« Last Edit: April 05, 2013, 12:50:08 PM by Mars »


Offline Mars

  • Moderator
  • Tireless poster
  • *****
    • Posts: 1994
    • View Profile
je pense comprendre d'où vient le problème

l'image est vue comme une ressource Web que hfs refuse de diffuser car l'utilisateur est banni

à l'heure actuelle seule la forme de [ban] du template peut être utilisée
une entorse est  de stocker l'image que tu souhaites utiliser sur un hébergeur d'images externe en mettant l'url dans une macro redirect

[ban]
{.redirect|http://i72.servimg.com/u/f72/15/89/52/36/bannis10.gif.}

c'est tout ce qui est possible actuellement.


Offline Frex

  • Occasional poster
  • *
    • Posts: 11
    • View Profile
Je te confirme que le lien que j'utilise pointe sur une image de mon répertoire sur ma machine , pas un lien externe ?


Offline Mars

  • Moderator
  • Tireless poster
  • *****
    • Posts: 1994
    • View Profile
Si un utilisateur est banni, il n'a plus accès aux ressources partagées sur ta machine, donc le seul moyen de personnaliser la page [ban] avec des images est de rediriger sa connexion vers une source externe comme je te l'ai indiqué plus haut  ;)
« Last Edit: April 12, 2013, 07:34:42 AM by Mars »